Chinese Mastery Path of the Spirit After Update

Same here, I’m unable to progress the chinese Mastery past this on Steam, I’ve tried multiple ways and followed peoples guides above, it doesn’t seem to give credit.


Same here, came here after trying to google solutions. I’ve tried a few times now and on my most recent attempt I tried not researching any tech at all and B lining it to the Spirit Way so that I avoided accidentally downloading a tech I needed to get from the building. I confirmed I grabbed all 4 techs on the way, the two unique archer ones, the one horseman one, and the civilian harvest upgrade.

Unsure what to try now.


I am also having the same issue. This is still bugged on PC as of the latest patch (Halloween biome patch). Can we get some communication on this please?


I am having the same issue on Steam version. Even tried the previous live in beta section, but it not working.


Not the user you’re responding to, but I’m having the same issue. Just attempted the mastery again, didn’t upgrade any special techs until Imp, built spirit way last, did the two chu ko nu upgrades, the fire lancer, and the econ one in the spirit way, no mastery.

1 Like

14.10.2023 here and im unable to finish this mastery, after 2 years!!

1 Like

We will have to be patient… a little longer
The team probably has to work a lot on the DLC which is scheduled for release, exactly in a month

@SavageEmpire566 I am experiencing the same issue.

To everyone experiencing this, should leave a log on this thread to alert them.


I have the same problem. I tried it dozent of times. Also right now.


27.10. Still doesn’t complete, lost count on how many tries

1 Like

still blocked :face_with_head_bandage:
I think we shouldn’t be very far from the next patch, this problem has been around for two months, fingers crossed

This bug appeared in August 2022. So it’s not two months but one year plus 2 months…

I’ve contacted the support and they say this:

“Currently this is a known issue, and our Team is working on a solution. Please keep checking game updates frequently for fixes.”

1 Like

deeply interesting :face_with_spiral_eyes:

Same issue here too, on console edition. I’ve tried different approaches without luck. Also I’ve checked the technology tree just in case I missed something but not.

Cross fingers that this is fixed on next update.

1 Like

Still bugged Nov 5, 2023. Stuck on this one and have definitely tried upgrading all 4 items at spirit way in multiple game styles and solo efforts

1 Like


Same problem 9th Nov. 2023.

This is a good game. I urge the team to fix it as soon as possible. Very annoying for China players.


Where did you contacted support? I thought opening a thread in this forum is the official way?

Today i was able to do the mastery, after i installed the patch with the new DLC. The description of the mastery is now broken (its the same as fighting against the hard AI), but after i went up to imperial and did all 4 technologies in the path of the spirit, i’ve got the mastery.
Can anybody else try this and confirm if it’s working as well?

1 Like

Confirmed now. The mission can be done now even though bugfix didn’t report it.