Color palette mods not working


Build #66692
Windows 11


Color palette mods do not change the color of units and buildings.

However, one distinct exception is for units that have been reskinned by another mod. For example, I run a mod for my Cataphracts that changes the gold parts of the model to a dull silver color. These Cataphract units are fully affected by my color palette mods. All unaltered units and buildings are unaffected by the color palette mods.

The attached image shows Cataphract and Centurion units together. Note that the Cataphracts are recolored by the active color palette mods and the Centurions are unaffected.


This issue occurs 100% of the time I play.


Here’s the steps to reproduce the issue:

  1. Subscribe to any color palette mod.
  2. Start any match. The colors will be unchanged.


  1. To see changed colors on reskinned units, subscribe to a unit retexture mod in addition to a color palette mod. The one I use is the Cataphract Reskin (Low-Visi) mod by vierklee.
  2. Start any match. The colors for all unaltered units and buildings will be unchanged. The colors for the reskinned unit will be changed.


All units and buildings should be colored according to the color palette mod activated.



No game files were necessary to illustrate this bug.


The devs are well aware of this by now, it’s been reported several times already.

Will it be fixed anytime soon? I’m dying here!!!


Really hoping the developers address this soon. There seems to have been a change in the file directory for AoE II DE that differs from the file path used previously for color palette mods.

It is possible to change player colors manually through the RGBA color values in the spritecolors.json file.

steamapps > common > AoE2DE > resources > _common > dat > spritecolors.json

This is merely a temporary workaround that I have found, however color palette mods are still broken.


Yeah, I’m also waiting for this fix, I really like spring colour palette mod and now it’s not working :frowning:

Follow-up to the workaround I mentioned - I wouldn’t suggest it to anyone. I found that by editing the spritecolors.json file the in-game UI can be messed up causing all button icons to appear without images.

1 Like

not sure if you’re new to mod/stuff breaking, but the usual turn around time for fixes are always next patch, means roughly around 1-2 months.

if they deem it not urgent, we might not see a fix for at least 6 months to a year, or more.

if its something plastered all over youtube by t90 or sotl it might get a hotfix within a week.

if you dont wish to wait long, theres currently a few workaround, one above editing .json and if you could get it right, it can work. the other is below with the old .smx files.

create your own graphic mod with smx files. if you have made backup of the old .smx graphic file that would work, but its sort of only feasible if its used locally and would take upwards 20GB+ if you use UHD.

1 Like

Hi @Quantum240
Thanks for the report, we are already tracking this issue :slight_smile:


Since last patch I am missing spring blue color mod, it’s not working :frowning:


Still not working.

Issue is that they are treated as data mods instead of graphic mods.

Any news on this? The Spring Color palette is still not working.


For now, you could edit “AoE2DE/resources/_common/dat/spritecolors.json” and try the colors you like the most.

1 Like

That’s right. But, regarding mods:

I wouldn’t recommend it. It’ll mess with the other UI because of how the mods are handled. Best just wait for a fix.

I’m still waiting for that fix. It’s been broken since September last year.

1 Like

Just wanted to dogpile on this report, would be really cool to have these mods working again

1 Like

Any idea on when this might be fixed? It’s been several months now. I appreciate any updates you may have on this! Thanks!

Hi @Quantum240
Unfortunately I can’t provide an ETA, it depends on the priority the issue has.

That’s understandable. Hopefully it will get fixed eventually! Thank you!

1 Like

Still no fix and no proper solution on how to make color palette mods work again, very sad.