D3D11 Error responsible for very frequent crashing in game

:arrow_forward: GAME INFORMATION

  • PLATFORM: Steam
  • OS: Windows 10

:arrow_forward: ISSUE EXPERIENCED

:question: *DESCRIBE THE ISSUE IN DETAIL (below).

Game screen goes black randomly and gives only the following message after completely crashing

image

It says to check my drivers to make sure they are updated, here is a screenshot of geforce experience proving I have updated drivers downloaded on October 7th 2020:

image

:arrow_forward: FREQUENCY OF ISSUE

Once every 2-3 games in both single and multiplayer (Frequently)

:arrow_forward: REPRODUCTION STEPS

Reproduction is only possible through playing the game, there is no obvious connection as to what is crashing the game specifically. It is happening during matches though, not during time spent in menus.

7 Likes

Hi ChicDinosaur31,
Could you try to run the game in DirectX12, maybe this is causing your crashes!

Hope this helps! :slight_smile:

Yours Truly,
MainAkkount

Hi there, I looked online and it said that I might have to do Windows Update to update my DirectX, in any case I ran dxdiag and discovered in my system information that my directx version is directx 12

image

It turned out I did need some windows updates though so I’ll restart and update them and see if that helps at all.

If I’m not going down the right path tell me, because I’m not sure if there is a steam option for running a game in directx 12 you wanted me to find.

3 Likes

Hi ChicDinosaur31

Yeah, I checked, there doesn’t seem to be an option in-game.
I thought D3D11 referred to DirectX11, but maybe it didn’t.
Updating Windows is probably a smart idea if this doesn’t help I’d want you to try this:

Step 1: Right-click Age of Empires III: Definitive Edition and select Properties.
image

Step 2: Go to the Local Files tab and Verify Integrity of Game Files.

If that doesn’t work, you can try to reinstall the game. I know that this sucks, especially if you don’t have fast internet speeds.
I hope I have helped you out! :slight_smile:

Yours Truly,
MainAkkount

image
I verified integrity of cache and it didn’t detect any missing files. I updated windows though so if it happens again I will reinstall and see if that works. If that fails I’ll come back here and see if there are any more suggestions, thanks.

3 Likes

No problem dude, just here to help out! :smiley:
I really hope it works now, nothing worse than a game that crashes, without a way to fix am I right?

I just came back to say I just had that crash again. I think the game itself just crashes a lot and there is nothing I can do about it :frowning:

2 Likes

Hi ChicDinosaur31

That sucks, I shall spend some time to see if I can figure out what the D3D11 crash is all about, hopefully, I can learn enough to solve it for you. Can’t promise anything, but the least I can do is try right? :smiley:

Yours Truly,
MainAkkount

1 Like

@ChicDinosaur31
I may have found something:

D3D11 Error Fix

ERROR
A D3D11 Error has occurred and the game is forced to terminate. Verify your graphics drivers are up to date. (HRESULT: -2005270523)

Drivers:
First, make sure you have installed the latest GPU drivers. If you have the latest drivers, then I suggest you reinstall them and make sure you do a clean installation. This should fix the error.

Another reason for the D3D11 Error could be that you are playing the game on a laptop with a dedicated GPU and the game isn’t switching to the dedicated GPU. This can be easily fixed.

If reinstalling the drivers doesn’t work than it might be that the game is trying to run itself on the Intel Integrated graphics. I think you can imagine that this isn’t a great idea, so we can try to do what is suggested below:

Suggested Fix
For Nvidia GPUs, open Nvidia Control Panel > Manage 3D Settings > Program Settings > select the game > select “High-performance Nvidia processor” under preferred graphics option.

Yours Truly,
MainAkkount

1 Like

image

AHa! It was like you said it was running on integrated.

I’ve now changed it to high-performance NVIDIA processor.

It’s really weird that it would choose integrated because none of my other game programs are defaulting to integrated.

In any case, I hope and pray that this is the solution. Wish me luck. I’ll post again if I get a crash.

2 Likes

welp, it’s the same case that happened with AoE2 DE, during the entire first months, there was a bug and crash fest

Hi ChicDinosaur31,

Glad I could help you fix it!
If you could mark the solution as the solution so others will be able to quickly see how to fix the issue :slight_smile: I hope you have lots of fun playing again!

Yours Truly,
MainAkkount

Unfortunately I just crashed again on the Francis Drake mission. Same D3D11 error, changing integrated graphics was NOT the solution

2 Likes

Darn it, I’m all out of ideas :frowning:

I also see this crash. I am running it on a desktop machine with an RTX 2070, so it’s not a GPU issue. I believe it’s a bug in the game.

3 Likes

For some reason personally for me i have been Experiencing crashes on Steam version vs possibly windows also?

in Act 2 Bring Down the Mountain I always crash with no errors from start to 5min in. the game just gives up for me.

kinda wonder if it’s a bug same that just on certain thing causing it

2 Likes

I’m going to try reinstalling now, I will say the Francis Drake mission crashes and gives me this error a LOT. While I can get through multiple other matches online and in single player I literally can’t get through the Francis Drake mission once. I also had a few crashes on the Barbary Pirates Algiers mission but none on the Ethiopian or Siberian conquest mission. I can’t get more than 10 minute into it without it crashing. That’s what I’m using to test if this works.

Ultimately the take-away I’m trying to give here is that my game crashes on certain scenarios and maps more than others. So it’s got to be something with the game right?

Well I just reinstalled and while I was able to get through the Francis Drake mission the game crashed upon the beginning fight of the Fort Duesquene mission. Once again it is the D3D11 error.

I think it’s safe to say reinstalling did not help. I’m all out of ideas. The game is very unstable.

1 Like

Hey all - I’m running into the same exact issue. Same error code and everything.

I have:

  • Reinstalled the game twice
  • Verified file integrity each time with no fails
  • Reinstalled the latest nvidia driver
  • Made sure Windows is up-to-date

The game crashes randomly - don’t really see any rhyme or reason to it.
I’ve only been playing multiplayer with a buddy against 2-3 computers.

I’m going to do random things like turn off VSync to see if it helps. I’m keeping tabs on this post cause it seems like the only place I can find anyone else having the same issues as I am.

2 Likes

Having the exact same error message.

There are general Regedit fixes floating on google. Which Crashes now my whole pc. Not recommending it to try.
Other games that show similar error messages are fixed by a game patch.

I can finish games by using the resolution 1080p, which looks horrible on a 1440p monitor.
Desperately trying to find a solution i went trough the steam comments only finding more people having the same d3d11 error.

As other solutions for the same error by other games was a patch i think we need to wait for hopefully a patch :frowning:

The log for google index for other people trying to find a solution :
PreGame 24934: Account Event - New State: LoggedIn, Old State: AttemptingLogIn, Last Error ID: None
1239912 00:20:39: [D3D11Manager::present] Present Failed, hresult=DXGI_ERROR_DEVICE_REMOVED, reason=DXGI_ERROR_DEVICE_REMOVED
1239972 00:20:39: [WPFG][L4,C512] Render Target CreateTexture2D failed - DXGI error: 0x887a0005