D3D11 Error responsible for very frequent crashing in game

Just chiming back in again - I played three complete rounds tonight with no crash.
Same as I’ve been playing (with a buddy on multiplayer against computers.)

I turned off VSync at the beginning of our session and it seemed to have worked. ,
Not sure if it’ll work for anybody else, but it’s worth a try if you have it on!

Unfortunately for me I disabled V-Sync already, it can’'t be this. I appreciate the suggestions though, keep them coming I’m trying everything.

1 Like

It seems to be related to the same crashes that other players are getting too. It should get fixed with the next patch. (random game crashes)

I found a workaround, by going into Nvidia Control panel and setting the max frame rate of my AOE 3 DE to 60 fps it stop all the crashes I was having. I can finally play the campaign without neurotically having to save every minute.

If anyone has this problem follow the instructions in the link above and you should see a stable gaming experience.

1 Like

nothing u do is gonna fix the crashes because in multiplayer everyone crash at the same time this is not something that we have to fix


I m having same issue on my nvidia GeForce 2070 super . No solution worked.

I’m having the same issues and none of the above solutions work.

not even developers know how to solve it


Still crashing even after most recent update.

I’ve managed to stop my game crashing!
I capped the fps on AOE 3 DE to 60fps in Nvidia control panel and disabled " g-sync " on my monitor.

Not sure why that’s causing the game to crash but I managed to play for over 90 minutes once I disabled g sync/capped the fps to 60

Hope this helps someone

I capped it to 60fps awhile ago and it helped with the campaign crashes but I started having crashes again. I’ll disable Gsync too and see if I get any more problems

I have bumped this thread for a friend who is still having this issue.

1 Like

I’ve tried underclocking my PC with MSI Afterburner to have some success. It doesn’t stop the crashing entirely but now I’m positive when I’m entering a game that I will have a 90% chance to complete it.

I underclock my core clock by -26 and underclock my memory by -100

Maybe this will help your friend.

A friend of mine had this issue and changed his resolution setting in game to a lower resolution and hasnt had the issue since then. Not sure how/why this worked for him tho.

Same question.I can only play AOE3:DE on my laptop now,my desktop is gtx980

Laptop is 1050ti.And when i’m playing Mount&Blade Warband which also has this issue

Two of my friends and I are now getting this error for the first time(none of us has had it previously) while playing the new African Civs and maps. I’ve not been able to finish a single game yet, crashes out with this sort of error every single time. Would say after half an hour or so it crashes out. Never at the start of a game.

I have verified the game files and reinstalled my graphics driver with no improvement. My friend found he had an update for his drivers, installed it, but did not improve things.

Initially, it was happening randomly to one of us, but it hit all three of us simultaneously in the last game.

I hope this is somewhat helpful in fixing things. Keen to play the new civs but hard to do so when the game crashes out every time.

1 Like

I am having same problems. I played 3 games and I am forced to go desktop.

I always have this error at Atlas map. There is something at this map.

1 Like

Same with me. Attempted 3 treaty games on this map and it crashed everytime.