D3D11 Error responsible for very frequent crashing in game

Just had the error for the first time:

A D3D11 Error has occurred and the game is forced to terminate. Verify your graphics drivers are up to date. (HRESULT:-2147024809), The parameter is incorrect.

Never had it before the African Royals DLC


Whats your grafics card?

That’s true. I never had it before too. I uninstall the DLC and I don’t have the problem again… Yet. It’s look like the problem is on the DLC and one of the process with it, because I tried to reinstall all the game and the DLC and do that doesn’t solve the problem.

I have the same problem. After downloading “DLC The African Royals”, 30 minutes after starting the game, the game closes. My graphics card is NVIDIA GeForce GTC 1650 Ti. I’m not sure what is happening. I already tried to download the graphics of the game but it has not helped me at all. I hope they can solve this problem soon.

Hi @everyone,
We have identified issues on the African Maps: Tripolitania and Atlas that will result in the D3D11 error. If you are seeing it anywhere else, please let me know!


Me and several of my friends just got the D3D11 error on Tassili about 15 minutes ago.

1 Like

Tassili is another map that appears to have the same issue.

1 Like

Hi @VaguerMedal9858 & @CaseDuckling875, in your encounters with this issue, was the Trade Route fully upgraded at the time of the issue? That was the source of the error we found on Tripolitania.

1 Like

No, the trade route was not fully upgraded, I believe one of the routes had at least the 2nd upgrade, but not the 3rd. The game was only about 20 minutes long.

I also don’t know if this has to do with the issue, but the games I’ve had where this error occurs, the entire game leading up to the crash is super laggy and stuttery. Its very hard to even play the game.

Playing a lot, consistently getting this error. Got it on Highlands and Savannah as well. All African maps seem like they could produce it but it’s hard to say…lost like 6+ games with friends since launch kinda getting a bit burnt out from it happening so often. It seems like more people = more chance to crash, obviously though since that makes sense. Sometimes it crashes the whole lobby too.

Hey sorry been kind of busy lately and the weaker AI made pretty much give up on the game

My GPU is Radeon RX 580
I am currently on the Windows 11 insider program btw

tbf so far it only happened once

PS: I just love your profile pic


1 Like

yeah got the issue on Tripolitana map, but then played another match and it was fine

I M USING RTX 2070 super AS well and my game keep crashing once every 1-2 hours , cant even complete a full game of treaty , using african civ has more chance to crash tho .

Me the same. Found it when trying to play Atlas map. The game crashes everytime when starting a multiplayer game, but no problem when playing single player skirmishes.

Quite strange the problem has been found for months and still not solved.

Just try a different map (Alaska), still could not play. Never been able to play multiplayer.

The problem is due to windows, not AOE3DE. It is an issue where the machine is switching from integrated graphics to the graphics card. You fix it by going into graphics settings in Windows and adjusting the settings to only use the graphics card to run AOE3DE. You select the program and then switch it to “High Performance”. Follow the instructions in this article: https://www.howtogeek.com/351522/how-to-choose-which-gpu-a-game-uses-on-windows-10/

Already tried that, make nothing different. I updated my GPU driver, tried changing the graphics preference to High Performance both in the Windows setting and in Nvidia Control Panel. No help.

By the way, I am using Windows 11 and suspect there might be something with it; but still find no solution.

were you able to find the error?, i installed windows 11 and the game already started to have failures

1 Like

This just happened to me in a team game. Please a reconnect button!!!

We love this game, but the game doesn’t love us…