Deck builder removes the wrong card for China

:arrow_forward: GAME INFORMATION

  • BUILD #: 201.12.1840.0
  • PLATFORM: Steam
  • OS: Windows 10

:arrow_forward: ISSUE EXPERIENCED

:question: DESCRIBE THE ISSUE IN DETAIL (below). Limit to ONE issue per thread.

Here is the problem I’m experiencing…

Removing 10th Fortress age card in deck builder for China removes 9th card instead.

:arrow_forward: FREQUENCY OF ISSUE

:question: How often does the issue occur? CHOSE ONE; DELETE THE REST.

  • 100% of the time / matches I play (ALWAYS)

:arrow_forward: REPRODUCTION STEPS

:question: List the DETAILED STEPS we can take to reproduce the issue… Be descriptive!

Here’s the steps to reproduce the issue:

  1. Add 10 cards in Fortress age for China
  2. Click on the 10th card to remove it
  3. It removes the 9th card

:arrow_forward: EXPECTED RESULT

:question: What was supposed to happen if the bug you encountered were not present?

Should’ve removed the card I clicked on

:arrow_forward: ACTUAL RESULT

:question: What actually happened (what went wrong) because of the issue you’re reporting?

Removed the card before it

:arrow_forward: IMAGE & ATTACHMENTS

:question: Attach a relevant PICTURE (.jpg, .png, .gif), VIDEO (.mp4, YouTube), DXDIAG FILE (.txt), or CRASH/GAME LOGS (.aoe2record, .txt) below.

6 Likes

Actually the problem of removing wrong card happens to all civs, not only China

not sure whether it is the 9th card tho

3 Likes

Like above post says, this is an issue for all. For example, I tried to remove 600w from my deck and rendering plant was removed. I don’t know if rendering plant was the 9th card or not though.

This has happened with other cards and civs for me.

1 Like

This also happens to me, with different civs.
Had several games with a crucial card missing, because I don’t always notice that the game removes a different card when I’m changing my decks.

Also happened to me today during deck building with ports

I had this issue when I edited my Aztec decks. I click on a card that I want to remove and instead of this card another one gets deleted.

I unintentionally played into the late game without one of my factories last night. This issue needs to be fixed ASAP.

This bug still exist as of today

1 Like

This has got to be one of the absolute worst bugs.

1 Like

I made a video to illustrate.

P.S. if anyone can tell me how to embed YouTube clips, that would be awesome.
EDIT: I figured out the embedding on my own, but it was by accident. It would be great if this information was included in the forum resources section!

that has happen to me with russian civ and maybe other civs.

1 Like

Happened to me with Japan:

Add 2 vils
Add Heavenly Kami
try to remove 2 vils
Heavenly Kami is removed instead

Currently a workaround is to quickly switch to another deck and back, so that the cards are correctly ordered.

Very annoying issue, needs to be fixed ASAP.