Download does not start , windows store seriosly?

We got AoE DE on a simple FTP Server to download maybe??

Windows store is Buggy atm, if i press Install, i choose my ssd with enough space free.
(i was trying also normal hd nothing changed)
He wrote me, “download start” only 2,4 gb , i see no downloadspeed.
The indicator on bottom does not go Forward.
And the Installation breaks down !

I try now since 1-2 hours nothing work!!!

And then i wanted to post here to get help, but Need to spam first 4-5 Posts that i can create this Topic!

please give me a link to a simple download, and then i start it.
Cause Windows store is garbage!!!
I cannot even find my own games, he give me alltime to full shopsite.
RThen i can search aoe : DE to try it again.
And then it does NOTHING .

he does not even create a age of Empires direction, he does NOTHING.

Have you tried running the Microsoft Store troubleshooter?

Hello thanks, yes i try it now.
He wrote me there was a error in Cache about Downloads. (got the german Version, i just translated ).
Also he wrote me that the issue is solved.

I start the download again- he try to install again.
Now he want to start a download with 1,97 GB since 5 mins, nothing happens.

If i start the Programm again, he wrote me again that the Cache got a mistake -> but solved now!

For me it sounds like, the download from aoe DE is atm broken over Windows store.
Cause i try different other games / apps , this work all without Troubles.

Only AoE DE is not able to download, and he wrote me no error or so.
I press install, he try some mins, then i just get the install button back -.-

Man we are on PC here, give me a FTP download from the game, i move it in the correct Directory and can Play, why everyone does it so complicated???

i do not even get the Icon "age of Empires DE " in my Windows.
If i install another game and cancle the download, the first Thing what he does is, to give me a Directory + shortcut with the game on my windowsbar!

I have it downloaded and ready to play. When I click the “play” button it brings up an image of the game icon for about half a second a closes. So I’m not sure why I can’t play.

i got a fix for my download Problem. after 5 hours of testing.
No Support at all, thanks for 1-2 usefull answers on my Topics .

Just for info.
Windows store does not remove the temp files propperly by Age of Empires DE!
Also this Windows store reset Programm did not work propperly for age of Empires DE.
He told me that my Cache files got issues -> but he solved the Problem .
Atleast that was the msg.

It was not true, the Cache files was still hidden, and you are not able to simple open the Windows app ordner!

fix for this is.

1.) deinstall Tools, to open this ordner and delete it manuelly!

2.) start the download , or better to say try to start it, and press instantly on X , so he deinstall few files!

Overall way to complicated, a simple zip file for this game would be better.
Windows store try to make it easy for everyone, but if you get a issue, you cannot solve it so easy .
If i would get this Problem on steam, i could fix it in few clicks.
same on battlenet, or ubisoft Client or whatever.

Windows store sucks :wink: this is the best example!

how did you fix? i just send you a PM, please answer :slight_smile:
thanks bro

i fixed mine by uninstalling my preloaded game from my preorder and just reinstalling. I have gigabit internet so it wasn’t that big of a deal.

@GrandPrufrock said:
i fixed mine by uninstalling my preloaded game from my preorder and just reinstalling. I have gigabit internet so it wasn’t that big of a deal.

That is true when it had become available in my timezone… But my internet bandwidth is not that big… took me 1 hour to finish

@maxaut Did you Restart the PC? If not please try!

I have a same issue. I couldn’t start a game, just a small window appear for 1 sec than nothing. So now i try to reinstall i hope it works.

And yes i try with restart my Pc, not helped.

Ok, it’s finished working fine finally :smile:

Spent time working through Microsoft support until they transferred me to XBOX Support and Jeremy. After some troubleshooting we discovered that by disabling Antivirus (Trend-Micro), game functioned normally. Thank you Jeremy!!!

I can’t even buy the game from the Microsoft Store, its says the request is not supported, even though I have Windows 10, there’s and error code: 0x80070032, anyone else have this problem?

Having Issues here too

I’ve downloaded the game. It’s installed. I can open the game fine. I can navigate the menu and open the settings and single player menu etc. but as soon as I start a game, it closes and opens up the Microsoft Store app on the AoE:DE page. Have anyone has the same problem? Please #aoe answer me if you work up to this particular issue?

Same issue as original post. Can’t download / install. The game will start to download, then progress is no longer shown. It gets to a progress point and then just gets stuck. I have reset the store, re-registered the store with power shell, and cleared the cache. All other store apps download an install without issue. Wasted 2 days now. Anyone got an iso or download that works? I bought a key and this installer is a mess.

Ok I’ve had this same issue and continue to have ongoing issues. I fixed the main installation issue this way:
Go to your install drive, find the WindowsApps folder. Right click->Properties-> Security->Advanced. You will note that only the so-called ‘trusted installer’ has permissions as well as system, but NOT YOU! Edit the ownership of the folder, make it you or your local administrator so you can change security settings. Apply, close the properties window. Right click again->Properties->Security->Advanced and make your user have everything but full control. Apply and close. Now run through the installation again. You will see the download actually begin. Mine made it all the way through the download, and so-called installation. When I launch the game however I now get the error:

Unable to Setup storagePoint ‘MY GAMES’
Result = Unable to Create Directory”

I have not begun to troubleshoot this new error yet as frankly I’m rather disgusted with this whole ■■■■ thing. I think at this point I might just want my money back, which is a fantastic shame because I’ve loved AOE for years, and then MS goes and buys it and ruins it. If you want a good replacement, it’s still in development, but it plays, it’s called 0AD (Zero A.D.)

I couldn’t even report the error to MS, because you know wait, there’s an app for that. I click on get app - screen flashes, and window comes up again - get app … screw that! Find out for yourself MS since you want to make things so difficult.