Due to the borked map file encryption for African maps, Linux/Proton users are unable to use them/play multiplayer

:arrow_forward: GAME INFORMATION

  • GAME BUILD #: 100.12.38254.0 (newest steam version as of writing)
  • GAME PLATFORM: Steam
  • OPERATING SYSTEM: Linux Mint 20(however it occurs on other distros/Linux setups in general)

:arrow_forward: ISSUE EXPERIENCED

  1. Inability to join any multiplayer lobby due to them not appearing as listed
    Likely derived from
  2. Formatting/Encryption of files for the African DLC Maps makes them unreadable on Linux, hence Linux users have a different map roster, hence different version of the game.

:arrow_forward: FREQUENCY OF ISSUE

100% of the time / matches I play (ALWAYS)

:arrow_forward: REPRODUCTION STEPS

Here’s the steps to reproduce the issue:

  1. Run the game on a Linux PC
  2. Using Proton 5.X or higher, or Eggroll, or Experimental
  3. Turn on the Multiplayer screen after the game loads

:arrow_forward: EXPECTED RESULT

A list displayed, containing all available multiplayer matches.

:arrow_forward: IMAGE

MP Screen:


How African map files are displayed:

How other map files are displayed:

8 Likes

Lets go, let linux play !

4 Likes

Come on TT, track this issue and do something, i wanna play with my linux friends !

i am still confused how new maps can make the game break but (why do you need encryption on maps anyway?)

To not have people upload the maps as mods, to work around the need to purchase them.

2 Likes

Additional Feedback:
African maps are not selectable in Skirmish mode, which likely means Linux is unable to recognise them:

Selecting African Maps under Select Map provides this error upon starting the game:

1 Like

damn… :frowning: this is so mean…

so the maps are part of the DLC? I understand the civs and SP maps, but MP maps? Seems like a strange decision

Yes, they are part of the DLC. Also there is no distinction between SP/MP maps; all maps can be played in both SP/MP.

Hi @ShinkuroYukina, I am sorry this issue is affecting you and other Linux users. I have added a ticket in our database and linked this forum post as well as @SKWYRL’s post: No multiplayer after update.

We are tracking the issue now. Thank you for your reports!

7 Likes

Additional Feedback:


African scenarios also fail to load, so the issue is not limited to Maps.

1 Like

This issue still exists in the current build of the September PUP, when run with either the latest Proton or a custom version of it. I still cannot see or join any public or LAN multiplayer games from Linux.

Has there been any progress on fixing this issue, or on finding some workaround for it?

Sorry for the bump… I’m just getting a bit frustrated. It would be one thing if only the content from the new DLC were borked, but being unable to play AOEIII multiplayer at all is getting annoying for my family (myself and my dad both run Arch Linux, while my brother is on Windows, and all of us enjoy playing Age of Empires together).

It would be nice if there was even just a way to run the pre-DLC version of the game for those of us experiencing this problem.

2 Likes

AOE 3 DE has no multiplayer games available due to this same glitch. I am on Ubuntu 20.04, exact same problem.

Please fix ASAP. More and more users are using Linux with SteamDeck coming out soon, please fix this so I can enjoy AOE3 DE again!

2 Likes

I’m not sure encryption is the right word. The map files are XML and C Source files, but the new AF map files are binary in nature. This could be encryption, but I think it’s more apt to call it obfuscated than encrypted… though they can be interchangeable.

Screenshot of the file command output showing the actual file type, regardless of the file extension:

I’d be more curious what functionality is missing in proton that the game needs to de-obfuscate the map files, rather than trying to demand the devs remove something that was added for business purposes.

Is there any update on a fix for this? I’m playing AoE4 and digging it right now, but it makes me want to return to my first RTS love: AoE3. Would buy it and the African Dynasties expansion in a heartbeat if the map bug got fixed!

2 Likes

As far as I can tell this issue is still not fixed. No games show in lobby when trying to play multiplayer.

29 november, issue is still not fixed plz fix it, i need playyyyyy !!!

Mexico DLC has come and gone, as has the November patch (that messed about with and improved the USA deck, so thank you anyway), and this is still not updated.

Not only do Skirmish maps fail to load, and multiplayer is just…aether’d, but the only African historical battles which load even some of the time are Spanish v. Corsairs (which I think isn’t even from the DLC!) and Portuguese v. Somali.

The civs themselves function properly.

Would copy-pasting the format of a different map with the appropriate changes in names and assets and such to alter the .xml file work?

This bug is reproducible in Porting Kit-run versions of DE on Mac OSX 10.15.7.

the multyplayer is now working using Proton 6.21 GE i am playing on this moment plz, try and post if work for you same

Ok, so right now things are very stupid, but they seem to kind of work:

  • With Proton Experimental, the map encryption issue seems to be resolved

  • With Experimental and the equivalent fix from Age of Empires IV (1466860) · Issue #5258 · ValveSoftware/Proton · GitHub, multiplayer seems to work

  • I’m having the progress bug with Experimental: you can’t make new decks, and campaign progress doesn’t save. BUT! With Proton 5.0-10, I can save decks, and then load them in Experimental.

So, for now, it seems like you need to do your prep work/campaign play in 5.0, then switch to Experimental to play multiplayer. Tedious, but definitely workable!

1 Like