Enhanced AI

Discuss Enhanced AI

I played to the vs multiplayer AI, and really felt its power! Singleplayer AI is still bad, even worse in campaigns

I updated the mod yesterday. Below is a list of the main changes, but there are actually more changes to this update. Give it a try and find out!

Changes in 0.9.7:
German Settler Wagon maintenance has been improved. It worked before, but it’s more consistent now.
Improvements to card deck selection.
British AI can use Florence Nightingale if they select that card and research it.
Warships are more aggressive.
Livestock pens are now used by the AI for land maps!
Ships should respond to being attacked a little bit better.
Handicaps brought back for Hardest and Extreme difficulties for now. Handicaps were brought back
because it is too difficult for some people to read this mod’s description.

I have the mod in my Mods list but how do I use the advance Ai in Skirmish games?

Strange I have done that and the Ai does not build walls or play any different to the default AI. I play on Extreme difficulty

@PurSpyk, if the AI does not send you a message at the beginning of the game mentioning that you are using my mod, then the mod is not activated. If you have other AI mods activated at the same time, that could cause problems as well.

The mod has been updated today. Below are the update notes.

Changes in 0.9.8:
Greatly improved card selection for: Aztecs, Chinese, Ethiopians, Huadenosaunee/Iroquois,
Huasa, Inca, India, Italians, Japanese, Maltese, Mexicans, Sioux/Lakota, and USA.
The AI will use Livestock Pens more often now and they are no longer restricted to just land maps.
Adjustments to the naval logic.
Fixed an issue with ships loading artillery due to a recent official game patch change.
Very experimental custom Archipelago logic is now implemented. The AI will likely not be a challenge on Archipelago yet.
The AI will now build bases on islands in the Archipelago map. This base building logic will be implemented for land and other sea maps soon.
Refactored various areas.

2 Likes

The mod was updated again today. Below are the update notes.

Changes in 0.9.9:
Improved the AI’s ability to rush and made it more aggressive in general.
Aztecs now train Eagle Scouts.
Spanish now train Missionaries and War Dogs. They use Unction too.
Chinese now train Disciples.
Italians make use of more Architects now.
Minor improvements to the Archipelago logic. It is still very experimental.

2 Likes

Hi; I tested this and it seems it doesn’t work, as the AI is still unable to load the artillery in a ship:

First of all, thank you for reporting some test results, this is helpful!

However, I believe your issue may be due to a mod conflict. I just tested to confirm and it works fine for me.

There are two things to check:

  1. (Not likely) Make sure the protomods.xml file exists in the data directory of my mod.
  2. (Most likely) Turn off any other mods you have, as one of those may have a protomods.xml file that is causing a priority conflict with mine.

Let me know if this information helps. Thanks, @EntombedCurve02!

1 Like

I will check again and post results, I’ll let you know as soon as I do it

1 Like

I have this mod subscribed to and have tried to use it, the in game AI does not mention that the mod is active and i have no other AI mods activated at the same time. the only mod active is one that increases the pop to 400, would that be an issue?

I have checked both and the mod is not working when I have no other active mods and protomods.xml exists in the data directory. AI didn’t send me message about using the mod and there’s no features mentioned works ingame. Here’s file address after i subscribe your mod: Games\Age of Empires 3 DE\76561198114942867\mods\subscribed\209052_enhanced ai, is this the correct order?

It seems you put your mod in a folder called “Enhanced AI” in the subcribe verion, it’ll work if you remove that folder and put your mod file directly in the subcribe file"209052_enhanced ai".

That is very odd, I have always uploaded it that way. I will take a look. Thanks for pointing out the issue.

The issue is now fixed. Please download the updated mod and you should see the files in the proper directory again. Thanks for pointing that out, @Sonnambula249!

It is very strange that this happened, because I am uploading it the same way I always have. Perhaps it was a bug. On a related note, I have noticed that the “age3-mod-status.json” file in the main mods directory does not seem to properly update when mods are removed from the local directory. There may be some bugs worth looking into in that area of the app.

1 Like

Hello, @squeezaGeezer91! Thank you for reporting this, I believe your issue is the same one as below. If you download the updated version of the mod I just uploaded a few minutes ago, it should now work for you. Please let me know if you have any other issues. Thanks!

it is working now for me, turns out the mod was conflicting with my 400 max pop mod i had turned on as well, once i turned that off your mod was running smoothly :smiley:

appreciate the quick response :slight_smile:

1 Like

Hello there!

I’m glad to see that there is ai modders on DE too. Until 2020 I was a modder for TAD and I know how hard it is, doesn’t even tried on DE. Thank you for this mod, you can expect me in this thread as a tester. For now, what I would like to see is consistent wallbuilding from the ai, which isn’t what happen on most matches. Thanks again, see ya

3 Likes

Hi, @oJoseHenrick! Thank you for testing the mod.

Yes, the wall building aspect of any AI mod uses a wall building plan type that was disabled in the default AI. It is somewhat limited in its capacity to handle things like trees, trade routes, buildings, or minor civilization settlements as it is on its own. I assume that is why the original developers of the game stopped working on it and disabled it in the first place. I have an experimental solution to this, but it will probably take some time to make it into a public release.

I will appreciate any testing feedback you can give. Thanks and enjoy the mod!