Error: "File transfer failed. Please ensure free disk space before retrying"


I receive an error “File transfer failed. Please ensure free disk space before retrying” when loading a multiplayer game. I believe this started occurring after installing Update 6159.

Any fixes for this issue?


A mí me pasa lo mismo y no puedo jugar.
Que podemos hacer para poder solucionar este problema? Antes del nuevo parche (6159) no pasaba. Espero lo puedan solucionar lo antes posible.
Muchas gracias!


I had this exact same issue, both when hosting a ranked and non-ranked multiplayer game. Verifying game files in STEAM didn’t help, but I was able to successfully join a game someone else hosted. The issue first occurred for me today with Update 6159 (after never having encountered it in previous versions), and seemed like a surprising message – I have several hundred GB of free disk space, and haven’t ran into memory issues in any previous version of the game. Lots of other people seem to be having the issue with this update, e.g.


I have the same problem and a friend of mine too.
We cannot play multiplayer after download and install update 6159 even if yesterday (November, 12) we have been playing together.

Please, solve ASAP the problem with a new update.

Thank you,

Best regards,

Steam players:


The same thing has been happening to me since the last update. Can you please fix? Thank you.


I think I found a way to fix this. Go to the AoE3DE folder in explorer and double click on the AoE3DE_s exe file and go to properties. Go to the security tab and give full control to all of the different security packages (all application packages etc.). Then double click on the file and select ‘run as administrator’. After doing that it worked fine for me… Let me know if it works!

1 Like

Having the exact same problem here. Started after last patch, never had it before. Also tried the suggested fix above, didnt work. Plz fix ASAP, game is unplayable.

1 Like

The same problem for me.
It doesn’t work to me also.
Please fix it asap

If someone solve it, please let me know

1 Like

Yep, here too.
The suggested fix didn’t work for me either.
Please hotfix and don’t make us wait until the next patch. The game cannot be played in multiplayer at all.

1 Like

I also have this problem. Verified Steam files, gave app all permissions, nothing works. Please undo this part of the patch, it’s causing more problems than it fixes

1 Like

I am having the same problem too. Please fix.

1 Like

Fix it please and make this game playable…

1 Like

guys do you have some news?
does it works for you actually?

1 Like

Same here. Two seperate installs, my wife and me. Started since the last update. A fix would be nice.

1 Like

I have the same, 55 GB of free space and an error pops up: “File transfer failed. Please ensure free disk space before retrying”. It appeared after the update on 11/13/2020. The game does not start on Surface Pro, it starts on the Razer Blade 15 without any problems.



We cannot play Multiplayer.

FIX this bug.

Thank you.

1 Like

Hello guys, i experienced the same issue. I tried everything and i think i found a solution. I turned off anti-aliasing in graphics settings and now the game seems to work (i already had every graphic setting setted to low): after that change, i never experienced the “file transfer failed” So i suggest to you to turn off everything on graphic settings; i hope it worked like it worked for me. Probably the last uptade turn up the gpu usage.

My name still censored tough :face_with_symbols_over_mouth:

how do i do it? turn of the anti-aliasing thing?
Thank you~

Multiplayer działa jedynie w opcji “online”, w “lan” przestała działać po ostatniej aktualizacji. Próbowałem Satanasso6823 i Eyta2426 rozwiązania i nie pomogło.

Multiplayer works only in “online” option, in “lan” it stopped working after last update. I tried the Satanasso6823 and Eyta2426 solutions and it didn’t help.

1 Like