First unit in build queue can't be canceled when UI scale is 125%

Game Version:

  • Build (current)
  • Platform (Steam)


When starting my build at the beginning of a game, I got housed and tried to cancel the villager in my TC queue. I was unable to cancel the villager to start researching Loom instead while I built a house.

I read about the same issue someone else was having on a forum; they found that it only occurs when your UI scale is set to max (125%) I lowered the UI scale to 123% and was able to cancel units again.

Reproduction Steps:

  1. Set UI Scale to 125% (Also occurs at 124%)
  2. Set any unit to train or tech to research at any production/tech building.
  3. Try to cancel the tech/unit. It won’t cancel.
  4. Set UI Scale to 123% (or lower until it works for you)
  5. Repeat step 2 (cancel should work again)

I think this bug is also linked to screen resolution. My current screen resolution is 1600x900 and I have to reduce UI scale to 120%. When I change the resolution to 1366x768, I need to reduce UI scale to 118%.

This bug not only prevents you from cancelling units/researches but also prevents selecting individual units when you have multiple units selected from the their cards in the UI area. Same goes for deselecting individual units with Ctrl and all units of a kind with Shift.


I forgot to add in my post, this bug is as of build 33059

I also have this annoying bug. Running UI at 125% and screen res 1920x1080

I also have this bug too. This games release should have been delayed. So many annoying bugs that prevent gameplay.

Same problem here. Very annoying

Game Version: Age Of Empires 2 Definite Edition

playing on patch 33315


Playing on ultrawide resolution 3440*1440 Fullscreen makes the cancel unit in production buildings (such as villager or archer or tech etc) not clickable.


(I got this from another dude but hopefully this picture is up to date)

So I can cancel the Red (referring to the image above) dots queues but the villager in production or I cannot click on (Yellow) .

I have tried to change the resolution to a more standard format and immediately the button is clickable. Ofcourse this is not a reasonable operation to do in a multiplayer game :wink:

This is actually the only button I am referring to in the topic but it includes every production building that I have tried in the game.

Reproduction Steps:

  1. Launch the game on a ultrawide monitor
  2. standard game against AI
  3. get some food
  4. queue villagers in your TC
  5. attempt to cancel the villager being built (by clicking on it because game option does not have any hotkey that I am aware of)

Thank you very much!

Important update!

My In-game HUD scale is 125%
(Options>Interface>In-Game Interface)

If I put that back to default 100% I longer have a problem.

So I guess that narrows it down quite a bit :smiley:

Game Version:

  • Build (101.101.33315.0 4426672)
  • Platform (Steam)


If you go to options > Interface then under In-game Interface
Set In-game HUD Scale to 125%

Any technology you research then try to cancel… Will NOT cancel. There seems to be something blocking the mouse click on that technology

Reproduction Steps:

  1. go to options > Interface then under In-game Interface > Set In-game HUD Scale to 125%
  2. Research loom for example then try to cancel it

Hi @GregRising, This is a known issue which may be fixed in the upcoming December Update.


Thanks for the update. I had this issue like a month ago and forgot to report it but thankfully many users did.

Fantastic! Looking forward to the steep lancers balance lol

1 Like