Fix to sound problem [34483]

If your sounds disappeared after updating, Reinstalling DirectX fixed mine

https://www.microsoft.com/en-us/download/details.aspx?id=35

Thanks for posting what you found. We’re looking into why sounds are not working for some players and it would help to get a little more information from you.

  1. Are you playing on the Microsoft Store or on Steam?
  2. What version of Windows do you have?

Thanks in advance!

Microsoft Store version. Windows 10 latest mainstream version.

This is specific to the sounds disappearing after the new Age DE update 34483.

That download isn’t even meant for Windows 10. All DirectX binaries are included and delivered through the operating system using add and remove windows features. Only by forcing this download to run under previous version of Windows might be able to force it’s installation. So personally I find it strange and likely impossible that this did solve your issue. No offense meant, just curious.

1 Like

It runs just fine without the need for forcing anything. So personally I find your comment unnecessary and unprofessional.

Objectively, I find it destructive and would prefer if you’d refrain from making uneducated comments without researching the subject first. You might wish to alter your post to not deter people away from a proven solution to their problem.

Perhaps like so:
“It is curious that this is required since windows 10 should download all necessary libraries automatically. Perhaps someone should take a look at why the game isn’t calling for the needed DirectX libraries to be installed during the update process.”

Like I said. I’m really happy that installing this on Windows 10 worked for you.

2 Likes

Thank you, it worked for me also.

That link you posted from Joonas Top is for DirectX 9 running on Windows 7 and below. The dxwebsetup.exe file is almost 9 years old. How might that fix a DirectX 12 sound issue?

1 Like

Updated only a few days ago and I am also facing the sound problem. Do you have already any idea how to fix it?

Thanks

If you are here for Age of Empires Definitive Edition. Simply download and run the directX web setup from microsoft. It will download and install the missing directx9 libraries for you.

The recent windows versions do not have the required directx9 files for the game to hook. I just installed windows 1909 pro on a new computer and had to do this on it too to get sound working for the game.

I have tried that already and used the above link. Download works fine but when running it I get:

Error creating process C\users\myname\AppData\Local\Temp\IXP000\dxwsetup.exe Reason: INDOWS\system32\advpack.dll

I am on Windows 10 all updated

It sounds like this is a different error than the sound issue. Have you tried the troubleshooting steps in our help article for crashes?

If the error message is still coming up after trying these steps, reply back and we can work together on other steps!

Updated driver, re-installed Windows 10 still no in-game sound. In general soundw works fine on the computer. When I launch AOE I have a sound as expected. But when you decide on the game paramaters and also when launch the actual game - no more sound.

Hello ADragon8602, any ideas which could help?
Thanks

Sigi

I am having the same issue sound when game starts but once in game no sound. Windows 10, store version of AOE.

First of all check if DirectPlay (and media features) are enabled.

If you use the Windows 10 N version you probably also need to install this addon.
https://www.microsoft.com/en-us/software-download/mediafeaturepack

Hello PCS70,

Direct Play was unticked - I changed it.
Media Features was ticked already.

Still no sound after selecting game parameters.
I have Windows 10 Home not N

Any other ideas?

So you do hear the intro music playing but inside main menu or while playing all sound is gone?

Maybe there’s something else wrong. Could you check the settings of sound through options from the main menu?

If they look like this:

Move them up again like this:

These settings were the first thing I checked when it happen. They look like it should be - second photo.
It all happened aftet the latest update. Before that everything was fine.

Yeah, I thought already that would be too easy and obvious although not mentioned.

Which type of audio device is installed on your system?