Game crashes on boot

:arrow_forward: GAME INFORMATION

  • GAME BUILD #: 7006804
  • OPERATING SYSTEM: Windows 10

:arrow_forward: ISSUE EXPERIENCED

Game crashes on boot.

:arrow_forward: FREQUENCY OF ISSUE

All the time since the hotfix. I last played on Monday, July 12th and game ran fine/

:arrow_forward: REPRODUCTION STEPS

Here’s the steps to reproduce the issue:

  1. Start the game
  2. Splash screen shows up
  3. Game crashes

:arrow_forward: EXPECTED RESULT

Well, game should probably not crash on boot.

We are unable to reproduce this issue. Could you try verifying integrity of your AOE2:DE installation?
How to do that:

  1. Make sure the game is fully closed.
  2. Open Steam - Library tab, find AOE2:DE in the list of games.
  3. Right-click on it and select Properties.
  4. Click on Local Files on the left.
  5. Click on Verify integrity of game files.
  6. Wait for the process to finish.

Hi @aoescout ,

Sorry for not updating the thread in a few days. Here’s what I tried:

  • verify file integrity through Steam → all fine, still crashes
  • uninstall the game and reinstall through steam → still crashes
  • delete Age’s folder in C:\Users{me}\Games → still crashes
  • delete C:\Program Files (x86)\AOE2URLHELPER → still crashes
  • I updated my drivers → still crashes
  • I tried uninstalling the most recent Windows update (KB5004237) → still crashes
  • I ran sfc /scannow & restarted → still crashes

When I removed Age’s folder I noticed it keeps logs of crashes so I’ve attached the most recent one.

Looks like it crashes because of

Exception type 0xc0000005 occurred at 00007ffbe140ba66

I’ve looked on the forums for similar issues and found this thread

I tried everything in there and no luck.

2021.07.16-17.27.16.txt (9.8 KB)
Age2CrashReport.txt (147 Bytes)

@ag2801 Thank you for the additional information.

Could you please post your latest minidump file (AoE2DESteam-50700-[date and time].mdmp)? You can find it in “C:\Users<your user name>\Games\Age of Empires 2 DE\logs”. Make sure it’s the right date (the last time you crashed).

I had to upload it to Google Drive because the forum software here would not accept its .mdmp extension

1 Like

@ag2801 This appears to be an audio driver problem - the minidump shows a crash in AudioDevProps2.dll. We had similar reports before.

You may be able to fix the issue by uninstalling something called Sonic Studio, which seems to have been bundled into some recent ASUS update:
Hope this works for you.

1 Like

It works! I uninstalled all programs that had Sonic Studio in the name. There were two that came with the Asus motherboard and were recently updated (I can’t remember the exact names of the two apps).

Thanks a lot for your help and patience @aoescout <3

1 Like

had the same issue. instead of uninstalling sonic, i just disabled them in sounds and it worked… spent hours trying to fix this issue until i stumbled upon this post. thanks.

1 Like

I didn´t found sonic studio on my computer (i have an msi motherboard), game keeps crashing after a few seconds of the intro video, i want to play, love for another solution, thanks.

Pd: I tried unistalling realtek drivers but it doesn´t work either.