Game crashes when clicking to imp with a castle

:arrow_forward: GAME INFORMATION

:point_down: These details are CRITICAL; DO NOT skip them or your issue may not be reviewed.

  • GAME BUILD #: 10078593
  • OPERATING SYSTEM: Windows 11

:arrow_forward: ISSUE EXPERIENCED

Game seems to crash whenever I click to imperial age with a castle on the screen. Tried reproducing in single player and seems to only be the case when playing RM or Death Match, not Empire Wars. This seems to be the issue, although I am not 100% sure that the castle with imp is the cause of the problem.

:arrow_forward: FREQUENCY OF ISSUE

:point_down: How often does the issue occur? CHOSE ONE; DELETE THE REST!

  • 50% of the time / matches I play (FREQUENTLY)

:arrow_forward: REPRODUCTION STEPS

:point_down: List CLEAR and DETAILED STEPS we can take to reproduce the issue ourselves… Be descriptive!

Here’s the steps to reproduce the issue:

  1. Build a castle in standard RM settings
  2. Click imperial age with a castle on the screen

:arrow_forward: EXPECTED RESULT

:point_down: What was SUPPOSED to happen if the bug you encountered were not present?

Game crashes immediately

:arrow_forward: IMAGE

:point_down: ALWAYS attach a PICTURE (.jpg, .png, .gif) or VIDEO (.mp4, YouTube link) that highlights the problem.

:arrow_forward: GAME FILES (SAVE / RECORDING)

:point_down: Attach a SAVE GAME (.aoe2spgame) or GAME RECORDING (.aoe2record) of the match where you encountered the issue. Link it below if using an external file service.

MP Replay v101.102.8319.0 #(73855) @2023.01.05 112339 (1).aoe2record (4.0 MB)
MP Replay v101.102.8319.0 #(73855) @2023.01.05 091448 (2).aoe2record (3.0 MB)

MP Replay v101.102.8319.0 #(73855) @2023.01.04 193655 (1).aoe2record (4.3 MB)

1 Like

I have been having this same problem constantly! I am always about to win a long game, and then it crashes! Really frustrating!
MP Replay v101.102.8319.0 #(73855) @2023.01.05 224353 (1).aoe2record (3.5 MB)

I have exactly the same problem. I’m relativly sure I’d have won the game… then I clicked to Imp and everything crashed. It isn’t the first time this happend to me in the past few days.

Unfortunately it seems like I am to new to this forum to Upload replays :confused:

UPDATE: I removed the “Original Sounds” mod and game seems to be back to normal. Don’t know if that’s true for everyone but you should try removing some mods to see if it still crashes.

Yeah I’m a CBA Requiem player so there are castles in every game and my game seems to be crashing too every time I age up and I go back to one of my castles. Every single one of the games I play crashes.

I don’t have that mod and 100% of my games crash.

Deleting all my mods seems to have fixed my problem so far. Only played 3 games to test my theory so far though.

1 Like

You should try re-enabling the mods one by one to find the one causing the issue. This is something that occurs after every update, outdated mods causing issues until they are updated by the mod creator :slight_smile:

Bro I had like 50 mods active from all the events. It works. I also deleted my entire mod file on my computer. :stuck_out_tongue:

1 Like

I’d like to add that if your game generated minidumps during these crashes, these could be very helpful for us to track the root of the issue, you can find them here: C:\Users\USER\Games\Age of Empires 2 DE\logs

1 Like

I’m not sure which games are the correct ones so I’ll just post all the games I played those days. I believe 5/10 of them were crashes.

2023.01.07-11.54.46.txt (30.4 KB)
2023.01.07-17.19.40.txt (20.1 KB)
2023.01.07-17.38.47.txt (22.7 KB)
2023.01.07-19.39.04.txt (12.4 KB)
2023.01.07-19.57.04.txt (11.7 KB)

2023.01.07-23.48.54.txt (35.3 KB)
2023.01.08-13.08.54.txt (12.2 KB)
2023.01.08-15.50.41.txt (21.5 KB)
2023.01.08-22.19.11.txt (46.1 KB)
2023.01.08-22.53.58.txt (70.3 KB)

Do you have files that look like this?:

AoE2DESteam-73855-2023.01.07-19.56.49.mdmp (326.9 KB)
AoE2DESteam-73855-2023.01.07-20.10.17.mdmp (307.3 KB)
AoE2DESteam-73855-2023.01.08-13.29.31.mdmp (314.9 KB)
AoE2DESteam-73855-2023.01.08-16.14.25.mdmp (333.7 KB)
AoE2DESteam-73855-2023.01.08-22.51.29.mdmp (335.3 KB)

As fate would have it: yes I do.
Not sure what program to read these with though. These look like a bunch of gibberish.

1 Like

Thanks for the files!

1 Like

I did some testing and it doesn’t have anything to do with the castle being in view or even having a castle. For me the imp click regardless of having a castle (or not) crashes the game. I have a friend who is also having the same problem.

I should add that in multiplayer me or my friend clicking to imp also makes the other person crash but we were in a 3v3 and our 3rd player does not crash, the same 3rd player never crashes - This has happened multiple times (9 out of 10 times)

Did you try disabling mods?

1 Like

Just tried, seems to be the Custom UI causing it for me. Well… first test game in and it went imp without crashing.

I was using…

Screwed Purple - [Custom UI]
Author: Watlingj1057

My friend with the same issue uses

Transparent UI
Author: Teban0721