Game crashes when mod list is loaded in "Browse Mods" tab

Game Version:

  • Build 101.101.34223.0 4509956

Issue:

switch to Browse Mods tab won’t crash the game instantly,when mod list loaded,game crash

Mods installed:
Even Smaller Trees
Localization Fix and Enhance Data Tooltip

removing mods wont solve the problem

Reproduction Steps:

  1. Click MODS in Main Menu
  2. Click Browse Mods
1 Like

Hey @qzaedcoknuh! Thank you for taking the time to post about your issue. Our QA team is unfortunately not able to reproduce the issue internally, so we could use some additional information:

  • A copy of your DXDiag.txt
  • The Event Error Log from the Windows Event Viewer

I’d like to pass them to the team so they can continue digging into the problem and hopefully find a solution.

Thank you!

Hi, I have precisely the same issue. Clicking “browse mods” in the mods section causes the game to close after ~3 seconds.

Happy to provide the files you asked qzaedcoknuh for, but have no idea how to access an “event error log”. Also, apparently new users can’t upload files…

The game is also currently crashing for me when trying to open the “Browse mods” tab ingame.

Edit: Not sure if related, but I am also unable to subscribe to mods, either through the site or ingame, or update screenshots for my mods.

This is happening to me too. I was literally browsing thru mods this morning. Added small trees, the official one.

Fast forward to this evening and as soon as I revisited the browse mods tab, it crashed. I removed the small trees mod just to see if it was causing it but now it I cant subscribe to it from either the game or the website. Why are there so many problems in this game still???

Trying to search for mods on the mod page ingame causes an instant crash.

Im having the same issue. This is on Steam and Game Pass. Reinstalling does not help. I can’t even download my existing subscribed mods :frowning: . Just clicking on “Browse Mods” causes an instant CTD. Maybe its an invalid character in one of the titles?

Not sure if this helps or not, but here is a screenshot of the mod screen right before the CTD

Game Version: 101.101.34223.0

  • Build 4509956
  • Platform: Steam

Issue:

Age2DE crashes when I open the mod workshop and click on “browse mods”. This is consistent, as in it crashes every time when mod browser is opened.

5 Likes

Having the same issue .
The browse mod tab worked perfectly before.
Mods still work,
But when i open browse mods it just crashes after 2-3 sec everytime.

Same issue, on steam and microsoft Version

I cant add mods! When i go mod section and search for mods game crash instantly!
PLS FIX MS!

I have the same issure, last night it worked perfectly, i even installed a mod and now it simply does not work.

1.Open game
2.Open mod
3.Click to browse mod
4.Game crashes after waiting a few seconds

Seems to be a common problem

my game keeps crashing randomly when playing and always crashes when I try to view mods to download? Need help

what should I do,I deleted it and restarted

Hello everyone! If you are still encountering this error, we will need some additional information so we can dig into the problem:

  • A copy of your DXDiag.txt
  • The Event Error Log from the Windows Event Viewer

If it exists, we would also love the Crash log located in one of these folders, if you’re able to create one by reproducing the crash:

  • C:\Users<WINDOWS USERNAME>\AppData\Local\age2_x1\logs
  • …\Users\UserName\Games\Age of Empires 2 DE\logs

I hope to hear back from you so we can see what can be done to help! Thanks for the report!

While I agree this is useful info, this can be easily reproduced by just visiting mod browsing window.
Its happening for everyone and in every pc. This shouldn’t require much of repro/info from user side.

Its not so great when the same info copy pasted in every thread!