Game drops fps with new graphics card (AMD RX 6600)

Winter and Christmas without some rounds of AoE feel sad. I think they don’t care if we find something unacceptable. If you are not an rich investor your opinion has no worth. We just can wait and hope there is someone in the backround fixing it.
Because its not the first time this massiv lagg after feudal age appears but back then more people were affected.

Sounds like Microsoft is being typical. Can’t be bothered to do it especially on older games. I wish I could get refunds for the extra content I bought at this point.
If they would at least talk to us and provide some update on progress being made - this would be way less frustrating.

1 Like

I could avoid the issue altogether by forcing the game to run on the integrated graphics card. It’s nuts.
I got a 6800M but have to run on the integrated graphics to avoid the issue.
Maybe it’s an issue with Navi, since the integrated from 5900 HX is a Vega one.

Honestly doubt it. I mean, when I uninstall the game and reinstall, I can play maybe one or two 4v4 games before the lag issues start. Then I move to 3v3 and can play some of those. Then 3v3 starts to lag after some games and I move to 2v2 for quite a bit and eventually even 2v2 and 1v1 starts having this same lag. Honestly just so damn weird and to me it seems like purely a game issue since everything else still works fine on my pc.

1 Like

How is your ingame benchmark running?
Mine stutters from the beginning but the score is decent.
Can you test like 4on4 deathmatch vs AI?
There after I would say 5 minutes ingame time the stutter begins.
Against human opponents its most of the time after feudal and then it gets unplayable.

:arrow_forward: GAME INFORMATION

:point_down: These details are CRITICAL; DO NOT skip them or your issue may not be reviewed.

  • GAME BUILD #: 101.101.56005.0 7694700
  • GAME PLATFORM: Steam
  • OPERATING SYSTEM: Windows 10

:arrow_forward: ISSUE EXPERIENCED

:point_down: DESCRIBE THE ISSUE IN DETAIL (below). LIMIT TO ONE BUG PER THREAD.
Originally posted this on reddit: https://www.reddit.com/r/aoe2/comments/r9p5lj/rx_6600_xt_stutter_issue/

As you can see it is an issue multiple people are reporting.

Got a new RX 6600XT graphics card as was relying on my AGPU Ryzen 5 3400g integrated graphics card before.

However the game experiences stutters/freezes as the game goes on with larger number of players (starts smoothly). Even though the RX 6600XT is significantly better than the Ryzen 5 3400g I’m having this issue.

Doesn’t seem like its a general issue with the GPU - it can AoE4 on medium-high settings very smoothly so you would think at the very least it wouldn’t stutter with AoE2. Have tried updating drivers, monitoring gpu/cpu temps levels and ram and disabling freesync.

When I’ve googled it, it seems lots of other players have had similar issues with AMD 6000 XT series in AoE2: DE.

Does anyone know if devs have even acknowledged this as an issue they are working on/aware of?

Further links from research I did:

:arrow_forward: FREQUENCY OF ISSUE

:point_down: How often does the issue occur? CHOSE ONE; DELETE THE REST!

  • 100% of the time / matches I play IF its a 3v3+ that goes on to mid-game or later. Also if I run the ranked benchmark test.

:arrow_forward: REPRODUCTION STEPS

:point_down: List CLEAR and DETAILED STEPS we can take to reproduce the issue ourselves… Be descriptive!

Here’s the steps to reproduce the issue:

  1. Run ranked benchmark
  2. Experience clear stutter/micro-freezes
  3. Get a score of over 1150 regardless
  4. Alternatively just play any game that is 3v3 and let it go to mid-game

:arrow_forward: EXPECTED RESULT

:point_down: What was SUPPOSED to happen if the bug you encountered were not present?
Game runs smoothly without freezes

:arrow_forward: IMAGE

:point_down: ALWAYS attach a PICTURE (.jpg, .png, .gif) or VIDEO (.mp4, YouTube link) that highlights the problem.
WRanked-Bench-Mark — ImgBB

:arrow_forward: GAME FILES (SAVE / RECORDING)

:point_down: Attach a SAVE GAME (.aoe2spgame) or GAME RECORDING (.aoe2record) of the match where you encountered the issue. Link it below if using an external file service.

*

1 Like

Confirmed same issue.

Hello, this is luckily already tracked issue, thanks for the report nonetheless.
Have a nice day.

1 Like

I bought a RX 6600 XT from Powercolor today - now I have stutters/freezes/laggs in game.
I could play smooth before with my XFX RX 570 8GB.
CPU is Ryzen 5 3600.
I think something is fishy with the GPU and AoE2 - please fix. Winter is coming and I want to enjoy my AoE2 - not interested in AoE4.

Ah that is good to hear!

Do you have a link to the topic that is being tracked? I saw one related to freesync but this isn’t the same thing so want to make sure there is no confusement here.

can someone translate this thread?

do they talk about the same problem?

no - people with this card have problem in aoe. if you would done 1 minute of research before posting - you would have known is has nothing to do with driver.

I can say after some testing.
It happen in teamgames after people reaching feudal age.
I can remember that is not the first time these bug made appear.

Back some patches we had this feudal lagg bug already.
Can someone confirm?

2 Likes

confirmed again
seems ChristheCo has recognized that it’s an issue that is being tracked. Hopefully a resolution comes sooner than later. I’ve stopped playing the game for now as the other night it got so terrible, i quite virtually had no idea what was going on in battlefields

Can someone confirm?

2 Likes

I don’t have a graphics card yet, but this one is definitely on my sight. It’s always nice to have compatibility with modern hardware, specially in apps or games with lots of users, so I hope @fe_dev_team identifies what the issue is.

1 Like

Yeah, where is this being tracked so we can know when it’s fixed. I have little reason to play the game until it’s fixed

Any update? Still unplayable for me.

Edit:

Can someone confirm that this fix helped? https://www.reddit.com/r/aoe2/comments/o0zvxo/solved_age_of_empires_2_definitive_edition/

I don’t have malewarebytes and whitelisted steam folder on my NOD32 - didnt fix it.

1 Like

I don’t have Malwarebytes. None of these fixes have worked.
I think we may need to take this to AMD and see if they got anything for us.

1 Like

I have the same exact issue, also on a RX 6600.

AoE4 works perfectly, but AoE2 DE has a lot of lagging/stuttering/

4 Likes

I have 2,500+ hours in the game but I’m unable to play anymore since I upgraded my GPU. :frowning:

Devs, any news or updates regarding this issue?

3 Likes