Stutter/Lag

Version 101.101.54684.0 7486483
Steam
Windows 11 Home

Frequent stuttering lag - happens at low unit counts and high. Changing graphics does not help. Tried uninstalling and reinstalling the game without any avail.
Updated latest graphics drivers. Tried rolling back.

Happening 100% of the time on multiplayer skirmish games

Here’s the steps to reproduce the issue:

  1. Multiplayer game
  2. Not tried lower unit count but graphics test works
  3. No issues with solo missions

If someone walks me through how to make a video, I’ll do it.

Game has not crashed yet so I don’t have any comments here.

My PC:
CPU: AMD Ryzen 5 5600G with 8GB ATI
MOBO: ASRockB550M-C
GPU: AMD Radeon RX 6600 XT, 16 GB (2x8GB)
RAM: PNY XLR8 16GB 3.2GHz PC4-25600 DDR4
SSD (2):
931GB Samsung SSD 870 EVO 1TB (This is my game drive)
465GB Western Digital WDC (This is my OS drive)

2 Likes

Quick update - Tried a solo game again online with no allies - no issues there after tinkering with some of radeon’s software settings. If anyone has any idea if their software can introduce lagging/stuttering, let me know. I’ll try a multiplayer game again tomorrow after work.

Thanks!

1 Like

Update to my last update.
THIS DID NOT WORK.
Changing radeon settings made no difference whatsoever.

1 Like

Hi @Dudeherocks

Yes, we know that some players have issues with lag. However II recommend you to try some stuff, just to be sure that it is not something on your side:

  1. In steam, in AOE2 game, Properties → Local Files → Verify Integrity of game files
  2. Unable your mods
  3. Uninstall/unable your antivirus
  4. Update direct X
  5. Delete your user files

For deleting your user files, you should:

  1. Go to C:\Users\YOUR_USER\Games\Age of Empires 2 DE
  2. Copy your user folder to a safe place, it has lots of numbers.
  3. Delete the original and open the game again. A new user folder will be created
    If this works, then copy back the files from your old user folder. Those files are in the folder

C:\Users\YOUR_USER\Games\Age of Empires 2 DE<0>\Savegame, Recorded Games and Save games.

Hope it works, if not, be sure that it is tracked :smiley:

Dear devs! Remove that weird fps lock that’s built into the game for at least one and a half year now (you know, the one that locks to the refresh rate and can lock to half the refresh rate if your performance drops INDEPENDENTLY of the vsync setting) and add exclusive fullscreen mode / DXGI flip model to the game and you’ll see a lot less of these non-specific stuttering / lag complaints.

Having what is essentially forced on double buffered vsync in a videogame in 2021 is really bad and that’s why the game has this weird stuttery feel to it most of the time. I can’t believe for a second that you don’t want to see your game run better.

  1. Done
  2. Done
  3. No antivirus
  4. Done also 50 other games using direct X have no issues.
  5. Now done
  • still not working, still no improvements. Lowering the game to lowest settings doesn’t fix it either. Disabling all of radeons software adjustments to the game doesn’t fix it either.
    FYI this is a 6600XT. My laptop with a crappy 1650 can perform without issues. It’s definitely inferior in every way though.
    This continues to be an issue in multiplayer games. I have no net issues with any other games, including other age games.
    Everyone on my net for LAN parties work just fine. Just me. I have the highest spec rig - one guy is running a 5 year old laptop that was $900 at the time (meaning it doesn’t even have a dedicated GPU) and he can run the game at lowest settings without this tearing/stuttering.

Same exact thing here… Same graphics card… My last PC played this so well… a lot inferior to this one…

And even with a great system I get micro stuttering as well… Not only with multiplayer, single too… and I’ve tried games with one up to 8 AI players… Gets worse at later game.

RYZEN 9 5900X with 32GB RAM, an AMD RADEON RX 6600XT in an M2-SSD Drive, no anti-virus, no mods, no nothing, exceptions on disabled anti-virus also done, for the folder and apps, new win10pro install with driver/bios/os up to date on stable versions… Every test has been done and I apparently get a frame lock that comes from the game as well… But this micro stuttering is really bad… The game became unplayable to me.

Edit 1: Oh and btw, My processor doesn’t go up more than 7% utilization and my GPU 50% (I set the graphics to low and it doesn’t help either.)

Hey Guys, just came here to say that I’ve fixed my stuttering problem on this High end system.

Here are the steps that solved the issue for me.

First off I’ve changed to another monitor… I know that this is weird but I’m not sure if it’s related… Bare in mind though that I used to play with my last monitor just fine in the previous computer I had.

Now I’m using a two monitor setup and my main monitor (where the game runs in full screen mode) is a Dell S2721DGF… Anyways… Lets keep going…

I’ve reinstalled the game and after the install I’ve went to the /user’s folder/games/ and deleted “age of empires 2 DE” whole folder.

I’d suggest disabling steam cloud at least at first for the game… Once done all those things, I’ve launched the game and my game worked. Definitely something related to driver/configuration-stored of the game. I don’t think is related to the new monitor but might be… Like I’ve said I’ve used to use the old monitor as well just fine in a previous set up… So my second suggestion is, update not only your graphics card but also your monitor driver and then DELETE everything from Age 2 DE folder under /user’s/games folder… Also disable steam cloud for the first time at least…

YEEEEYYY I Can PLAY

1 Like

Keep an eye on this. I had a few apparent “temporary fixes” that seemed to rectify the issue. By the next day, it was back.
I also don’t think my 2021 monitor could be the issue but all my drivers are up to date for GPU and Monitor.
I’ve disabled steam cloud and re-enabled it as well.
The biggest fix temporarily was disable radeon’s performance software but that latest a day if even.
I’m not sure if we should consider pushing this onto AMD as well for evaluation.

I will test this when I have some time.

I can confirm. I bought Powercolor RX 6600 XT (Ryzen 5 3600) this week. And problem appear.

After some testing. I happen clearly in TGs after people hitting feudal age.
I can remember some patches ago there was a problem with feudal age and stutters too.

Can someone confirm that?

I am guessing TGs means team games? As in skirmishes/multiplayer?
Yeah I haven’t noticed much if any in single player games, but it does happen vs AI skirmish games.
Mine definitely gets worse after feudal age.
I tested to see if unit population played a role (although it should not matter with my hardware) and it made no difference between 300+ pop cap and 100.
I haven’t noticed any particular unit or building causing issues.

There has been no updates on this. I tried the game again last night - no improvements. Does this forum even have individuals who respond to these inquiries?
Seriously very concerning.
Have any of the other users had any luck fixing it themselves?

1 Like

Same issue. AoE4 works fine, AoE2 DE stutters/lags a lot. It worked fine on my integrated GPU but not on my newer AMD 6600 GPU.

1 Like

This was the state I feared most about AoE2 DE - were we reach the point that all money is milked and I belong to the group with tech. difficulties and nobody cares. Every year I play AoE from fall to spring and right now I’m not able to play for a game which I bought for months.
I started playing AoE 2 HD because I enjoyed it so much. You just could start. Creat lobby. People join. You enjoy. No Problems. No Anger. Just pure fun.

I have 2,500+ hours in the game but I’m unable to play anymore since I upgraded my GPU. :frowning:

Devs, any news or updates regarding this issue?

1 Like

Oh I uninstalled the game and refunded AoE4. They aren’t getting anymore money from me until they start showing some decency to at least provide updates/solutions.
Speaking with my wallet.

1 Like

NAVI is the GPU architecture referring to the Radeon 6000 series. Vega is the one integrated on my motherboard. Sometimes the game runs better in the integrated GPU than in the Onboard one, but again, the issue is the same, but I’m experiencing that it changes sometimes. It is basically stuttering, but sometimes it used to improve when selecting the game to run on the integrated GPU rather than the dedicated. Nowadays it makes no difference.