Game is Removing Mods On Boot

Game Version:

  • Build (101.101.32911.0 4395365)
  • Platform (Steam)

Issue:

After I subscribe a mode, it succesfully gets installed in mods folder and becomes visible at installed mods section. But they don’t work. After I close the game and re-launch, the mods in mods folder gets removed (sometimes one of them, sometimes multiple). Even the non-removed one(s) do not work. I am trying this with “small trees” and “zetnus improved grid mod”.

Reproduction Steps:

1.subscribe a mode and wait until green tick appears.
2. look for mods folder and you will see them.
3. Exit the game (Because the mods are not working)
4. Re launch the game and watch the mods folder at the same time.
5. See those mods get cleaned.
6. Feel sad.

10 Likes

This is happening to me as well. It also seems to be doing the opposite too - the mods I’m currently subscribed to can’t be UNsubscribed to.

1 Like

That’s exactly the same problem I have. I subscribe to a mod, the files properly download and appear in the subscribed mod folder as well but they won’t work. Once I exit and open the game again, the files will get deleted and the mods won’t show up in the “installed mods” tab ingame anymore. If I try to subscribe again the same thing will happen. It’s basically impossible for me to subscribe to any mod.

I signed in with my xbox live account in the game and I’m running the Xbox Console Companion app as someone recommended in another thread but nothing solves the issue.

What’s worse is that I made a mod myself but if I put those files in the local mods folder they won’t load either, though if I just replace the modified files directly inside the folder where the game is installed it will work properly. So yeah, nothing mod related works for me it seems.

1 Like

Those kind of issues are mostly normal for games but I cannot understand how they didn’t fix this after a long beta test period with so many insiders…

Same issue for me, but only for “zetnus improved grid mod” (no problem with “small trees”).

1 Like

it’s completely random over here. sometimes grid works for me but trees gets removed. but after a reboot non works.

I have the same problem. Which kind of files did you modify? I Modified .cur, .ddf, .bnk and png files, only the png files work from the mod folder. When I apply the files directly to the game folder it works…

If the mod manager is not capeable of applying .wem or .bnk files, we will never have sound/music mods available through mod manager.

Mods weren’t available in the Beta, so everything related to them was only tested internally.

I modified .png and .dds which are image files. More specifically, particle effects that are in “…\resources\_common\particles\textures\atlases”. Again, if I just replace those files in the proper folder where the game is installed they would work properly, but putting them inside the local mods folder does nothing. They will show up in the “my mods” tab ingame and I can turn them on, but the game will load the default files and not the ones I modified.

You said the .png files you put inside the local mods folder load properly though, so maybe I’m doing something wrong? Tbh the game doesn’t tell you where to put the files you want to modify or how to sort them, so what I did was creating a folder inside “…\mods\local” with the name of my mod, where I put the path “resources\_common\particles\textures\atlases” and the modified .png and .dds files there. Is that how it should be done?

I just had this same bug :grimacing:

I had the small trees mod, zetnus improved grid mod and the one that zetnus posted to have the original intro of the game. I would like to know how to solve this and be able to have them all without lose one of them each time I try to apply the other one :disappointed:

Same problem. I don’t have any of Zetnus’ mods, but I have the “Smooth Ground Textures with Grid NoSnow” which always stays, while the “Small Trees” mod gets deleted every time the game starts.

I just pushed a fix to the mods service that will hopefully correct these issues. If you’re still unable to unsubscribe or continue to have mods auto-uninstall, let me know.

2 Likes

I can confirm that you fixed it!

I downloaded a new mod and I was able to keep the ones I had and activate them all without any unexpected consequences!

Thank you @DodoNotDoDo :grin:

1 Like

Hi. I’m getting this issue recently. Not only I cannot see the Mods I installed before restarting the game but also, the mods I deactivated and unsubscribed before the restart, comeback active.

1 Like

This issue has still not been fixed. It has been a problem since November, 10 months have passed…why is it so hard to fix? It really feels like dealing with a small indie company…

I think the problem was solved but came back recently.

1 Like

I’m having the same problem.

I unsubscribe and even manually delete a mod but when I reopen the game the mod auto-reinstall itself.

I think the problem was solved but came back recently.

Exactly, I’m 100% sure that the problem was solved right after @DodoNotDoDo claimed that he pushed a fix. Probably something else caused the same problem again.

:arrow_forward: GAME INFORMATION

  • Build: 101.101.37906.0 510S673
  • Platform: Steam
  • Operating System: Windows 10
  • Gamertag: varun2109

:arrow_forward: ISSUE

:question: Describe the problem in detail (below). Please limit to one issue per thread.

Here is the problem I’m experiencing…
Mods go missing on restart, it goes missing in mod directory also. Need to subscribe again and again on restart.


Looks like this issue has resurfaced.

:arrow_forward: REPRODUCTION STEPS

:question: List the steps to reproduce the issue… Be descriptive!

Here’s how to reproduce the issue:

  1. Subscribe a mod
  2. Restart game
    3.Check installed mod

:arrow_forward: GAME FILES

:question: Include a OneDrive or Google Drive link to a SAVE GAME or REPLAY FILE of the game where you encountered the issue.

:arrow_forward: IMAGE & ATTACHMENTS

:question: Attach a SCREENSHOT, VIDEO, DXDIAG .TXT FILE, or CRASH/GAME LOGS (if relevant).

1 Like

Thanks all for reporting this. It was unrelated to the previous issue, but a recent change did cause the same end result. It should be fixed now. Apologies for the inconvenience!

3 Likes