Game is Removing Mods On Boot

I modified .png and .dds which are image files. More specifically, particle effects that are in “…\resources\_common\particles\textures\atlases”. Again, if I just replace those files in the proper folder where the game is installed they would work properly, but putting them inside the local mods folder does nothing. They will show up in the “my mods” tab ingame and I can turn them on, but the game will load the default files and not the ones I modified.

You said the .png files you put inside the local mods folder load properly though, so maybe I’m doing something wrong? Tbh the game doesn’t tell you where to put the files you want to modify or how to sort them, so what I did was creating a folder inside “…\mods\local” with the name of my mod, where I put the path “resources\_common\particles\textures\atlases” and the modified .png and .dds files there. Is that how it should be done?

I just had this same bug :grimacing:

I had the small trees mod, zetnus improved grid mod and the one that zetnus posted to have the original intro of the game. I would like to know how to solve this and be able to have them all without lose one of them each time I try to apply the other one :disappointed:

Same problem. I don’t have any of Zetnus’ mods, but I have the “Smooth Ground Textures with Grid NoSnow” which always stays, while the “Small Trees” mod gets deleted every time the game starts.

I just pushed a fix to the mods service that will hopefully correct these issues. If you’re still unable to unsubscribe or continue to have mods auto-uninstall, let me know.

2 Likes

I can confirm that you fixed it!

I downloaded a new mod and I was able to keep the ones I had and activate them all without any unexpected consequences!

Thank you @DodoNotDoDo :grin:

1 Like

Hi. I’m getting this issue recently. Not only I cannot see the Mods I installed before restarting the game but also, the mods I deactivated and unsubscribed before the restart, comeback active.

1 Like

This issue has still not been fixed. It has been a problem since November, 10 months have passed…why is it so hard to fix? It really feels like dealing with a small indie company…

I think the problem was solved but came back recently.

1 Like

I’m having the same problem.

I unsubscribe and even manually delete a mod but when I reopen the game the mod auto-reinstall itself.

I think the problem was solved but came back recently.

Exactly, I’m 100% sure that the problem was solved right after @DodoNotDoDo claimed that he pushed a fix. Probably something else caused the same problem again.

:arrow_forward: GAME INFORMATION

  • Build: 101.101.37906.0 510S673
  • Platform: Steam
  • Operating System: Windows 10
  • Gamertag: varun2109

:arrow_forward: ISSUE

:question: Describe the problem in detail (below). Please limit to one issue per thread.

Here is the problem I’m experiencing…
Mods go missing on restart, it goes missing in mod directory also. Need to subscribe again and again on restart.


Looks like this issue has resurfaced.

:arrow_forward: REPRODUCTION STEPS

:question: List the steps to reproduce the issue… Be descriptive!

Here’s how to reproduce the issue:

  1. Subscribe a mod
  2. Restart game
    3.Check installed mod

:arrow_forward: GAME FILES

:question: Include a OneDrive or Google Drive link to a SAVE GAME or REPLAY FILE of the game where you encountered the issue.

:arrow_forward: IMAGE & ATTACHMENTS

:question: Attach a SCREENSHOT, VIDEO, DXDIAG .TXT FILE, or CRASH/GAME LOGS (if relevant).

1 Like

Thanks all for reporting this. It was unrelated to the previous issue, but a recent change did cause the same end result. It should be fixed now. Apologies for the inconvenience!

3 Likes

Thank man. Indeed fixed.

I just submitted a mod and subscribed to it, however it doesn’t launch, and when I restart the game I see the folder disappear in front of my eyes! Is there some waiting time between subscribing and restarting the game that we should be aware of?

Right now it’s not enough to just sign up for the mod on the site, you also have to sign up for the game and wait a while without leaving the game for the mod to fully download. A circle usually appears to me to the left of the mod name which means that the mod is being downloaded. Only when it disappears do you download the mod.

Hi, is it possible to unsubscribe to the mods for events? When ever I try to unsubscribe one of those mods then come up active next time I play the game. For example, the trophies and TCs decoration.

1 Like

@DodoNotDoDo is there any news on a fix for this?

It’s still happening - whatever the code is for this part of this sytem, it really should be regression tested each time any new code/fixes are implemented since it seems to be frequently impacted.

The issue with being auto subscribed to the event mods? Depending on timing, it could be related to a recent event where previous event mods were re-enabled so may have gotten resubscribed. But even if they’re subscribed to, you should be able to deselect them so they’re not enabled.

So I guess I need more detail on what you’re referencing, like specific mod(s) and if they’re auto subscribing or auto re-enabling or what’s happening.

It’s actually the exact same issue as the very original post reported, including the replication steps.

Perhaps though, as you said, it’s to do with timing, since I can see today they have launched a new challenge event, perhaps this is interferring.

I’m not seeing an issue in my testing, nor do I see any problems with the backend system. If it does continue for you, please start a new bug report (since this one is marked solved) with as much detail as possible so the game team can check it out.