Game keeps crashing every 15-25 minutes

I play the game via the Gamepass Ultimate on the Xbox App (Microsoft Store).
I am running on Windows 11, all latest version + NVIDIA drivers with RTX 3060 Ti and Ryzen 5 3600X. The game runs fine with all on maximum settings, HDR and 4K resolution.
But the game crashes out of the blue in regular time intervals of roughly 15-25 minutes. Two of my friends experience the exact same issue, they also play via Gamepass and on Xbox App. They however are on Windows 10, one with Intel CPU + AMD GPU, the other one with same setup as mine.
We crash with just a few minutes apart, like when I start the game first, I will crash first. When friend started the game like 2 minutes after me, his game will crash 2 minutes after mine. It’s as if there is a dead time counter.
There is no error message, just closed window instantly with no freezing whatsoever.

How can this be resolved? I believe this is even related to the Xbox App with Gamepass because it has happened with two other games “Snow Runner” and “State of Decay 2”, too.

9 Likes

Me and my friend are experiencing the same problem, Xbox app game pass.

2 Likes

Me and my friend are experiencing the same problems. 10-15 minutes of game play and his game closes automatically. My game closes on its own shortly thereafter. We are using Xbox App and Gamepass.

2 Likes

a friend of mine has the same problem also on xbox gamepass
i’m running it fine on gamepass though… whats the problem ?

2 Likes

Same issues, exactly. Tried updating drivers, etc, etc… 15 min. crash

2 Likes

Same issue. Steam version, Windows 10, 11700k, rtx3080ti

2 Likes

Is there anything in the “warnings.log” for you guys?
You can find it under c\user\your name\documents\my games\age of empires 4

1 Like

You want this to happen you just don’t know it.

Together with my friend, I also encountered this error, played two games in a closed lobby with a duration of probably 20-25 minutes and literally flew out of the game at the same time, tried it a second time, flew again, but with an interval of 2 minutes.

A similar problem was in another Back 4 Blood game after we decided to try to play not through the xbox game pass ultimate, everything is fine without any problems.
The problem is clearly in the xbox game pass, but here’s how to fix it?

1 Like

No, unfortunately nothing useful inside it.

Hello, appreciate the report. We’d love to look into this further. Would it be possible to have anyone hitting this issue write in here: https://support.ageofempires.com/hc/en-us/requests/new?ticket_form_id=360001686692 to our support team and provide both their DxDiag and warnings.log file (found under Documents/My Games)?

Thank you!

4 Likes

MissValent1ne, done. Hope it helps.

Thank you for the response! I have also contacted the support already, including the files that you mentioned.

Thank you, much appreciated!

Done, hope it helps too. Thank you.

I have a problem, my game is closing alone. The first time the game closed in the tutorial, it was running very well and just closed. The second time I was playing a multiplayer game and closed too, inside the game I had no problems with FPS. My friends had this problem too. I’m playing using the Xbox game pass

My Notebook: Ryzen 7 4800H 2.90GHz
GTX 1650Ti
8GB RAM
SSD 512 GB

Me and my friend are experiencing the same problem, Xbox app game pass…

2 Likes

Same exact thing here. Xbox game pass for PC,3090 FTW, intel 10900k, 32 gigs of Ram, Windows 11, all recent drivers, tried several different “fixes” I found on the internet/youtube (shut off overlays). None of them work, It almost feels like I am on a timer to shut the game off after 25 minutes.

I found a fix for me…it was my CPU overclock. I had some software that was overclocking it, so I disabled it on startup and then went into BIOS and made sure overclocks where off (basically I set everything to auto). Seems to be working, completed a couple games without crash. Try it, just turn off any overclocks for RAM/CPU

Me and my cousin are experiencing the same horrible problem. Crash in 20-25 minutes in multiplayer using XBOX GAME PASS ULTIMATE.

32GB RAM, 2080 SUPER NVIDIA, 10750H Intel

We need a big solution for version: 5.0.7274.0.