Game keeps crashing every 15-25 minutes

I have solved with checking “offline settings” in XBOX General options

I think I solved it. i was having the same problem so I bought my son his own gamepass account.
it seems family sharing doesn’t work on PC

The game crashes out of the blue in regular time intervals of roughly 15-25 minutes. My friend experienced the exact same issue, they also play via Gamepass and on Xbox App.
There is no error message, just closed window instantly with no freezing whatsoever.

12 Likes

Thanks for the report :slight_smile:

I am having the same issue also playing on gamepass. I have had no issues with the campaign but every time I start a single player skirmish vs ai it eventually just closes the game sometimes right away sometimes 10 or 15 minutes in.

‘singleplayerpage.xaml’ is corrupt! Unable to continue.

when I look in the warnings this is one of the last lines also it crashes just slicking single player to actually playing in the game for 15 minutes and everywhere inbetween

Have you overclocked you GPU? I noticed that my game will crash at random when OC’d, but going back to the default values fixed it. I haven’t had a single crash since (playing on Gamepass/Xbox app)

No I have not over clocked anything it doesnt crash at all on the campaign just on the skirmishes

Did you find any solution? i’m having the same issue, also playing on Gamepass

I uninstalled the game and reinstalled it I’m checking it out now. Hopefully that solved it.

The game crashes here too! There is no error message, he just closed to window instantly making for me difficult to understand the problem. Im playing with Gamepass and on Xbox App. My Game pass Pc is shared with my partner and she have the same issues with different pc build (all stay in requisit) and internet provider, there is no difference if we are in tutorial, multyplayer ecc… near 17, 22 min the crash come evreytime making experience frustraing. I hope can be solved in short times. I found only this forum speaking about this type of crash without error.

Can you see an application error in the Windows event viewer?

[Windows] + [R] type in: eventvwr
In the new window you can see the tree on the left side. Navigate to “Event Viewer (Local)” > “Windows Logs” > “Application”.
I guess here you can find an error message about Age of Empires IV.

after uninstalling and reinstalling I have had no more problems the skirmishes are now working for me.

There’s nothing helpful in there

Name der fehlerhaften Anwendung: RelicCardinal_ws.exe, Version: 0.0.0.0, Zeitstempel: 0x616a29bc
Name des fehlerhaften Moduls: RelicCardinal_ws.exe, Version: 0.0.0.0, Zeitstempel: 0x616a29bc
Ausnahmecode: 0xc0000005
Fehleroffset: 0x00000000008badb2
ID des fehlerhaften Prozesses: 0x42e0
Startzeit der fehlerhaften Anwendung: 0x01d7cca92e673f79
Pfad der fehlerhaften Anwendung: C:\Program Files\WindowsApps\Microsoft.Cardinal_5.0.7274.0_x648wekyb3d8bbwe\RelicCardinal_ws.exe
Pfad des fehlerhaften Moduls: C:\Program Files\WindowsApps\Microsoft.Cardinal_5.0.7274.0_x648wekyb3d8bbwe\RelicCardinal_ws.exe
Berichtskennung: 895717b4-fbd0-4f94-a21b-badf9705b790
Vollständiger Name des fehlerhaften Pakets: Microsoft.Cardinal_5.0.7274.0_x64__8wekyb3d8bbwe
Anwendungs-ID, die relativ zum fehlerhaften Paket ist: Game

Same exact thing here. Xbox game pass for PC,3090 FTW, intel 10900k, 32 gigs of Ram, Windows 11, all recent drivers, tried several different “fixes” I found on the internet/youtube (shut off overlays).

getting same error as well
Faulting application name: RelicCardinal.exe, version: 5.0.7274.0, time stamp: 0x616a2b32
Faulting module name: RelicCardinal.exe, version: 5.0.7274.0, time stamp: 0x616a2b32
Exception code: 0xc0000005

After chatting with technical support everything was immediately clear. In my case, I was playing with shared account and the person sharing the service with me hadn’t activated in the xbox app, under settings, Offline permissions enabled.

We are going to try this option of “Offline settings”, but I think it’s not going to help. We will see

I had it deactivated

I might have found the reason for the crashes, for me it was iCUE that was at fault, the fancontrol software from Corsair, below a reddit thread about more info of the stuff I tried so far with no success and the hardware I’m running:

Only after shutting down iCUE and disabling the service from starting up on boot did I stop experiencing more crashes, so anyone running iCUE, stop it, as for the devs this might help reproduce the exception on their end and debug it.
Found out about this after running AoE4 as an Admin, so iCUE naturally crashed since for some reason it tried to access the RelicCardinal process which due to lack of higher permissions caused iCUE to crash and bring RelicCardinal down with it.

2 Likes

Do you guys turn of V-sync? I used to get crash so often like you do, but after I turned on V-sync, the game run much more stable for me.