Game spontaneously crashes after latest update

26 days. 26 days and it’s not been fixed.

Time to get refunds.


almost 3 months and still no fix…

going to 4th month soon!

No worries. I’m still waiting for save chapter glitch fix…and it’s going to complete its 2 year anniversary

What glitch is that? I haven’t heard of it.

For me I can’t get through a full game without crashing. Sometimes don’t even get to start before it crashes lol. All since this stupid xbox update.

The game is unplayable at the moment!
Game is crashing spontaneously!

1 Like

After the previous patch the problem was solved. But today the problem is there again! :-/

1 Like

Hi @DBodes
Can you tell me exactly when this happen? We’re tracking that joining a lobby using an URL the game may crash.
Can you also check if the game is generating mdump files?
Thanks for the report and sorry for the inconveniences.

The game crashes in ranked 1v1 and ranked team games. In a solo game to. Suddenly the game closes and it disappears.
Here are some details from the last game:

2023.05.17-18.43.38.txt (10.1 KB)
Age2CrashReport.txt (4.1 KB)
DxDiag.txt (113.0 KB)

1 Like

Just happened the same at me too, it was 3v3 ranked arabia.
At around the 12th minutes, it just dropped me out to the desktop.
Because of the hotkey issues in the recent Rome DLC (which I bought) I freshly reinstalled the game yesterday…
Earlier never had such issue.

@DBodes @moleMTL is your game generating mdumps?
You find those here:
“C:\Users\USER\Games\Age of Empires 2 DE\logs”
They look like:

Overlays from Nvidia, Discord and Steam can also cause crashes. You should also add the whole folder of the game to your antivirus exception list after every update. Sorry for the inconveniences.

FYI. Checking the error logs of @DBodes I noticed a lot of r-link errors which most times indicate an error with his cross-play configuration, e.g. using other Xbox account signed in (not connected to Steam account for Xbox/Store clients cross play) or lack of installing the latest MS Store (Xbox) updates although Steam client did update the AOE2DE game client.

Hello, On my side I checked for the minidump, but there is no such in the mentioned folder. In my case the crash was very quick, just dropped me out to the desktop, no slowing, no lagging (there was some game lag though earlier, but it looked like a normal network lag) prior to the crash. I reported that crash in a different ticket also
maybe it is a different kind of issue.

1 Like

Everyone i know on xbox with the return of rome dlc is also having a similar crashing issue.

Unfortunately there are no current mdump-files. There are only old ones from february.

In the last months every second patch create the problem and after the next patch the problem is no longer there. I hope you plan the next patch very soon :wink:

In my perception i do nothing special in the moment of the crash.

Are you getting the bugsplat window?

No, the game closes und the desktop is on the screen. No window to report the bug, no hint what closed the game.

Edit: I startet the game just a moment ago and there the bugsplat window appears after starting the game. I sended the report with the link of this thread. In the first time the problem occured, there was a ingame window after starting the game new.

May Hot Fix - Build #84485

I opted in to the beta in Steam, looks like the problem was solved, I could finally finish a single RoR campaign without any sudden closing to desktop. Will keep updated here.

1 Like

Ich bekomme beim Start über Zuschauer-Dashboard ( eines aufgezeichneten Spieles BUGSPLAT.
Gibt es dazu BITTE eine Lösung ?!