Game stuck in splash screen, accessing non-game files on my drive

:arrow_forward: GAME INFORMATION

  • Build: 101.101.39515.0
  • Platform: Steam
  • Operating System: Windows 10
  • Gamertag:

:arrow_forward: ISSUE

I haven’t played the game in a few weeks. Today, when trying to launch the game, it got stuck in the splash screen while using a constant ~12% of CPU and a sparing amount of disk IO.

I tried:

  • Launching from the Desktop or Start Menu shortcuts
  • Launching from Steam
  • Run as administrator (cough), including running steam as administrator first, then launch the game from there
  • Removing game folder (C:\Users<USERNAME>\Games\Age of Empires 2 DE)
  • Verifying integrity of game files in Steam
  • Uninstalling and re-installing the game from Steam, with or without the graphics pack DLC

None of these makes a difference.

The game remains stuck in the splash screen. I suppose it is possible that it will eventually be able get past that, but I have waited 10-20 minutes and it still wasn’t done launching.

Eventually, I got fed up with it. Being a developer myself I decided to dig in a little and observe what the game is doing that is taking so long.

First, I used Process Explorer to gather a stack trace of the active thread. It was actively spending time making IO-related system calls (reading/writing/stat-ing files and directories, etc).

Then, I used Process Monitor to investigate what files it was reading.

To my surprise, it was spending those CPU cycle and disk IO going through my personal files that the game absolutely should be accessing!

As far as I can tell, it was crawling through my entire drive indiscriminately. It just so happens that I recently cloned a Node.js project on this machine. Node.js projects tends to have a ton of small random files due to their node_modules structure. The game happened to have found its way there and got “stuck” churning through a ton of files. It is probably not much of an exaggeration to say it was behaving like a virus at this point.

After moving the project into Recycling Bin, I tried launching the game again. This time, it got stuck similarly but in the system temp folder (C:\Users<USERNAME>\AppData\Local\Temp), which is also very big for related reasons (it’s common for Node.js tools like yarn to put their cache files at that location).

After removing (almost) everything in that folder, the issue is “fixed” and the game finally launches in a reasonable amount of time.

Needless to say, I am not pleased. Fortunately this is a Shadow VM that doesn’t have a lot of sensitive or personal files on it, but still. WTF. :neutral_face:

I am not going to assume malicious intent by the developers. Bug happens and I understand it. But this is not cool and please be a lot more careful going forward. Please look into putting in some safeguards to actively avoid this (accessing files the game should not be touching) going forward.

Here are some potentially related details and hypothesis of what happened:

  1. Since the last time I played the game, I enabled developer mode for Windows. Among other things, it enables Symbolic Links.

  2. I noticed the game creates some files in the system temp folder, the same one that has lots of files (yarn cache, etc) and possibly symlinks into other places. Perhaps there is a bug (perhaps an extra “…” in a path somewhere) that causes it to traverse the entire temp folder, following symlinks and upwards.

  3. I hope this is not the case but perhaps the game uses some very aggressive anti-cheat or DRM that purposefully scans all the files on disk.

I hope we will get a response from the developers on this as this is quite alarming, especially when some of the most common suggest for “fixing” problems like this is “Run as Administrator” (I did it out of desperation and knowing that this is a dedicated gaming VM, but please don’t do it, it won’t fix this issue and just increases your exposure).


I looked into this a bit more and I’m pretty sure the problem is that the game tries to search through every single folder and file in %TEMP% (C:\Users\<USERNAME>\AppData\Local\Temp) probably to determine whether a particular file exists. It never seems to find it, so I don’t know what it is looking for. If you have a lot of temp files in that directory, or if you are unlucky enough to have a symlink pointing outwards from the temp directory, then you are going to have a bad time.

What issue are we talking about in this thread?

The game takes a long time to lunch, stuck in the splash screen – the not-fullscreen, not-interactive, not-clickable picture that shows up on your desktop while the game launches. If you are having issues before that even shows up, then you probably have a different issue as well.

From my experience, this happens before the splash screen switches your mouse cursor to the “AOE cursor”. If you are stuck in the splash screen but are seeing the AOE cursor, you probably have a different issue. On the other hand, if the game launches into fullscreen mode, then you probably have a different issue also.

For most people, the game eventually get past the the splash screen and finishes launching, though it can take an incredibly long time. Some have reported it finishes launching after 30 minutes. In my case, it takes so long that I either run out of patience or my Shadow VM times out and shuts down, so I don’t really know whether it will actually finish. However, it does not crash. If the game crashes for you during the splash screen or otherwise, this is not your issue.

This also seems to happen (for me at least) before any meaningful logs are written. If you see a lot of things in the logs while the game is stuck “loading”, then this is likely not your issue.

Also, this problem occurs with or without any mods. It even happens on a clean re-install of the game. If the problem goes away when you are not using any mods, this is not your issue.

Finally, this is not about having too many files on your computer in general, that your disk is too full or too slow, etc. This is (in my opinion) clearly a bug specific to the game, totally unnecessary and definitely should be fixed. It’s strictly about the number of files/folders in the %TEMP% folder (unless you are unlucky enough to have symlinks that points elsewhere, but it’s probably relatively rare). It is the number of files that matters, not the content, size, type of the file, etc.


Until this is fixed, if you are having issues with the game taking forever to start (stuck in splash screen), the workaround is to remove files from your temp directory. The fewer files it has to check, the faster the game can start.

The easiest and safest way to do this is to use “Disk Cleanup” from start menu, uncheck everything and keeping only “Temporary Files”, then run the cleanup. This will remove only stale files that hasn’t been used/changed for a while. Give it a shot and see if it “fixes” the problem enough.

If that doesn’t do it, then you can manually delete things from there. Open explorer and type %TEMP% in the address bar. It should generally be safe-enough to delete everything from here, but obviously I can’t take responsibility for that.

This is usually used as a “scratch pad” area for programs and they should just recreate the files as needed. If the file is in use or created as administrator, it will either not let you do it or prompt you about it. When in doubt, leave things alone.

To be super safe, you can reboot, close as many programs as possible (giving them a chance to clean things up themselves), then delete everything that Windows will allow.

Note that this can make the programs that needed those files slower the next time you use it. Presumably they created those caches for some reason to memorize something that takes a while to compute or download form the Internet. By deleting them, they will have to redo the work next time, whatever it is.

Related Issues


This was solution to my problem, thank you, you absolute hero <3

1 Like

None of the solutions work for me… the game still take 1:20 mins to start from the splash screen.

I also tried Low Graphics, disabling all mods and reinstalling : no improvement.

Before the last patch, the game took at most 8-9 seconds to load. I don’t know what else to do.

If it really bothers you, I wrote about the process I used to find my particular issue in this longer thread. It’s kind of a long shot, and is not going to directly fix your issue. It may help find what is causing it and from there we can try to find a solution. Just leaving it here to link the two threads.

In my case, the game practically wouldn’t launch so I was pretty invested in getting to the bottom of this back then. Good luck and if you decided to try it, let us know what you found and I may be able to offer more help at that point.