Get AI to build Dromons

So has anyone figured out how to make AI produce Dromons yet? I tried using the unit ID’s (1795), but doesn’t seem to work for some reason.

My line of code is this:

(goal activate yes)
(unit-type-count-total 1795 < 3)
(can-train 1795)
(difficulty == hard)
(train 1795)

I tried manually enabling the Dromon unit using a trigger (although it shouldn’t be necessary with Byzantines as they can already build the unit), but it doesn’t change anything either.

Any help or suggestion is most welcome!


I was trying to make Huns train Mangudais and for some reason, I had to place a lot of castles in the scenario editor for them and give them a lot of extra population and it worked. After that, I removed the castles and it kept working.
Try to remove the difficulty and goal conditions and add a chat-to-all effect, as a debugger, so you don’t have to wait until they actually train dromons

Thanks for the reply.

I’m experiencing this issue specifically with Dromons, and not for any other unit in my case (using Object IDs or full line of code). I also have entries for all Difficulty settings, so we should bar this from the list of possible issues I reckon.
It’s not a population, or anything in-game related, as the IA in the scenario in question has it all. In your own case, it might just have been that you haven’t “Enabled” the Mangudai for Huns and set a custom training locaiton through triggers? (I don’t know if that’s the case or not).

Thanks for the replay anyway!

It was the first thing I did.

Also, could it be that you are training oher stuff in the dock and that prevents dromons being trained just because qeue is full? Try placing a stupid amount of docks and see what happens

Yes, I ran tests on 20m, 5 docks with a fairly low amount of units in queue at any time, but to no avail, all other ship types are being produced correctly, but not the Dromons.

At this point, I am certain that it isn’t an in-game problem, but an AI code issue. I figure that the game doesn’t recognize the Dromon’s Obejct ID for some reason?