Health bar units disappearing

When you are ingame it happens a lot to me when i click a single unit or a group that the health bar disappears, this is not the case with buildings only units

Thanks for letting us know. We’ve forwarded this along to our team for review.

If I set Gameplay Resolution Scale at any number except 100, HP bars never show up for units.
Always On, Selected, Smart, no matter whatever setting for HP bars.
It’s completely fine when it’s set at 100.

1 Like

Thanks for the report, we’ve forwarded this along to the team to investigate.

Thank you! I have spent the last 3 hours trying to figure out how to get them to work. My scale was automatically set to 75 and no unit healthbars would work until I set it to 100. Buildings, walls, and even siege worked fine. I didn’t even want the scaling changed…fine at 100 for me.

1 Like

Glad to hear this worked! We’ve got the health bar issue logged as a bug to get looked into on our end, but until a fix is implemented the 100% scale is the best way to ensure they appear.

Even when I select the ‘always on’ option for health bars, I cannot see any health bars for units.

6 Likes

Hi there, we’re looking into this issue currently.

Other players have however noticed that ensuring your Gameplay Resolution Scale is set to 100 (in Settings → Graphics → Gameplay Resolution Scale) should ensure the bars always show.

1 Like

Hey OMGBoxShark, it shows but setting it to 100 decreases the game performance, is there a way to fix the health bar not showing without setting the gameplay resolution scale to 100. Thanks!

1 Like

This worked, thanks.

However, a word of caution: when I changed the resolution scale in the menues outside of a game, the game crashed as soon as I tried to get into a game. However, once I changed it while already in a game (starting the game at 90 then changing it to 100) it worked from then on.

Your best bet would be to change the resolution of the game instead of scaling. You can do this for most display modes (windowed) in-game. I believe it’s Exclusive Fullscreen you aren’t able to set resolution in-game, but could change your Windows resolution temporarily as well.

1 Like

I am really sorry to sound stupid or harsh, but why should I degrade my graphics setting just to see health bar?

2 Likes

I have to add myself to this problem. I am gaming on 4K monitor, and for optimal performance, I tend to lower the scaling to 90% to hit stable FPS.

Currently, your advice is to affect my FPS(which itself is not that stable) just to see healthbars?

This just simply wont do.

Please fix this issue, it is plaguing A LOT of users (you can read about it all over internet/steam forums)

I am sure it wont be that difficult for a talented team such as yours.

Thank you

2 Likes

While I understand it’s not an ideal solution, until a bugfix can be implemented, this is the best way to ensure they show up in-game right now.

Is this bug tracked and being worked on? I echo other people’s opinions, you can’t simply ask us to use display scaling (will also need to scale the UI) or a degraded experience for an extended period. I understand and appreciate a workaround, but the fact this workaround is present should not put less importance on fixing the bug.

1 Like

Why “smart” Healthbars only show wounded enemies and not my own wounded units?

Isnt that a nobrainer? Need to know my wounded to individually micro them back. See the wounded vills who are chopping on that tree on the far edge and stuff.

Whislt on the subject… Why do the health bars fade during combat, even with “Always On” ?? Is it a bug or a feature?

Thats exactly when I need to be monitoring health bars to be able to move units and the only way to see them completely is by selecting the units… Which is absurd as their portraits dont even show on UI.

Correct, our team is looking into this issue to identify the cause.

Thanks, looking forward to it. In the meantime the display scaling works well enough for us to enjoy the great game!

Version: 5.0.7274
Version: MS Store

No matter which option I choose under UI -> Healthbars my units have none, only buildings.
I have an RX 5600XT - could that be a driver-related problem?

2 Likes