How to set hotkey for a non generic unit in the Castle

I have been trying to set a hotkey for the Royal Janissary in the Castle, after setting its train location. The key is setting hotkeys is to choose add and then put one number in the small box to the right. But no matter with how many numbers I tried, I still can’t set the hotkey.
I have also tried by setting or subtracting the hotkey.

Each unit has a default Hotkey ID, you gotta use one already existing corresponding to the desired position of the creation icon within the creation menu. For instance, location 1 (the top left position within the creation menu) is occupied by the militia line in the barracks. Militia hotkey ID is 16079 (check in Genie Editor). So if you set any unit’s Hotkey ID to 16079, this unit will have the corresponding hotkey.

Where did you place it? If it’s in the fourth square, I’d recommend using Mercenary Kipchak hotkey.

I am trying to replace the Elite Janissary with the Royal. Is it possible, to do that and use Q as a hotkey?

At the start of the game, change train location of Elite Janissary to Castle first square AND hotkey id to Elite Janissary hotkey ID. You can get this ID by looking at Advanced Genie Editor.

Use other trigger with a Elite Janissary is researched condition and as effects, disable elite Janissary and enable royal janissary AND replace every janissary and elite janisary to royal janissary

Edit: janissary hotkey ID is 16105; elite janissary hoykey id is 16455
Edit 2:
RoyalJanissary.aoe2scenario (1.6 KB)

I made a little example with three triggers:

  1. At the start of the game change train location and change hotkey
  2. After research, enable Royal janissary and disable Janissary and Elite Janissary and trigger next trigger->
  3. Looping trigger to replace every Elite janissary to Royal janissary. It’s looping so it replaces every janissary that’s being currently trained at some other castle at the time of finishing the Elite research, when it spawns.
1 Like

Thanx. It works.

I seem to have another problem with the Tamar campaign (I have posted about it)> Can you look into it?

That’s a recent known bug.

So you say I 'll need to play the scenarios again?

Not until the bug is corrected