I can't download from the store

I bought the game but it won’t download.

1 Like

Hi @baddkat30, Did you purchase Age of Empires II: Definitive Edition from the Microsoft Store or Steam?

I bought it from the microsoft store.

Do you have Windows 10 version 1903 installed? It is required that Windows 10 on your PC is completely updated to install and run Age of Empires II: Definitive Edition. If you click the start button and type “winver” and press Enter it will tell you the version of Windows 10 installed on your PC.

For more help please see the Age of Empires II: Definitive Edition support page under Download and Installation Issues.

Yes. I have windows 10 1903 version.

I don’t know if this is relevant (or not), but the last Windows 10 version is the 1909 (November Update).
I received it with Windows Update, but it can also be downloaded with the Windows Update Assistant Tool and you can also have a fresh installation with the Media Creation Tool.


Alright. Did you walk through the linked Download and Installation Issues troubleshooting steps?

I did. It says I need administrator approval but its my computer and I am the administrator, right?

Including all of the steps relating to being an administrator below?

Windows Store: I receive an error and cannot click the install button: ‘You must be an Administrator.’

If you encounter this error, there are several troubleshooting steps you can work through to try and address the problem:

:hammer_and_wrench: Check to see if the Install button works despite the visual error.
:hammer_and_wrench: Check for pending Windows updates. Verify that there are not any pending Windows updates. While you may be on an up-to-date version of the OS, there may be essential application updates waiting to install. Be sure to restart your device after installing any updates.
:hammer_and_wrench: Reset the Windows Store App. You can find instructions on how to do so HERE.
:hammer_and_wrench: Run the Windows Store App troubleshooter. You can find instructions on how to do so HERE.
:hammer_and_wrench: Use the System File Checker to repair Windows Store. You can find instructions on how to do so HERE.
:hammer_and_wrench: Restart your machine multiple times. It may take several restarts to finish identifying and installing a critical update. Try restarting your machine to recognize any new or missing updates.

If you continue to experience issues after running through all of the above steps, please contact the Microsoft Store Support Team.

I also bought this game on Microsoft store a few days ago and it wont let me install it. I have version 1607 and when I try to update it its stuck on 95%! I’m also the administrator of the cp.

1 Like

I have Windows version 1909 and I’m the administrator of my computer. Nothing works so far. Even followed the instructions provided above of checking for corrupt system files, resetting the store, etc with no luck. This sucks as it’s the only game I cannot download from the Microsoft Store. All other games, download/install fine except this one (and the first release of the game which is Age of Empires: Definitive Edition). Should’ve bought this from Steam instead :frowning:

Same thing happened with me. Updates, was able to indicate it would try to download… Nothing. Finally logged into the web based version of Microsoft store, found my game clicked it on the web browser and bingo finally started to download. One of the most aggravating things I’ve experienced in awhile. Hoping it’s smooth from here!

I bought the game today on microsoft store, and I can’t download it.
I have this code error : Code : 0x8007065E

What can I do ? Do you have suggestions ?

I’m getting a 0x8007001F error. Tried every possible fix I found (new admin, reset store, reset windows update, clean boot, …).

Any ideas how to fix?

@Sulphur69 and @Sulphur69

Could you check this very extensive TS guide.

Also is there any third party antivirus application or internet security application installed?

Same issue here. I have literally tried everything.
Wish I would have purchased a different game or the steam version.
PowerShell doesn’t work. Firewall is uninstalled, Microsoft Store reset, created a new Windows user account, tried downloading XBOX app beta (it does not even start downloading after getting the installer from the website).
So frustrating.

1 Like

Okay, found the solution for me.
A Microsoft Service for “storage service” was deactivated in the microsoft settings.
I remember that I disabled it years ago because it was drawing too much of my windows performance.
Now it runs smoothly.


Thanks for reporting this solution back. They have added that from 1903 on and sometimes it’s not activated after upgrade of previous version too, it reserves some space for that purpose and if you are low on disk space already it could be in disabled state.

Have fun wit the game and stay safe at home.

Hey been having a similar issues, what do you mean by storage service and where do you activate this in windows settings?

I have been trying to dowload AOE2 since yesterday evening. Tried again for half a day today. Downloads a small part of the file and then gets stuck. I have restarted the store, rebooted windows, cancelled and restarted the download several times. Nothing works.