⚠ IMPORTANT ⚠ Stuck on AoE:DE Build 27674? Upgrade to the latest client! (Windows Store)

Out of curiosity, I checked the 3 dots on the top.
From there I checked my library and I found all the stuff available ti me. Aoe DE was there too.
The “download” button was available, so I am downloading.
(hopefully the correct version?)

1 Like

@PCS70 & @GMEvangelos
Sorry for the delay, I was restricted in number of posts as this was my first day on the forum. It was also night in France! :slight_smile:
My lone problem was to install the new multiplatform version from the store.
But today, it is fixed. Version 100.1.20218.0.

I tried with another PC and account. Gaming Services installation fails if you do not use first a session with an account with admin right.

Below is how it worked for me.
1/ Installation of Xbox beta in standard account
2/ try to install Gaming services in standard account with elevation thru another account failed
3/ Installation of Xbox Beta then requesting Gaming Services installation loggued with an admin account allows a first installation of Gaming Services.
4/ Then with standard account you can install Xbox beta and install gaming services thru store with elevating your rights with the same admin account you used for the first installation.
5/ When done you search your AOE DE in store in standard account and install with success !

It seems to me that “Service Games” installation is not clean when done with elevation of right thru another admin account.

Hope this helps.


Olá Amigos,

Eu comprei o jogo bem no comecinho na Windows Store, porém muitos amigos meus compraram pela Steam. Eu fiz a leitura acima, dizendo que a partir de 19 de agosto de 2019, todas as plataformas estariam juntas para jogar em multiplayer, essa informação se confirma ?

Hello friends,

I bought the game from the beginning on the Windows Store, but many of my friends bought it from Steam. I read above saying that as of August 19, 2019, all platforms would be together to play multiplayer, is this information confirmed?

Yes. This post is all about this new cross platform AOE DE upgrade.

1 Like

ScoutingSheep As far as I understood, the grey icon AoE DE is the old client, but it shouldn’t be downloadable now… so not sure :s

@ScoutingSheep It is greyed, so it’s still the old client. If you search Age of Empires Definitive Edition and have the right windows version you shouldn’t see this one and only the right one.

If it somehow help you, here the link : https://www.microsoft.com/en-us/p/age-of-empires-definitive-edition/9njwtjsvgvlj?CustomerIntent=Consumer&activetab=pivot%3Aoverviewtab

Apparently i need to download an update?

I thought i just need the 1903 build. It’s all so messy.

Seems it isn’t right. Check by writing winver in research bar on windows
It will tell you the exact version of windows you have.
If you’re not on the right one and update doesn’t propose you to do so, use their manual updater, you can find it easily with a google search.

1 Like

Yeah, It seems i have the 1803 build.
The 1903 i read was like “what you will find in 1903”
Updating now.


Wait…I have to redownload all 17ish gigs instead of a patch for just crossplay???

@GrizzGolf Yes.
Ok, Guys. It works.

Hi there, big problem …

I just installed the new 28218 Build and have now at least two problems:

  1. whenever I move the mouse over a button (menu), a building (in the game) or a unit (in the game), a woman’s voice reads the button text or explains something about the building or unit!
    (No, it’s not the windows 10 voice feature - I can activate this additionally )
  2. several texts inside the game are overlapping with other text or GUI elements.

while 2 is just annoying, 1 is a no go and makes the game unplayable! :frowning:

Can anybody help?
I’ve Windows 10 1903 with latest updates - is it possible to re-install the latest 27xxx Build?
(Unfortunately, I’ve deleted it :frowning: )


Hello, i unlocked all achievements in the old version but they did not transfer to the new one as promised in the Faqs. How can i fix it? (I play with the Windows Store version and is patch with the latest one). Thanks

For the voice you just have to desactivate the accessibility option in the games option.

1 Like

The AOE1:DE in Steam doesn’t seem to have a Workshop or Modding capability? Why would one buy it if not playing multiplayer (maybe)? I have it on Microsoft Store or whatever it is. And it feel very laggard and unwieldy and the scenario editor has resolution issues where the tabs on the top are microscopic (anyone know how to fix that?).

@kinzoplus thanks for your hint!
The german translation for this option is very misleading. But because of the answers from you and another player, I solved this annoying problem. Thank you!
Don’t know, why these options were activated by default … never heard this in years of playing AoE :wink:

Are you using the same gamertag when you login as you did on the old version?

Yes, i use the same. But do not worry. I will just unlocked the again je.

Hey All,

I finally upgraded to the new version on the microsoft store. It seems like the base of players is essentially non existent for the new version and it should also have steam players?

Anyone else share this experience, or is it maybe something wrong w/ my config?


Seems like my problem of downloading with the pop-up error: “Try again later” has been resolved by a manual reinstall of the Windows Store through powershell as it was suggested by Window’s ‘Get Help’ virtual assistant.

Funny, because wsreset command and resetting the app through Apps & Features apparently wasn’t enough. No guarantee this method will work for others.

  1. Make sure your Windows is on 1903

  2. Launch PowerShell as Administrator (right click -> Run as Administrator)

  3. Run: Get-AppxPackage *windowsstore* | Remove-AppxPackage

  4. Reboot PC

  5. Launch PowerShell again

  6. Run: Get-AppxPackage -allusers | Select Name, PackageFullName

  7. Locate in the list: Microsoft.Windowsstore. Should look like this:

  8. Note the the package full name (which is the 2nd column)

  9. Now run this command but replace “TheFullNameOfThePackage” in the path with the full name of the package which you found earlier.
    Add-AppxPackage -register "C:\Program Files\WindowsApps\TheFullNameOfThePackage\appxmanifest.xml" -DisableDevelopmentMode

  10. Reboot computer

  11. Launch Windows Store

  12. Search for Age of Empires Definitive Edition from the search (the one with coloured icon)

  13. Choose Install -> Install location -> Pray

The above Powershell commands merely reinstall Windows Store for you. That is it. Again, no guarantee.