⚠ IMPORTANT ⚠ Stuck on AoE:DE Build 27674? Upgrade to the latest client! (Windows Store)

Long time ago after first release date I removed AOE DE and then suddenly I couldn’t install it from MS store anymore whatever I did and try. But using point 9 I could reregister the package again as it was still cached and available there.

Strange that the standard PS command with reregistering all appx packages didn’t solve your issue as it should do the same. Probably the complete deletion of the MS store and reboot is required to fix this.

Also I did notice recently that when certain apps are still running in the background reregistration doesn’t work, so I created a kill all appx processes script to run that before reregistration tasks.

Thanks for posting back your findings.

I could restart my computer and it ‘unstuck’ my Microsoft Store updates…

Now I have this :

This seems to be the ‘Try again later’ error… I tried after some hours with no change.

Please tell me I don’t have to follow all these 13 steps with the whole Store reinstall oO

Also note I could install the new client from another computer without any problems.


I can´t update the game to 28529 version. The microsoft store don´t show me that update. My game is actually on 27374.

What i can do?


search for age of empires, you should see a second version as well.

Look at the initial post… it tells you how to get it.
There is a new client that is seperate from your current gameversion.

New episode on trying to make the new client work…

After another restart, I could pass the ‘Try again error’, and the game finally installed !

And then I run it… I saw the logo and… nothing, and I saw this in eventvwr :

Failed to launch the app from PDP 9NJWTJSVGVLJ : Age of Empires Definitive Edition
Error Code: Unknown HResult Error code: 0x80000000
Function: LaunchDefaultPackageAsync
Source: C:\BA\41\s\src\App\Helpers\PackageStatusHelper.cs (487)

And then… each time I try to start it again it does nothing. I tried to end process ‘Runtime brocker’ and… now my start menu looks like this :


And the new client disappeared from the Store, completely erased ? I have to redownload it again ? Some minutes after, it appeared as damaged and needs ‘repair’ with ‘reinstalling’. Seriously ? Will it work some day ? I’m seriously wondering to get AoE 2 DE on Steam… if I get it.

I can see that you still have the AOE DE Cross Play Beta installed (third one). Maybe because that version is still installed it gives errors with installing the latest cross play release version. It’s recommended to remove beta products after the program is finished.

It’s… 2017 beta :smiley: And it never bothered release version.

Maybe it does now. Does it still work?

I did check the MS store too and as far as I can see the old client has disappeared from the store and has been replaced by the new cross play version since August 19th.

So it could be correct that you’ll only find one AOE DE now in the MS store.

I suggest to remove the errored installation, old beta’s and try to download and install again.

I’ve been trying for 2 hours to update and can’t get it done.

Whatever happened to just posting a ■■■■ link, let us download it and install it? It worked for 22 years just fine.

Jesus wept, Microsoft…get your crap together!

The new AOE DE cross play version requires the latest Windows 1903 build. If you are not running that Windows version it will be impossible to install. Please check your Windows build and version.

1 Like

this isn’t open source or piracy …follow the steps from devs.

Restarting didn’t change anything this time, but I don’t have any logs either >.< I often noticed that reinstalling, removing things with bulldozer is not the solution, there should be some tiny item that blocks the thing.

1 Like

I randomly tried again to ‘repair’ and start the game… I had crashes each time except once : the opening video blocked on ‘Microsoft Studios’ logo, then I could access main menu and try a game. But when I retried to start the game next time, the blocking opening video meant also the game crash, and I couldn’t go after the opening logo anymore. And other times it was like the first attempts : the AoE DE logo appears (before full screen’s opening MS logo) and disappears, meaning the game crashed.

Any idea for this ? (maybe I should create a seperate topic as this becomes serious…)

Ok I think I’ve found the cause, here is the Avast quarantine zone log :

Can someone confirm me I don’t risk anything if I put this folder in ‘white list’ ? Can the game be infected in any way or is it sure it’s a false positive ? (from this https://www.pcrisk.fr/guides-de-suppression/9178-idp-alexa-51-virus a threat can apparently infect game installation… or be a false positive)

1 Like

Well, I’m happy that you have found the issue that blocks your AOE DE installation from functioning normally.

All apps available at MS store are of course scanned for malware and virus content and of course things could go wrong there (like a while ago with the MSN content system and some malicious advertisers that managed to inject javascript code on MSN pages), but I guess you can be sure that if you installed AOE DE from MS store it’s safe and so must be a false positive of Avast.

The virusscanner that I use doesn’t bug me about AOE DE. It never did.

I made a complete Avast scan, and it didn’t find anything concerning AoE DE or the MS Store.

Then, I excluded ‘C:\Program Files\WindowsApps\Microsoft.Darwin_100.1.28529.0_x64__8wekyb3d8bbwe’ from analyzed directories, and the game can now run.

But as each version makes a new folder, it means that I’ll had to redo the exclusion on each update… and not sure I want to exclude all WindowsApps.

Microsoft should talk with Avast to stop considering AoE DE as a ‘idp-alexa-51’ threat.

Have you already tried using the whitelist you can find here: https://www.ageofempires.com/support ?

1 Like

Hi all,

I not sure if I’m right, but I wont get the update, too. I installed AOEDE on an Win10 1903 (183632.418) today and its still 27374!

By the way one question: it is right that the unitl limit could only be 250 on random maps not on selfmade maps?

About Build 27374, it’s the old client. You have to download a new client. Search ‘Age of Empires’ on MS Store and install the new client.

Edit : JexBall Thx for the Avast firewall link.

1 Like