⚠ IMPORTANT ⚠ Stuck on AoE:DE Build 27674? Upgrade to the latest client! (Windows Store)

About Build 27374, it’s the old client. You have to download a new client. Search ‘Age of Empires’ on MS Store and install the new client.

Thats really the solution … but why does the store not install the new client autmaticly :thinking:?

can you help me with this question too?

it is right that the unite limit could only be 250 on random maps not on selfmade maps?

Because it’s a seperate client due to revamped architecture to communicate with Steam release. You can have both and each one has seperate achievements.

For the pop thing, I didn’t test but this seems to be wrong, as far as I know the user can choose the max pop in the start Scenario lobby.

well no posibility choosing custom maps, only in random maps (Build28529)

If it’s not in Extra settings, it means it’s the mapmaker who chooses it in the editor.

obviously it’s not a good idea to use the editor in 4k (as the warning says!) :thinking::thinking: … is just don’t saw the input field!
Finally I could set more than 250 units … sorry for annoying with that!

I can’t download the new client all it says is to “install” when I click “install” all it does is say that I have completed the download like 10 sec after I click install (which is impossible since my internet is not that fast) after the download is “completed” instead of saying something like play, launch or open on the ms store all is says is “install” so I tryed to do the same prosses again and I get the same result, so my question is how do I install a game I can’t install or a game that is eternally on “install” status? can someone help me on this?

I think the only way to overcome this problem is to remove the old client first and then reinstall the latest client from MS store.

See if the game appears in the Windows Start Menu.

See if wsreset helps.

See if some antivirus blocks something related.

I wouldn’t recommand remove other clients until you tried everything else.

The two versions were only available in MS store until release of AOE DE at Steam. After September 19th the old client is officially not supported anymore and removed from the MS store and it’s id was replaced with the new client. If you didn’t install the new client before September 19th the only way to get the new client is to remove the old one first. You should still be able to restore the old client from your local app cache though as it’s not really deleted (yet).

Are you running Windows version 1903 already?

yes, I am running the 1903 version

might that be my problem?

Why this date September 19th ? I myself could get the new client without removing the old before this date.
If you are sure his problem is due to having the old client, so it’s ok, but removing a version you can’t get anymore before being sure it will enable install of the new one is very risky as he could have nothing after. If there is (simple?) a way to recover the deleted one in all cases, so it’s ok.

I myself prefer keeping versions I can’t get anymore, to seek out regressions on the new one, compare altered features to how it was before, or in this case get achievements for a title you can’t get anymore in your Gamertag account gives a little ‘prestige’ / fetichism some retrogamers like me enjoy :slight_smile:

@DisloyalEight88 you have the same problem as me, add the folder in the Avast exclusions list and then after repair it’ll work. But you’ll have to refresh it on each update as the folder name includes the version number (don’t know who at Microsoft had this strange idea), unless you exclude the whole WindowsApps from Avast analysis.

1 Like

ok, thank you very much

1 Like

I tryed excluding the virus but Avast won’t let me so I tryed eliminating it and I think that made it worse and I still can’t install aoe

Can you post a screenshot of what you tried?

I sent to Avast the fact they detect AoE DE as a virus, as a false positive.
I hope Microsoft did it too…

1 Like

After that date they didn’t list the old version in MS store anymore. But if you are the owner of the game and had it installed you can always reinstall it again from MS store in your library. I could still install the first beta of AOE DE if I wanted.

1 Like

no I can’t because the virus is no longer there

Cannot install AoE DE windows store either, it shows as owned but every time i tried to update or reinstall to new version i get the error code 0x80070490 after a short while of windows store showing it as download started.

Windows 10 Pro 1903

Tried uninstalling old AoE client when updating kept failing, windows update, store update wsreset, deleting temp files reboot, everything works fine except AoE DE and Forza Street, neither will install.

SFC and DISM both checkout fine

Reboot your internet router and system after that try to run Windows updates first. Then open MS Store and Xbox-Companion console. Sign out from both. Now run MS Store updates through ‘…’ and Get updates button. After all updates (if there were any) are processed sign in to store again and click on ‘…’ and get updates again. Check also pending downloads there.