Install the game from the Microsoft Store yesterday and I could not play once, open the screen with the logo of aoe and close

00000000: Age of Empires: Definitive Edition Build: 23987
00000001: Launched on: 20:47.49 UTC on 7-15-2019
00000001: TOSServicesUWP()->Construct
00000003: System Language: es-ES
00000003: System Region : MX
00000004: SessionId: f4d2225a-d2bb-4ffb-94ad-c0a1fbb0d234
00000004: TErrorHandler->Construct
00000004: TFileSystem()->Construct
00000004: Program Executable: C:\Program Files\WindowsApps\Microsoft.MSDallas_1.3.23987.2_x64__8wekyb3d8bbwe
00000004: TFileSystem()->InitializeStoragePoints()
00000005: SP PROGRAM_PATH: C:\Program Files\WindowsApps\Microsoft.MSDallas_1.3.23987.2_x64__8wekyb3d8bbwe
00000005: SP GAME_ROOT: C:\Program Files\WindowsApps\Microsoft.MSDallas_1.3.23987.2_x64__8wekyb3d8bbwe
00000006: SP USER: C:\Users\ragui\AppData\Local\Packages\Microsoft.MSDallas_8wekyb3d8bbwe\LocalState
00000006: SP TEMP_FILES: C:\Users\ragui\AppData\Local\Packages\microsoft.msdallas_8wekyb3d8bbwe\AC\Temp
00000006: TSettings->Construct()
00000110: GameApplicationView->Construct
00000111: GameApplicationView->Initialize()
00000161: GameApplicationView->SetWindow()
00000205: GameApplicationView->Load()
00000206: GameApplicationView->OnActivated()
00000208: GameApplicationView->Run()
00000227: game->Config()
00000228: game->Startup()
00000228: InitStoragePoints
00000230: InitGlobalSystems()
00002268: TOSServicesUWP()->Init
00002268: ConnectedStorage->Construct
00002340: TSettings->Load()
00002341: TSettings->Load( ‘global_settings.ini’ ) = true
00002342: TSettings->Load( ‘settings.ini’ ) = true
00002455: TRIBE_Game->Construct()
00002456: TRIBE_Game->setup()
00002465: TDrawSystemD3D11->Construct()
00002466: MediaPlayerManager->Construct()
00002479: Adapter 0 = “Intel® HD Graphics 4000”
00002479: VendorId: 0x00008086
00002479: DeviceId: 0x00000166
00002479: SubSysId: 0x00fa106b
00002479: Revision: 0x00000009
00002480: LUID: 0x0000000000007b6c
00002480: Flags: 0x00000000
00002480: VRAM: 33554432
00002480: Sys Mem: 0
00002480: SharedM: 1845493760
00002481: TDrawSystemD3D11->CreatingDevice
00002489: – CreateDevice OK = true
00002489: – FeatureLevel OK = true, level = D3D_FEATURE_LEVEL_11_0
00002490: Adapter 1 = “Microsoft Basic Render Driver”
00002490: VendorId: 0x00001414
00002490: DeviceId: 0x0000008c
00002490: SubSysId: 0x00000000
00002490: Revision: 0x00000000
00002491: LUID: 0x0000000000007f7a
00002491: Flags: 0x00000002
00002491: VRAM: 0
00002491: Sys Mem: 0
00002491: SharedM: 8541009920
00002491: TDrawSystemD3D11->CreatingDevice
00002495: – CreateDevice OK = true
00002495: – FeatureLevel OK = true, level = D3D_FEATURE_LEVEL_11_0
00002496: Preferred Video Adapter found = true, Index = 0, name = “Intel® HD Graphics 4000”
00002496: TDrawSystemD3D11->Init()
00002496: TDrawSystemD3D11->CreatingDevice
00003294: MediaPlayerManager->Initialize()
00003645: GameApplicationView->OnLeavingBackground()

Operating System: Windows 10 Pro 64-bit (10.0, Build 18362) (18362.19h1_release.190318-1202)
Language: Spanish (Regional Setting: Spanish)
System Manufacturer: Apple Inc.
System Model: MacBookPro9,2
BIOS: Default System BIOS (type: BIOS)
Processor: Intel® Core™ i5-3210M CPU @ 2.50GHz (4 CPUs), ~2.5GHz
Memory: 16384MB RAM
Available OS Memory: 16290MB RAM
Page File: 15368MB used, 3353MB available
Windows Dir: C:\WINDOWS
DirectX Version: DirectX 12
DX Setup Parameters: Not found
User DPI Setting: 96 DPI (100 percent)
System DPI Setting: 96 DPI (100 percent)
DWM DPI Scaling: Disabled
Miracast: Available, with HDCP
Microsoft Graphics Hybrid: Not Supported
DirectX Database Version: Unknown
DxDiag Version: 10.00.18362.0001 64bit Unicode

I followed all the indications of the forum and nothing has worked.

I appreciate the help

Hi. Welcome here on the forum. You seem to be running bootcamp on your Mac?
Could you please check first if DirectPlay is enabled?
If not then enable it, reboot and try to launch again.

Hi, Thank you very much for answering, I already have it enabled.

It is not the problem.

If I am running bootcamp on Mac.

It should not be a problem running Windows 10 and this game through bootcamp. The only thing I do notice is the uncommon resolution of the screenshot (1202x934 pixels).

You could try to press Alt+Enter to switch the launch screen to full screen mode before the crash to desktop see if it responds and doesn’t crash.

Could you also check your application log in Windows Event Log Viewer for error at the time of the crash. Please post them back here if there are.

Also I would like to recommend you to check your Xbox account state and if your gamer tag and name are defined on:

While being there also check your Microsoft account details by clicking your profile picture and then ‘My Microsoft account’.

Thank you very much for responding again, it is curious I can not switch to full screen as you told me. But only for AOE DE, all the others I have installed if placed in full screen.

I have installed an additional screen with a resolution of 1920 x 1080, i had already disconnected it but still do not work.

I checked the system events, but found no errors during the two seconds of execution.

If you can please tell me which system event I sent detail.

I’ve already validated my xbox account information.

I’m grateful in advance.

It was a week of hard work, I couldn’t answer before.

Hard work goes before pleasure. But I fear I can’t pleasure you with a solution to your problem.

I just noticed this line. Doesn’t your MacBook Pro have a dedicated GPU (like AMD Radeon HD something)?

Because although it seems to meet the minimal system requirements, the passmark test of the integrated HD 4000 is really very low, it’s far below 800 points. The game might fail to run on lack of video performance even though it’s running in a quite low resolution.

You could still try to update the current video driver by opening device management, unfold display adapters and right click your Intel HD 4000 and choose update driver and click ‘search automatically for update driver software’.

If this model doesn’t have a dedicated GPU I fear it just doesn’t meet the minimal requirements.

Dear, thank you very much for the response.
Update the Driver.
Still the same.
Perform a new installation on another computer with a compatible processor and a dedicated compatible graphics card.
The result was the same.
Thanks for the help.
I think more must be a problem of compatibility of the game with the last update of the operating system, than the resources of the system.

As far as I know (from hear say) there should not be problems with Windows build 1903 and AOE DE, but I’m still on 1803. In that case you might be able to revert back to that version or solve the problem with an in-place upgrade of your Windows using the media creator tool. Maybe you can look around for an older ISO with 1803 or 1809 build and try it again.

Quiero agradecer la ayuda de @PCS70, he encontrado una solución parcial. ya se ejecuta el juego.

Segui los pasos que se mecionan en el siguiente hipervinculo:

Habilitando el Usuario Administrador del Equipo.

Espero que en la proxima actualización del juego, se corriga este bug.

Quedo a la orden, y espero que sea de utilidad mi comentario para toda la comunidad.

1 Like

Now it runs fine you should disable the Administrator account again. Much safer.

Launch CMD as administrator and type:
net user administrator /active:no

As you are running Windows 10 Pro (but also if running home version) you should be able to create a dedicated local administrator account with a not so easy to guess name and password to use it for purpose of updating your system or specific installation tasks.

This local dedicated administrator account also can be used to switch the permission level of MS accounts added to your computer from normal user to administrator and vice versa.

Now I just still wonder if the accounts you used and created to install and run the game where of type regular user or administrator.

The default type of new accounts is regular user which you can change while or after creating the account. In Windows 10 Home it’s done through settings and user account management while in Windows 10 Pro it can be done too using computer management or local user management console. And of course it can be done too through CMD net commands and PowerShell.

Hey buddy! I hope you can help too, i’ve been in a problem and i cant play! I dont know how create a new post, so sorry, but i’m sending my question here…
I really want to play this game in my computer, i tryed everything and i cant play.
When i click in play on the plataform this message appear…

"my question is here too ( )

Estimado amigo @PCS70 , realice la instalación de AOE DE con el usuario administrador que se genera en la primera configuración de Windows.

Aunque tuve que repetirla con el usuario administrador local con el cual funciono.

1 Like

I can’t help you regarding the beta yet, but a (direct)draw system initialization issue looks like an incompatible GPU or maybe a missing DirectPlay installation.

1 Like

Estimado @Jankken, una disculpa por no poderte apoyar, pero no dispongo del juego para realizar pruebas, si consigo información de cómo solucionar el problema que presentas con gusto la comparto.

Quedo a la orden.

1 Like