Is subscribing to mods bugged for anyone else?

I used to play this game back in my teenage days and wanted to try it out again with some Mods I saw on youtube, so I decided to get the Xbox Game Pass. I downloaded the game and ingame browsing the Mods section when I click on Subscribe nothing happens.

On the webpage I can even see I have indeed subscribed to some Mods, but ingame nothing shows up.

I am sad.


I have the same problem

None of your mod subscriptions appear at the ‘Installed Mods’ tab?

Yeah, none of them show up. And clicking on Subscribe ingame nothing happens.

Could you try this?

This username I am posting under is my Xbox account as far as I know. I am logged into it and the app is running before I launch the game and still nothing.

1 Like

Have you tried to log off and then on from Microsoft acc at both the game and the companion? That could maybe force the resync.

And how’s your mod subscription folder?

I have tried relogging on everything (Game, xbox app) and nothing.

I don’t know where the subscription folder is. Sorry.

Default address for me is:

C:\Users\Casa\Games\Age of Empires 2 DE\76561198068893664\mods\subscribed\

Casa = Home

The Folders of the mods I have subscribed to are there, but they are empty.

Edit: Actually how do you Sign out of your account ingame? I think I can only Appear online then Appear offline, not actually re-sign.

1 Like

Clicking on the red button at the upper right on the main menu should sign you off from Microsoft acc ingame.

Relogging does nothing, now managed to relog again and still no mods show up in game. The subscribed folder has folders that are simply empty without any files in them. No wonder people miss the workshop oh well.

1 Like

try deleting your mods folder
C:\Users\x\Games\Age of Empires 2 DE\xxxx\mods

1 Like

It did not work, also my Age of Empires 2 DE folder has 2 folders containing info about mods. One is named with a series of numbers and the other is just a 0. I have tried deleting both nothing helps.

It’s kinda messy that the folders even show up but they come blank. :neutral_face:
In your place I would get this detailed info and report as a bug.


I fixed it, my game was installed on my HDD which is the D:\ partition.

Now I reinstalled it to my SSD which is my C:\ partition, and it worked.


Glad that you solved, and thanks for sharing the solution!!

It actually make a lot of sense if you consider how xbox apps and windows interact.

hi… i read all the messages that you send i have the same problem.what if i dont want to install the game to ssd?

I am not an expert my friend, but I think the game has to be on the same drive as the operating system. So it does not have to be a SSD, just where your windows is installed.

I am not 100% certain that was the fix or a simple reinstall was the fix itself.


I have Windows installed on C drive and game (Steam) installed on D drive. Mods work correctly.