Known Issue: File Error 12

We are aware of an issue impacting some users where they get “File Error 12” when attempting to launch the game. We have been researching this issue and are working towards a solution. Please consolidate reports of this issue here.

UPDATE - Nov 15th @ 11am PT

We have pushed out a build update on Steam (v 32875) which includes a patch for this issue. This update is on its way to the Microsoft Store in the near future.

If you have encountered this issue on the Steam platform, please update to the most recent build, and check to see if you are still encountering this issue.

  • If you are still encountering this issue on Steam: please let us know the file path that you are saving the game to (ie: C:/users/… etc).

If you previously had this issue, are no longer seeing this issue, BUT are now seeing a different error preventing you from launching the game, please let us know and include a screenshot of the error you are now seeing.

UPDATE - Nov 19th @ 11am PT

We can confirm that build v 32875 is currently available on the Microsoft Store.

If you have encountered this issue on the Microsoft Store platform, please update to the most recent build, and check to see if you are still encountering this issue.

To check your version, open the Microsoft Store app, click the ellipses (…) in the top right, and select Downloads and Updates from the dropdown. From the list, located Age of Empires II: Definitive Edition and look to the right to see the build number.


Game Version:

  • Build official version (11/15)
  • Platform: Steam
  • System: Windows 10 64x

Issue: File Error 12

I cannot open the game.


We are taking a look at this now! Can you please let me know what language you are using to play the game, the Operating system on which you are playing the game, and any additional details that might help us as we dig into the issue?

In addition to this, please try working through these steps and letting us know if they work for you:

Type: ASUS Zenbook
Processor: Intel® Core™i5-8265U CPU
RAM: 8.00 GB
System: Windows10 64-bit computing
Graphics: NVIDIA GeForce GTX 1050 with Max-Q Design
My language is Chinese.

Thank you so much for the response. We’re continuing to investigate on our end and will circle back with updates.

1 Like

I also have this problem.

Game Version:

  • Build official version (11/15)
  • Platform: Microsoft Store(Xbox Game Pass Ultimate)
  • System: Windows 10 64
  • Language: Korean
  • Comp Spec: AMD Ryzen 5 2600, 16GB RAM, MSI RTX 2070

I tried to download the media feature pack from the link you provided above, but it only has download link for N version of Windows 10, not KN.

Please help!!

I am also having this issue. Any tips?

  • Platform: Steam - downloaded 11/17
  • System: Windows 10 64
  • Language: English
  • Comp Spec: Parallels from Macbook pro - No issues with HD.

C:\Program Files (x86)\Steam\steamapps\common\AoE2DE

when will this be fixed in the Microsoft Store? I still cannot install the graphics pack without getting this error.

@Supurman - Hey there, can you please check for updates and confirm your version number per the update on the original post above?

I have an issue that the game tried to download itself once again. 14.3 GB. after restarting my pc i cant start the game and no update. do i really have to download the whole game once again?

Today, november 23rd 2019, i still encounter the file error 12 preventing the game to launch.
I am sure my game is updated to version 33164 and i have restarted the pc.
The path to the game files is:
C:\Program Files (x86)\Steam\steamapps\common\AoE2DE
I am italian and my computer is in italian. I tryed both italian and english languages for the game before launching it but to no avail.
I use Windows 10 home.
What other details do you need?

I have the same problem then I tried running steam as administrator (right click steam > run as administrator) and it solved

I am sorry to say it didn’t work.
Can i please have a developer attention? I already paid and i’ve never been able to play it since release!

1 Like

Game Version: Age of Empires II Definitive Edition

  • Build (101.101.34223.0)
  • Platform (Steam)


When i launch the game the starting image comes up, after which the “Fatal Error: File Error 12” message pops up immediatly. This issue only happens on my laptop, on my PC the game runs fine. I’ve tried reinstalling the game, checking the files through steam, reinstalling steam + the game but nothing works. I’ve also installed the game on a different drive, the C drive instead of D. Which is a SSD instead of a HDD.

Install path: D:\Games D\Steam\SteamApps\common\AoE2DE

Reproduction Steps:

  1. Start the game
  2. Instantly pops up Fatal Error: File error 12 message.

Hope you can help!

Edit: added install path

I just buy and download the game on STEAM and I also have the file error 12
I update my C++, Windows 10, steam and it still doesn’t work.

I also launch using AoE2DE_s.exe and I get this message.


I am French, with a French computer.

My platform is Steam.
the install path is C:\Program Files (x86)\Steam\steamapps\common\AoE2DE

Could you help me please.

I know it is an already known bug, but i can’t resolve it and i would like to play.

Thank you for your help

Game Version:

  • **Build: Capture1
  • **Platform: Steam
  • **Operating System: Windows 10
  • Gamertag: replaceme


When I launch the game, it doesn’t start and said file error 12

Reproduction Steps:

Here’s how to reproduce the problem:

  1. Start the game
  2. Crash file error 12


  1. launch using AoE2DE_s.exe
  2. crash file error 12 and SteamAPI_RestartApplfNecessary() has been triggered. Aborting startup

Hey there @Geflorth! This is an odd issue that we thought was fixed. It looks like you’re receiving a ‘SteamAPI_RestartApplfNecessary() has been triggered’ error. At what point does the File Error 12 message pop up? Do you have a screenshot or video of the problem?

Likewise, if you have not worked through all of the steps in this thread, I would recommend doing so:

Hopefully we can find a solution to your issue! =)

Hi, thank you for your answer.

I already try every magic trick I knowand all the steps and advice already done.

Here when the message pop up. Just launch the game and after steam opening, it pops up.

Hope you can help.

i just downloaded the age of empires 1 and 2 definitive pack. and the enhanced graphics pack thinking that would help. age of empires 1 works ok but i get the file error 12 [intel® HD Graphics GPU with vendor id 32902 and device ID 258 is not DirectX 11 compliant for my 101.101.36906.0 AOE 2.