List of unfixed bugs

Dark age is the least multi-tasking time in the game. There is always time to manually force drop without ringing the bell or garrisoning. There is never any need to shift queue more than just the next sheep. Just keep jumping from your scout control group and TC villagers. Scout on control group 1 and hunters all on control group 2. That way you can just press 2 then right click to force drop, then back to the sheep and shift queue them to the next sheep. You will always have idle TC time if you don’t force drop. Only garrison when you want to go up to next age and re-assign them to wood or gold.

1 Like

why transport ship didn’t unload all the unit even the the land is big?
like photo said, pls official test all things before the new patched release, pls, pls, pls

1 Like

That’s unfortunate that the desync bug with the villager automation on xbox isn’t in the priority list. It’s made the game unplayable for console players for almost a month now. In the meantime, I’ll continue testing the glitch and providing more information about it in its respective forum.

We need a new section for Xbox bugs. The Xbox version is really abandoned when it comes to bugs

Another attack notification bug was introduced in the last patch. Wolfs/enemy attacking you doesn’t prompt a notification.

I know this might not be a big deal, but I haven’t been able to play the game for the last 10 days on Windows, and no one’s talking about it.
I love this game but I can’t even play offline or on other pcs or other steam ids. So I hope someone sees this and maybe gives it a look or helps me in any way shape or form.
For more info on all that I have tried here’s a link.
Game insta-crashes on launch after the latest update(Windows/Steam)

Double click on Xbox (with KB and mouse) won’t select all units on screen. It has been like this since last patch and it hasn’t been solved with the new one.

Makes the game unplayable, it’s frustrating and unnecessary.

Please devs fix it. Please.

3 bugs introduced with June patch and still haven’t been fixed with todays update:

  1. Cycle through TC’s hotkey doesn’t always center you to the starting TC first anymore.

Makes you lose a fight or eco collapse because the screen goes to unexpected locations which makes your macro tasks take longer than you thought.

I won’t be able to know where my screen will end up the first time I click it and then have to hold on to figure out where it went. Mentally keeping track is not realistic unless it’s maybe a peaceful Michi boom game because the human working memory can’t also fit this in without losing track of more important things going on in the game.

  1. Clicking an empty control group doesn’t deselect your units anymore.

Goes as far as making you send the wrong units into the enemy army if you don’t know the units in your group died or messed up mentally by e.g. forgetting to create the group because your units didn’t deselect.

Can also make your screen unexpectedly move if you quickly toggle between your numbers to keep your fingers warmed up so you fat-finger less later on. (wide spread rts habit)

  1. Cycling through unfinished buildings doesn’t work anymore. (forgot to mention this initially)

If you try to jump to your first lumber camp, mill or mining camp before it finished to set the TC rally point then the screen won’t go there anymore. Same if your barracks builders get attacked by militia or something else it’s all about reacting quickly. The quickest way was to to use the cycle hotkeys as camera hotkeys. For AoE 2 a huge barrier of entry for new people is how hard playing a smooth early game is and this change made it even harder and more inconsistent.

If these changes were intentional at least give a toggle option instead of forcing them on every player.

reposting a comment to an issue from 3month ago: Units stop walking to the target location when the enemy unit dies - #4 by L1GHTMAN2k

Updated and cleaned up the list.

This bug is still not fixed.

1 Like

This is a bug that’s started happening to me recently. It’s made skirmishes nigh impossible to play.

I reported this bug in April and it’s still not fixed after the newest update:

In scenarios, when using the trigger effect “Replace Object”, the new object will keep the replaced object’s current HP, instead of its HP scaling in relation to maximum HP.

E.g. replacing a full health 30/30 HP Archer with a Knight will make it a damaged 30/100 HP Knight instead of a full health 100/100 HP Knight as intended.

1 Like

i can’t play after update!! my multiplayer test 1100 before update. now 760

Restarting skirmish 1v1 vs AI has crashed my game a couple of times today.

Zooming in and out is still unbearably slow for me after the latest update and still not working correctly after the hot fix. Anyone else having this issue?

This bug chimpanvi reported back in April is still a thing. It takes 5 mins to load into a 3v4 black forest match for me.

AoE2 Client hangs for a long time after starting local AI game (PC)

Is this one already listed?

you cannot edit empires2_x2_p1.dat for now, even little bit small edit. game menu will say your empires2_x2_p1.dat have problem. you can’t play anything, shit updated

1 Like

Hi, just wanted to let you know that this is by design – the Mod System must be used to create a local mod for playing your dat file, in the same way as for .json files also found in the “dat” folder. Overriding the base game dat is a dirty method, which results in losing your mod everytime the game updates, and has not been supported since 2020.
More information here