Lobbies more bugged than ever - part II

To anyone else willing to log, I also found this pinned topic helpful from GMEvangelos:

It tells you step by step how to turn on enhanced logging in Steam, using the same key that Chesqin gave.

I also encountered the stuck-at-pre-game mode problem yesterday, where it counted down 5,4,3,2,1 and just hung without starting; unfortunately, enhanced logging was not turned on. I’ll try to keep logging on as I play the next few days to see if I can catch one.

Here is a session with a Steam invite.

Tl;dr: I figured out that the game actually joins the lobby, and I show up as in the lobby; however, the UI doesn’t pull up the game lobby.

First, I start a fresh session of Aoe2DE. Then I accept the invite to join my friend Anduin’s lobby. My in-game name is Ante.

Nothing happens with the UI for a minute (it stays on main menu). So I click Multiplayer, then Lobby browser. This is what I see:

My name, “Ante”, is the fifth player in this lobby. But my UI doesn’t show the game, just the lobby browser. My friend Anduin confirmed that I’m in the lobby. If I then try to click “join game” from the UI, then it gives this error:

After this, it kicks me out of the lobby, and Anduin confirms that I drop from the lobby. So I think the UI is simply not loading the game lobby. (In fact, the UI doesn’t do anything and just stays on the main menu. I had to click “Multiplayer > Lobby Browser” to find this.)

Here is the session log from this session:

This is also the same sequence of events if I accept an in-game invite and it hangs like this.

1 Like

Using this method seems to have solved my lobby bug problems. Everything is loading the way it did before the DLC patch. No idea if putting this in caused or if you guys did some stuff on the back end.

1 Like

Thank you everyone!

The logs have already proven helpful and we were able to identify and fix one issue following it (no client update required). Please keep on providing more logs if you continue to encounter these issues. :slight_smile:

3 Likes

Whatever you guys did, I think that did it. I haven’t gotten an infinite loop timer for my ranked games for the past 4 hours. Thank you

I still can’t create a lobby. See bug report at Lobbies more bugged than ever - part II - #31 by SavvyEmpire

1 Like

Hey SavvyEmpire, would you be able to try this once more on the Enhanced Logging build (Lobbies more bugged than ever - part II - #41 by Chesqin)?
If you could reproduce this and send us these logs here that could be very helpful. :slight_smile:

1 Like

I’d love to, but there doesn’t appear to be Enhanced Logging for Windows Store users. It’s only available for Steam, correct?

look if you guys want to do updates and stuff like that im fine with that but atleast when you break the game fix it FFS its been ages and it is still as bugged as ever simple fix it stop screwing around with irrelevant things

2 Likes

Even after yesterday’s server maintenance, creating custom multiple player lobbies is still broken for me.

Same problem for several months. I think lobby is broken forever

server browser is bugged for me too.

Can’t access some games even if it displays that there no players in it (game already started ?)

it looks like the server is just not updating and i can’t access to new lobbies created.

If i put something in the Search bar, it just doesnt display anything.

Looked bugged since i came back to AOE2, no it’s not a client side bug, fix it pls.

Sometimes it works, sometimes it doesnt but the server browser was better before

1 Like

I have the same issue. I have to go to the ranked tab, then back to the custom lobbies tab, then it updates. Does that work for you, @one753 ?

Hey, here we go again

1 Like

Why no dev even answer about the completely bugged lobbies for several months ?

Before the problem was only to be kicked because your noob or not noob following the host.

Now you take 20 min to find a lobby and when you are kicked you are good for 20 min more.

After 40 min you find a lobby and 5,4,3,2,1 BUGGED

We’re aware of multiplayer services issues affecting some users and are investigating. You may see improvements based on recent steps we’ve taken to address this. In the meantime, please continue to send us logs. The steps to do so and how you can access the Enhanced Logging build to provide the best possible information are in the linked post.

Just created a account to let you guys know about solution to the lobby problem that worked for me! Go to Xbox Networking → wait for results untill you get NAT Type = Teredo is unable to qualify… → press Fix it → then Check again

After that the lobbies and ranked matchmaking works. I have to do this everytime before I starting aoe 2 de. I am playing on the steam version of the game.

I would have uploaded pictures, but apparently new accounts cannot upload media…

1 Like

Will give it a try, thanks for posting!

What kind of game is this. How broken does it have to be so that I can’t even create a lobby. This is borderlining on demanding a refund soon. Seriously,. I’m having the exact issue I made a bug report on over a month ago.

2 Likes

This didn’t work for me. Still can’t create a lobby.