Lobby Browser only showing games from one server

Game Version:

  • Build (32911)
  • Platform (Steam)


When trying to find a game to play I can only see open games on the Westus2 server. Games hosted on any other server will not show. My friend has the same result.

Reproduction Steps:

  1. Open Lobby Browser
  2. Let it search for Games
  3. See that the only Games it finds are on one server only.

Same problem here. I’m on East coast of U.S. and only see a few games on WESTUS2 and I’ve been checking constantly since launch, they are high ping for me and are difficult to connect to.
I have also tried hosting in EASTUS2, WESTUS2, and Default, waited at least 15 minutes, not a single person joined for even a second. I have hosted games in AOE2HD before and after testing this to verify my network settings are okay.
(Update: I briefly saw a game from a Korean server, and a game from an Austrailian server, one refresh and they were gone tho, still havent seen an EASTUS2 game show up, only WESTUS2)

I noticed there are 8 EASTUS2 Games that show up in the spectate list. Many servers show 7-8 games running… some show 14.

This issue is similar to this one: Can only see games from USWEST server and nothing else?

Edit: This is mostly resolved for me from updates/patches. I can only host in WESTUS2 though, despite the fact that I’m closer to the East coast (Ohio)

It seems I missed that topic when I made this one. Well glad to see others are having this issue as it should get fixed soon (hopefully).