Locked at 17-20 FPS but not all the time


i hope someone could help me with my problem:

My AoE3:DE is running often at around 17-20 fps so matter what graphic settings even in just the main menu. Sometimes i open it and it runs perfectly at 60fps but not always.

I noticed that my GPU reports a usage of 0% and just jumps every few seconds to 100%. CPU usage is around 15-30%

I got it once to work at 60 fps when I put the game to windowed mode and back to fullscreen but that only worked one time.

My Specs:

CPU: Ryzen 5 1500X
GPU: Radeon RX580 8GB
Game is installed on a HDD (no performance issues there)

Things I already tried:

  • Slightly overclocking GPU → no change
  • Disabling and enabling AMD tweaks (The things in the Driver software like sharpening and
    “Anti-Lag”) → no change
    → Newest drivers are installed
    → Windows is up to date
    → Changed every possible graphics-setting in game → no change
    → Changed refresh-rate in GraphicalProfile.xml file → no change
    → disabled “Windows Game Mode” and “Xbox Game bar” → no change

I am open for any possible solution and I am thankful for any help.

Did you check power settings ? Some forbid your GPU from working 100% all the time with a “prefer energy savings” settings.

Looks like you are using integrated CPU graphic card instead of dedicated one. This problem was reported by some users month or two months ago. Issue was also reported on Steam if I remember correctly.

You should be able to fix it quite easily.

1 Like

I already checked that. Nothing is set to save energy

I use a AMD Graphics Card with a Ryzen CPU. I don’t even have an integrated graphics card. Just the RX580

another thing thing to check is any sort of noise control or fan settings

Its not from AMD but NVDIA GPU has whisper mode setting that limits performance to reduce fan noise

I manually tweaked the settings and still the same problem. Its also just in AoE3:DE. All other games are running normal

After so long I finally found the issue. I have a program named “Rainway” installed. It allowes me to play games on my PC from other Devices (Like NVIDIA GameStream). When I noticed in Task Manager that over time a program called Rainway.Library takes more and more RAM. When its around 150 - 175 MB AoE3:DE starts to run at aroung 17-20 fps. As soon as I shut down Rainway it jumps to 60 fps and runs perfectly. That explains why this issue only happens sometimes. I don’t use Rainway anymore but its always running in case I want to use it. When I start my PC the Program just started and takes around 60-80 MB of RAM. But over time it takes more and more (So its doing something in the background) and then the game start lagging. It’s interesting why only AoE3:DE is effected by that and not other games.

Thanks for any help

1 Like

Pfff…too much FPS…I play the game between 2 FPS and 12 FPS xd…