Losing game control when chatting with Chinese input method

:arrow_forward: GAME INFORMATION

:point_down: These details are CRITICAL; DO NOT skip them or your issue may not be reviewed.

  • **GAME BUILD #:101.101.54684.0 7491487 ######
  • **GAME PLATFORM: Steam
  • OPERATING SYSTEM: Windows 10

:arrow_forward: ISSUE EXPERIENCED

Press "enter" to open the chat, and when you switch the Microsoft pinyin input method to input Chinese, if you suddenly "alt+tab", the game will lose control, you can only watch it, you can't move it at all.

:arrow_forward: FREQUENCY OF ISSUE


:arrow_forward: REPRODUCTION STEPS

:point_down: List CLEAR and DETAILED STEPS we can take to reproduce the issue ourselves… Be descriptive!

Here’s the steps to reproduce the issue:

"enter"open the chat
2. win+space to change input method
4.when typing , “alt+tab”
5.the game lose control, but it is still going , what i can do is just watch ,i cant move my screen ,i know what is happening ,but i just can’t do anything ,I have to restart the game.

:arrow_forward: EXPECTED RESULT

:point_down: What was SUPPOSED to happen if the bug you encountered were not present?
The game keep going.

:arrow_forward: IMAGE

:point_down: ALWAYS attach a PICTURE (.jpg, .png, .gif) or VIDEO (.mp4, YouTube link) that highlights the problem.

:arrow_forward: GAME FILES (SAVE / RECORDING)

:point_down: Attach a SAVE GAME (.aoe2spgame) or GAME RECORDING (.aoe2record) of the match where you encountered the issue. Link it below if using an external file service.
MP Replay v101.101.56005.0 @2021.11.30 204927 (2).aoe2record (6.3 MB)

Hi @XelNaga8080 !

Can you tell us which input method you use? A link with the instalation could be really nice.

Also, can you send to us a video? We cannot load your Replay


few of the chinese players that I play with having this problem on a daily basis. about 50% of the game 1 player will stuck and can’t do a thing.

Oh I see. Can you send me a link of which input method you use? Google maybe?


windows 10 settings, language , simplified chinese, microsoft pinyin input method

Thanks for the small tutorial :smiley: now I have the input method installed

I tried to reproduce this issue but I had no luck. When the suggestions appear in the top, then you alt tab and the game lose control?

I will try again in some days

I find a post about this problem. You can read it.

Hey, please try to reproduce on a mid/low-end PC. I used to experience this a lot on my Surface Book 2. I later switched to a Lenovo Legion 5 with Ryzen 7 and RTX 3070, and haven’t seen this issue since.

Try to switch input method with Win+Space multiple times, both in in-game chat and in mod manager’s search bar. You should be able to see it.

Hi guys,

Unfortunately, I could not reproduce your issue. However since many of you have reported it in different post we have created a ticket for further investigation.


We are now tracking this issue (=^▽^=)

1 Like




Hi everyone!

Are you still having this issue recently?

I often encountered this BUG before, mainly when switching language input method. The program can’t be controlled after this happens, but it still works, and the input commands can’t be delivered to the game.
However, this BUG is not triggered anytime and anywhere. You can use shortcut keys to switch input method in the game to try to reproduce it. The combination of Alt + Shift and CTRL keys is the trigger cause.

1 Like

Thanks for your answer @Dianstar !

We tried to reproduce this using Alt+ Shift instead of Windows + Bar but we did not find the issue. Is it possible for you to record a video where a keyboard is shown in the screen? So we know the exact steps you are doing


just had a player had this happen to them. but they were able to chat multiple times before getting stuck so chances of it happening is fairly random and like between 10-15% but eventually it will happen.

it is pretty game breaking, is it possible for devs to have ways to type in chinese by installing the language and just type randomly away and try to reproduce it?

Yes, I installed the chinese input method but no luck for now

1 Like

Im not sure if it helps but ive had this error 3 times now , i dont have any additional language packs. same symptoms, cant control but game runs in background. When ever i press F7 or the chat scroll. it will work the first time but then trying again it has the Bug. If i type using “enter” only its fine.

That is a different issue and it is also tracked, thanks ^^

I bought a new laptop and am using windows 11. After playing for a few days, it seems the bug doesn’t appear anymore.
Maybe the bug is related to low performance. With my old laptop when the population of 8 players is particularly large, there is a delay of about 1 second in switching input methods and there is a high probability of losing control. (Of course, this may also happen with a small population, but less frequently)
new laptop:
i7-12700h, gtx3050ti, 16G DDR5 4800MHz, ssd
old laptop:
i5 8300h, gtx1060-6g, 16G DDR4 2400MHz, ssd

Translated with DeepL Translate: The world's most accurate translator (free version)


Thanks for letting us know ^^

I already told you that you probably won’t repro on a high-end PC, months ago. Could you simply find a lower end PC to test?