Loss of resources when reassigning villagers to different resources

Game Version:

  • Build (101.101.32911.0 4395365)
  • Platform: Steam


I know that this was the case with HD and CD editions, but I heard from a Viper’s stream that now resources don’t get lost if you reassign a villager that have, say 5 food to wood. I tested it and find that this works in some cases and in others don’t. It works correctly when a villager is carrying any resource and is retasked to: lumberjack, shepherd or hunter. But vills still loses resources when retasked to: forager, stone or gold miner.

Reproduction Steps:

  1. Mine 5 gold with a villager, don’t drop it at a mining camp
  2. Reassign that same villager to mine stone. When the name of the villager changes from “gold miner” to “stone miner”, the gold is lost

Honestly I always found it part of the micro to first have to deliver the goodies by right click on the appropriate resource storage building and then do what you want. If this is about AOE II DE you can solve it another way through queuing villager’s tasks using the shift key.

1 Like

Yeah I’m with you here, but I thought that they implemented that you lose the resource only when the new resource is collected, so in case you misclick, you can just retask the villager to the correct resource without losing some


Yet that villager will have to drop off those few pieces again at another storage building. But I didn’t even know that they added this. I think I have seen that they now keep there resource until they start collecting the new resource. At that moment the old resource they carried is gone.

1 Like

This bug was fixed in Feb patch but now it’s back again. It’s so infuriating to lose hundreds of food by miss-clicking your villagers to a tree.

" Villagers will no longer drop resources as soon as they are reassigned to collect a new resource. Instead, they will maintain any collected resources until they begin the new task. The collected resources can now be instantly dropped by reassigning to a new resource with CTRL + Right Click ."

1 Like

Are you sure? I just tried it in last William Wallace scenario. I assigned farmer to chop a tree. He lost his food when starting to chop a tree, not immediately after assignment. This gives time to assign him back to farm or drop-off building.

It’s different in campaign for some reason. Try in standard game vs AI

I started empire wars game with standard settings and farmer behaved exactly the same when assigned to wood

Losing the resources when starting to collect a new resource is intended behaviour. A villager cannot carry more than one resource at a time. The feature they added last patch was that villagers won’t instantly lose all resources from (let’s say wood) when tasked to something else. They will only lose it when the villager arrives from the woodline to (let’s say the goldpile) and starts mining. Hope this clears some stuff up :slight_smile:

1 Like

Just to make sure I checked it out and it seems to work fine.
I tried all combinations in the below screenshot I could think of and everything worked. Every time the villager arrived at a new resource and starting harvesting it the old resources dissapeard (not earlier). The only exceptions are from food to food resources (ie. Fish > Farm, ForageBush > Fish etc.)

1 Like

simt0m is right, bug is happening to me in RM single player.

You should post exact steps for reproducing this (starting with game settings).

1v1, single player game, random map, use recommended settings, start chopping wood, once vil has wood click sheep, vil instantly drops wood (still far from sheep). Same thing from sheep to wood, and minerals to another res.

I used same settings, but villagers kept resources normally for me. Weird…

1 Like

As already mentioned, villagers only lose collected ressources when they STARTED to collect another ressources.
They dont lose it while they walk to collect a new ressource, its just not shown in the display but is back when you reclick the villager on ressource that he collected before.

Actually it is shown for me until villager actually starts gathering other resource.

1 Like

Just tested it out as well and it’s working as intended, villagers don’t lose resources immediatly when tasked to another gathering work, only lose after start working on the new task.

Do you mind sharing your game version?

Same for me.

1 Like

Version 4941835
Restarted my whole computer and it’s still happening. And it’s not still there but not shown either @LinieSpreu12610

Regarding troubleshooting this issue. Do you by any chance have mods enabled, if so please list them here too.

I just disabled them all, restarted game, same problem.