Massive FPS drops when selecting a hotkey with many units

I am getting huge FPS drops from 120 fps down to 10 fps every time I select a hotkey with many units in the mid to late game. It only does it right when its selected and once its selected for a few seconds it goes back up (FPS).

When spamming hotkeys (cycling them quickly) it makes the game a stuttery low FPS mess. This happens on all settings on a decent build (i5 9600k, GTX 1660 TI, 16GB RAM). I tried basically any combination of low graphics settings, turning off sound settings, UI settings etc. Nothing will make this problem go away.

I also talked to several people on Reddit with the issue and 3 of my friends also have it yet whenever I watch a stream they have no issues like this whatsoever. It makes macro really annoying in the late game, and makes micro borderline impossible. Has anyone figured out the cause of this yet?

No one on here has this issue? I noticed the devs certainly improved game performance over the last few patches, but this problem is easily the worse of it and there has not been anything said about it.

i get FPS drops and i have a decent build as well on low settings.

Seems there are not enough people with this issue for the devs to say anything about it unfortunately. Shame its made me completely stop playing.

My PC : i9-10900k ,RTX 3080
I have the same problem,I hope all friends who encounter this problem will leave a message here ,Let the production team see this post as soon as possible.

Yea, I’ve noticed this.

Selecting a load of units makes the frame rate plummet, even just drawing the box over the units it’ll plummet. But once you click away or cancel the selection the frame rate returns back to normal.

I made a vid on it but never got round to posting.

AMD 5900x
RTX 3080

Post it here please!

Any word from Relic on this issue? I can hardly play the game with this problem.

Hey all! If you’re seeing this, please contact support here with a summation of your issue as well as your DxDiag and warnings.log file. Thanks so much!

Thanks sent one in, looking forward to some reply on this issue.

1 Like

Still no fix for this. Will this ever be addressed? If not I am dropping the game as I cannot play with this and its just extremely frustrating. Every patch I hope its fixed but every time still there.

I find that the issue only presents itself if your playing a few games in one session, restarting the game is a way round it.

1 Like

Ah not for me, its every game. I tried all low settings makes no difference. Its just right when the units are selected every time the FPS will drop. So when using multiple hotkeys in the late game it presents a real issue.

@Doshworld if you have an active ticket with Support, it may be worth bumping with a “still having this issue, even after the newest patch.”

1 Like

Well 1 month and 2 patches later and this issue is STILL a problem. Will it ever be fixed? No one knows, but for now I am dropping this game until it is. I will check back with each patch to confirm that yet again nothing has been done. I am sorry but I paid $60 for this game, and it is legitimately bugged for me while I can go watch Twitch streams, and they suffer nothing of this issue. There is also zero chance it is my hardware, or my PC in general. Its on Relic’s end and you guys need to fix it.

Praying that this new patch fixes this issue. Its been almost 4 months now…

Being worked on, but that’s all the info I have.

Thanks for the update, I hope they were able to reproduce it like I have, on multiple PC builds.

For what its worth I found out if there are no enemy units on screen then the hotkey lag is not present. Even with massive amounts of units in multiple hotkeys, cycling them.

Thanks! I’ll get that detail over to the team investigating. Appreciate it!