MOD: Advanced Game Settings

Advanced Game Settings got big update, maybe not that big in terms of features, but everything was completely rewritten to work better with diplomacy :slight_smile:

It features many options that were in previous games, but also few new options.


And finally a little option to hide objectives ingame, incase you really dont want to see every single objective mod throws at the screen :slight_smile:

Any feedback and bugs can be reported at github , but you can also post it here.


How can I provide additional language support? I don’t know how to use GitHub

You really dont have to do anything with github other than writing comment and attaching translation to comment (drag & droping it into comment) same way Seicing provides Chinese localization here Localizations · Issue #19 · Woprok/AOE4-AdvancedGameSettings · GitHub

In FAQ section on the github is link to english localization file that needs to be translated to a language of your choice that is supported by the game AOE4-AdvancedGameSettings/Advanced Game Settings_en.csv at master · Woprok/AOE4-AdvancedGameSettings · GitHub

I will then integrate it into the mod.


The guy who made this mod is putting Relic to shame.
This is why a different company needs to take over and really to work on game improvements, features and mechanics

Relic is too slow and updating the game at the slowest possible speed.


@Woprok Thank you very very much for this awesome mod :slight_smile: The best mod in AOE4 so far in my opinion. There are so many things missing from previous AOE titles and you added so much with your awesome mod. They should add all those things from your mod to the base game :slight_smile: Keep up the great work.


I love this mod. Thank you for your hard work! :raised_hands:


me dice que el mod tiene datos corrumpos

I can’t help you as I don’t understand. If you provide information in English I will try to help&fix problem…

If you click the globe icon at the bottom of his/her post, the forum will translate it for you.


Nice, thats useful didnt notice that before. Anyway I need more info then that to be able to help him…

Hi there. I have been an active user of this mod from the get go. But right now I am facing this issue that doesn’t seem to get resolved. I updated to latest patch i.e. v5.0.17718.0 and after updating the issue started. Now whenever i Launch the game with the Advanced Game Settings and the Max REsource Tuning Pack, the game launches fine and i can play it. But as soon as I try to save the game, the BAD MOD DATA dialog box pops up and boom. I have been trying different things to resolve it but the only way to save the game successfully is to disable the Advanced Game Settings Mod.

I will request the developer to look into this issue. One thing that i will like to add is that I try to assign colors to different teams but the only color that is assigned to the AI players is red. I dont play online i Just play as skirmish offline. I am doubting that the unsuccessful saving of the game might be due to the fact that the teams are not assigned their proper color. :slight_smile: I am just guessing. Because previously the colors were assigned automatically without any issue.

please please look into this issue.


1 Like

Thats unrelated to the mod, you probably have game set to use team colors over individual colors…

Don’t expect me to go through all possibilities just to find what is causing issue and crashing the game with bad mod data… If you want the issue to be fixed find minimum changes required from default settings (obtainable by switching between gamemodes as that should reset any user made change) for it to happen and report it again with maximum informations possible… I am not going to spend hours trying to find what is causing save game issue that crashes with bad mod data (worst possible issue, thats hardly fixable by mods as save games are mess)

well firstly i would thank you for being so quick in replying. Let me try it once more by resetting the mod to default settings. Let me come back with more details as you said.

I have tried the default settings and attaching screenshots of the whole story. Kindly do take a look.

imgur link

I will check it out and try to figure out what is causing it. Anyway I will not guarantee that the issue will get fixed anytime soon…

thanks a lot. i would also add another bit of info. The recent update of the mod was released on 16th of July if i am not wrong. At that time I had not updated to the Game Patch 17718 and was using the previous one that was 15965. Even at that time when i was using 15965, the mod was working perfectly fine until the release of update on 16th of July. The Bad Mod Data error started at that time. I thought that updating to latest patch i.e. 17718 might fix the issue but it didnt. If you could by any chance try the last version of the mod before the update of the mod so that might be working pretty well without any bug.

My best wishes and thanks.

So it started happening after I updated mod after season 2 update ?
If that’s the case then at least I can narrow it… Can you check if save issue happens when you uncheck enforce colors?

let me check with enforce colors. please hang on.

I have just checked with the enforce color option disabled but still the result is same. I came to figure out that the mod had been updated when i by chance saw that the MOD had no colors available as there were previously colors available below the Enforce COLORS option which I never touched as i was good with the blue color that i usually got by default so never had to change that option.
And yes the error started after the mod update since i Had been running a long match with 5 other AI competitors till 13th of July as the last successful game save was on that day {screen shot attached}. After that i remember that i tried to play the game after the 16th
July when you updated the mod and the error came up.
I also had a doubt that the error might be due to the Black Forest Map as I was selecting it again and again. But then I tried Dry Arabia and the issue remained the same.

I used to have this bad data mod error previously whenever i used a Custom Map or Generated Map with Advanced Settings Mod. At that time the error would pop up at the same time when I tried to save the game. So i was never able to play any custom or generated map with this mod enabled.:frowning:

There was also this issue of FATAL SCAR ERROR whenever i used 400 population in the MOD. The game would throw a fatal scar error whenever some keep or any other wonder was destroyed in the map by the enemies or me OR whenever i Hit the maximum pop cap during the game. That error later on was fixed when i unchecked the Keeps or Wonders winning conditions. I was also suspicious that perhaps changing the winning settings by me had something to do with the SAVE GAME error but apparently it was not as the default settings were producing the same behavior with 200 pop and other default settings.

so here i am, a bit descriptive if you don’t mind. Though it might help…:slight_smile:

Any luck finding some solution…?