Modding - Taunts

I FIGURED IT OUT!

Okay, so you will need to download Wwise through their launcher. All the sound effects you want to add to the game you need to convert to .wav files. Then you need to import these files to Wwise and convert them into .wems, this video shows you how

After you that all you need to do is place them in your mods folder
\mods\local\MODNAME\resources\en\sound\taunt
(non english taunts go in the other language folders, i.e \de\ for Germany)

And prefix them with a number. The number they are prefixed with tell the game what number the taunt corresponds to.

1 yes.wem will play when you type 1 into chat,
999 ear_destroyer.wem will play when you type 999 in chat, you get the idea.

There seems to be some requirement for the original mp3 file, as I have gotten some sounds to work, but not others? Maybe bitrate or something I don’t know, some sounds just don’t play when converted to .wem

3 Likes

None of the 26 I converted played, but they were acknowledged by the game as being valid, because the chat didn’t preface the number with ‘/’ which happens if its outside taunt range

Hi, I made guide about make to Taunts Mod.
I am glad if it would be helpful.

3 Likes

I’ve gotten them to play outside the 1 to 105 range, but only one of the files I converted to .wem works. Something is going on, there must be some hidden requirement for the file.

1 Like

Haha what are the properties of the one file? Also did you use the same filepath you posted above?

Oh, no… :frowning: The sound files are now a pain to update? Not cool. I was about to update the sound files to make the battlehorn sounds quieter (how I’m the only person on Earth who finds them annoyingly loud and frequent is beyond me; there really should be volume/frequency sliders in the menu for them)… and add my own taunts, like I did with other AoE2s (AoE2:CE, AoE2:FE, AoE2:HD)

1 Like

Yes for us simple modders, at first glance its much different to AoE2 HD, due to encoding, and using sound banks, rather than simple Mp3s, but we might have a fix.

Ok so I changed the output settings in Wwise back to “Default Conversion Settings” and then changed “FFT Window Size” to 256. This made the converted .wems very large in size, however testing them in game they work! :smiley: And yes I used the same filepath posted above. If you try overwriting existing taunts, and when you try play them in game if the taunt becomes silent that means the file replacement worked, just that the engine can’t play the sound file, so overwriting the default taunts is useful for testing.

I need to play with the output settings in Wwise and find a setting that works and where short soundclips aren’t like 1MB in length.

1 Like

Me too! Yay, I knew we wouldn’t have to amend the bnk file, but it took a bit of screwing around, good job buddy

1 Like

Looks like none of the vorbis output settings play in game, only PCM, I need to try converting to opus and see if if they play in game now.

Edit: Nope, opus doesn’t work either. Well at least PCM works.

1 Like

After you that all you need to do is place them in your mods folder
\mods\local\MODNAME\resources\en\sound\taunt
(non english taunts go in the other language folders, i.e \de\ for Germany)

Hey man, this didn’t work at all for me, I placed a .wem file into that, name: 01 yes.wem. Firstly it doesnt even aknowledge my mod, it just doesn’t appear in the mod browser and then the default taunt plays when i type in 1.

I tried using the method of FBshokai, which worked, but only if i replace the original file (taunt.bnk) within the game directory. I’m trying to find a way to replace all the new taunts with the original 42 taunts.

Great work so far!

1 Like

Why have devs done something like that? Wouldn’t a different, more accessible format managing make it easier for the community to mod the game? If they give us terrible-quality taunts and voice-acting, at least let us mod it with the original ones…

Thank you for the comments!

PCM being the only supported format is a bug which has now been fixed for the future updates. Vorbis will be supported as well (this is the default format used by the game).

I have now created a quick guide that documents all the available Events and their IDs, as well as the replacement of in-game effects and music, and the addition of new and existing sounds into scenarios. Will also try to keep it up-to-date with currently known issues with audio mods.

10 Likes

Thank you so much for the spreadsheet with the IDs and the guide. This is awesome!

1 Like

Absolutely closed my mouth. Thanks for this!!

Thank you very much for your input - are you associated with Age of Empires professionally, or just a wizard?

From what I understand, there are 2 situations at play;

  1. changing existing taunts/sounds - complicated as the new game uses bnk soundbanks follow the guide provided by this kind man, and use the spreadsheet to identify sounds
  2. Taunts 106-999 are still fairly easy to add, use the file path provided above by my other kind friend, currently only supports WEM files (non vorb) but this will change. To create Wems you can take mp3s save as wavs (try using goldwave) and then export as wems using wwise (seems convoluted there might be a quicker way)

\mods\local\MODNAME\resources\en\sound\taunt This folder doesn’t exist for me. When I create this folder path, it is not recognised in the games mods manager. Whereabouts should the mods folder be located? in the root of the aoe2de folder? I’m using a steam copy btw

Hi mate,

I’m not currently at home so cant double check, but there should be 2 locations, all source game files in the usual steamapps location (program files), and then custom and downloaded files will be in Users/YOUR NAME/Games/AoE2 DE mods etc. Play around by downloading a test mod then opening file location from AoE directly

1 Like

Sorry to repeat myself, but the method provided here to mod taunts doesn’t work reliably.

I’ve placed .wem files (PCM) created from .wav files that have been converted from .mp3s from HD in:
\mods\local\Classic German Taunts\resources\de\sound\taunt

When typing 1 in game the new taunt still plays. This is what it looks like in the mod manager! What does the “!” mean?

I also tested another mod from the workshop, which uses the same procedure and the game also takes issue with that.

When I type the added taunts (321 for example) the game replaces whati typed with /321and nothing plays.

Hi alex,

I think replacing the original taunts 1-105 requires amending the bnk file. But I’m not sure why the subscribed ones aren’t working, anyone else?