Multiplayer freezes then fast forwards to be synchronous again

Think you both for your advice!

RAM is installed correctly, the setup also works flawlessly for much more demanding games such as Anno1800. I checked background apps, none of them behave weirdly when the freezes happen.

I will check the replays after the next attempt :slight_smile:

Do you have any idea what could be behind the freezes? I first thought it could be something in the graphic card drivers, but single player works perfectly. What happens behind the scene in a multiplayer game that could have those impacts if it’s not the connection speed itself?

Best & thank you so much already for your help!

I think you may need to do a debug report. Sorry

Exact same issue here. The game is basically unplayable! It’s okay in the beginning, but once castle age hits I am stuck with horrible game play. It slows, speeds up (catches up) every few seconds when in combat.

CPU 3800x
GPU 6700XT

Any help is appreciated

It started when I upgraded my GPU to the 6700XT

Interesting! I now also sent a bug report to the support team, unfortunately they only referred me to the standard trouble shooting pages. As we have the same graphics card, this might really be the issue?

I also tried all different types of graphics settings in the AMD Adrenaline suite, but nothing seemed to help :frowning:

Sounds a little like an old issue noted here, if I’m not mistaken. I’ll link you to one of my posts there, but feel free to read up or down from there.

  • I think someone found a correlation with all the actions the AI were throwing at the game (a lot!) as a contributing factor to the old issue back then. And in mid- and late-game it’d get worse because there are more units and actions going on. Not sure if that would be the case now, as I thought that got resolved in a patch, but wanted to mention.

You probably already have the latest drivers for your vid card (if not, maybe try)… but a few other things to try based on comments in that old thread I linked to, which might be easier to try than updating drivers:

  • First off, do you set up your games via the “Single Player” button on the main menu, or the “Multi-player” button? If it is just you playing vs. AI (no human teammates or opponents), then try using the “Single Player” button instead of the “Multi-player” one, if you don’t already. (Using the “Multi-player” button makes the game go through a server, etc., which may be introducing the issue. So, if it’s just you vs. AI, try using just “Single Player” button and see if that works; as you can set up a lobby there to be you vs. AI that way.)
  • Reset your router to get a new IP address
    • Not exactly sure how best to do this… but I think this is one way. Feel free to Google/Bing search for yourself:
      • Hit Windows Key and R together. Type “cmd” and hit OK. At command prompt, type:
        • ipconfig /release and press Enter
      • Next, type:
        • ipconfig /renew and press Enter
      • Wait until the DHCP server assigns a new IP address to you
  • Try changing graphics settings to anything below “High” (to like Medium or lower). It fixed the issue for some players back then

Disclaimer: I make no guarantees :slight_smile: The above worked for some, but not all.

I know these would just be band-aid solutions, and that was a lot of words, but just trying to help get you issue-free. If any of these work, or something else you do works, I’d be curious to know what

Also, at the very end of that old thread, GMEvangelos locked the thread and posted this:

Good luck!

Maybe see if any of my words above help? And if not, take a look at GMEvangelos’ post I linked to, and if you’re saying you did that, they emailed you back and just referred you to the troubleshooting pages, maybe point them to the long thread I gave above, give your dxdiag info, and point them to GMEvangelos’ post, too – so they have some context and GMEvangelos’ words about how they might want to use an escalation path to reach the devs. Just an idea

I also have a 6700XT and suffer from this (only in multiplayer). There must be something related to the AMD driver indeed…

Hi Kptainlgloo!

It seems to really be the graphics card. Would be great if you could also request a support ticket - Maybe we can get a reply from the dev team if we all try together.

Not sure if the dev team also reads this forum here?


My fix: I installed my old NVidia 1030 ($90 card) in my computer as well and I just switch cards when I want to play AOEII.

Quite sad the $90 card beats out a $750 one, but I have smooth game play with my NVidia card.

You could do thesame. Hope that helps!

That confirms that it’s the graphics card, but I really hope we find a better solution than to installing old cards again :frowning:

Done… let’s hope we’ll get some visibility!

Did you link them to this thread, too, so they can see the collection of examples? The likelihood of this thread getting much visibility by devs here in the ‘Ask for Help’ area ether, otherwise, is very low.

I’d, personally, make a bug report in the bug report area, with the graphics card in title, and link to this thread with these issue examples of same graphics card. It may attract more examples, but also be a more official log of sorts

Listing out what troubleshooting steps you’ve already tried normally helps devs, too, if not mentioned before

1 Like

Did you guys have any success (apart from installing old GPUs)?

I got another advice to disable AMDFreeSync, which however didn’t help at all…

no progress. I had the same advice as you, but it did not help.
Now I am back to standard troubleshooting, w hich does not help AT ALL.
Even if I drop quality to low, it will still be laggy as hell. So disappointing.

Hello everyone !
First of all : please be kind with my english it’s not my native language :smiley:

I have the same problem.
When I’m playing online I’ve some freeze. At the beginning of the game it happens rarely and it freeze for 2sec but more I advance in the game more the freezes happens and it become longer.
Everytime the game is making faster to comeback live.
Sometimes the freezes are so frequent that i’m chaining freezing.
Here is my config :

CPU : AMD Ryzen 7 3700X 3,59GHz
RAM : 32Go
GPU : Nvidia RTX2070 Super

I installed the game on my SSD but it doesn’t change anything.
I hope we’ll find a issue.

Hi everyone,

Tech Support emailed me that they pushed an Update that should solve “most of the exiting problems” - did it help in your cases?

@Tiortas: Interesting that you have the same issue with a Nvidia GPU, so far we thought its an AMD only issue


Hi, I have the same problem and i think that for some reason it’s a network problem (at least in my case)

  1. I use LTE router for Internet connection in my home.
  2. I have played last time in semptember 2020. It worked fine.
  3. I have a new notebook now. Ryzen 7 4800H with Radeon integrated + nvidia geforce GTX 1650. It’s a big upgrade from my previous notebook.
  4. I have tried playing now, but I have 10 seconds freeze every 10-30 seconds only in multiplayer games, even when it’s 1 player multiplayer game (with no AI or other players). I have 35-55 ping to the server. Singleplayer games work fine.
  5. I have tried disabling antivirus, firewall, router firewall, in game v-sync, graphic card v-sync, all mods. Nothing worked. UPNP on my router is enabled.
  6. I have taken notebook to my workplace with fiber connection, it worked fine.
  7. I have tried using my phone LTE hotspot, it worked fine. My phone and router use different LTE providers, but has similar download speed and ping.

I have no idea why using my LTE router causes LAG now, when i had played on it in september and it worked fine on worse notebook.

I have this same kind of error in my system. I have a high-end gaming pc and a high-end gaming laptop. I’ve noticed it happens most consistently on my gaming PC which has an AMD RX 6800. I have tried just about everything I can think of. It mostly occurs if I am playing online with multiple friends and we have 3-4 AI players on Hardest or Extreme. Has anyone had any luck with resolving this issue? As you get futher in the game the lag gets worse. Very frustrating.

1 Like

I have this error as well. Decent gaming PC. AMD 5800X, AMD 6700XT, and 16GB of RAM. It will start micro stutters a couple minutes into a game. Then as time goes on the stutters turn into freezing until it becomes unplayable. When playing multiplayer the commands I use are lagged behind everyone else playing and I won’t see them complete the commands for minutes. It has got to the point they finished the game and killed the last AI, 15 minutes later my game finally said we had won. We were sitting in the same room. I have metrics overlay on in Radeon. When it is lagging my GPU utilization drops to 0. When it is running fine I hit maybe 13-27% utilization.


I bought the two DLCs (Lords of the West, Dawn of the Dukes) yesterday, after which I started experiencing similar freezing (and subsequent fast forwarding). However, I also experienced it in the campaigns (Joan of Arc, second mission). So I’m not sure if it’s a network problem?

It’s weird, because before I bought the DLCs I did not have those freezes at all (or if I have, at most rarely). Now, almost every game, campaign or multiplayer with same mods installed, I have them very frequently and as the game progresses it gets worse. It hasn’t gotten to the point where it continuously freezes and fast forwards, I’d say the worst I’ve had is around every 1-2 minutes.

I tried reinstalling the DLCs only on Steam (by unticking and ticking the DLCs), and then a complete reinstall of the game (by uninstalling and then installing the entire game). Because I started experiencing them only after buying the DLCs, I don’t think it’s either a mod, network, or hardware problem, but if needed, my computer specs are i5-6600 @ 3.30GHz, 16GB RAM, NVidia GeForce GTX 970. T

he drivers should also be up to date, and I also tried to update my mods, but because I had no problems with them before, I’m not sure if they are at fault (playing on non-DLC civs also freeze right now).

Hopefully anyone can help, or maybe this was of help!