Multiplayer game becomes unplayable (rubber-banding, input latency, etc)

@yooupiman, @AceKING132015, @SpacyPainter872, @NUMETKO, @Sertay, @HuHot4661, the forum wouldn’t let me include you in the last post, so letting you know here, that the issue might be resolved with the patch that just came out within the past day or two. I, personally, still need to test. Please see my post directly above.

1 Like

I believe it has been resolved the patch before that, as noted in the patch notes:



  • Units no longer stutter-step when chasing other units.

For me, this continuous unit command refresh was the culprit. It wasn’t just when chasing, but every ‘attack move’ or ‘patrol’ by the AI was refreshed. I could see the militia do the shuffle from miles away on recordings.

1 Like

Interesting. A couple players above your post said they were still having the issue… and their posts were after that patch. I hope to try an MP game myself soon to test it out

Still having the issues.
2 Real players against 6 bots on black forest map. When we reach castle age, the game only for player who hosts this game become unplayable, like 6 -15 FPS + freezing and then fast rolling. Standart game vs bots works fine. Multiplayer vs real players works fine too. Only vs AI’s game become laggy. Any ideas?


Welcome to the forums, LosingAxis0! I’m afraid I don’t know the answer. Hopefully developers will see this thread and be able to implement fixes. If you have mods enabled, I guess you could maybe try to disable them and see if that helps… but aside from that, if that doesn’t fix, then I think the game would just need to be fixed by devs somehow.

UPDATE: In finding other threads talking about this issue, I’ve seen one player commenting that changing graphics settings to anything below “High” (to like Medium or lower) seemed to fix the problem for them. A different player commented that resetting their router (getting a new IP, etc.) fixed the issue for them but not others. I don’t know how many people these band-aid solutions might help, but figured I’d post it here, just in case.

Also, I was hosting the game when I had the issue, too. My teammate wasn’t really having the issue when I was; or not nearly as bad if he was. But after I dropped, my teammate started having issues (as he became the host at that point, right?), and he eventually had to drop, too, because the lag got so bad. So, being the host may be a component to this issue… as I’ve seen a few people surmising that, too.

It’s even pinned (by a developer, someone said) over on the Steam forum -

Curious it isn’t pinned here on the official AoE2:DE forum, unless I’m missing it :confused: And I’m not seeing it in the tracked issue list either:

Freezing. Freezing. Freezing.

I thought this was only an issue with the previous HD version. I was wrong and this issue still occurs even in the new definitive edtion.

I have a computer with very high specs. My online multiplayer experience with AOE2 DEF is garbage because the game constantly freezes every 5-10 seconds for 2-3 seconds.

The game freezes and lags then everything quickly speeds up on the screen to catch up.

Computer specs:

i9-9900k 3.6Ghz
64GB DDR4 Corsair RAM 3600
SSD M.2 Hard drive 2TB
2080-TI Graphics card

The entire system was around $7000USD at the time of purchasing.

Why on earth would this game require any higher specs than these?

I get 1370~ on the RANKED TEST. The RANKED TEST does NOT lag.

The game lags when I go online.

My internet connection is stable.

This is serious issue with this game and no one cares. I am absolutely astonished that Microsoft made this game because it feels like it was made by a small start up company.

While writing this I am extremely upset about everything obviously - I am praying that someone can help me fix this issue.

The game is unplayable. It is unplayable like this!!!


Only this game lags on your net?

I had this same issue until the may update. Since then I didn’t have the oportunity of playing much ranked 'cus guess what: more crashes! I see how they fixed the 5 min crash: you don’t crash at 5min if you crash ON THE LOBBY/LOADING SCREEN.

I have other friends reporting the very same issue. It’s so frustrating. I’ve lost so many important battles because of this issue, especially those who require you to micromanage your army. I am very upset because I don’t remember this happening on HD besides heavy lagging due to connection/low specs PCs.

The thing that makes me more impressed is that, yes, Microsoft released this. Probably the biggest computing company in the world can’t even make its own competitive game stable for once! Since DE came out I’ve been playing on a DAILY BASIS, literally almost every day, but now I trully consider leaving DE because every update the game comes with a brand new unplayable bug.

1 Like

It’s nice to know I am not the only person that shares these frustrations. The game is extremely clunky and it doens’t matter if you have a $2000 or $10000 PC, the game will likely not run well.

The ranked test gives me 1370 and runs smoothly. Playing online = I get these freezes.

Microing is near impossible when this happens.

My other friends dont’ get the issue so they don’t know why it’s happening for me…

I guess no mods or developers are on this forum are they?


They tend to read, but dont really actively posts.

Well, what a waste of money they are. No action towards fixing the lag issues with the game. My game went down to 5 fps today and lagged immensely It’s unplayable. WHAT CAN I DO? It’s unplayable.
I literally bought this new PC hoping it would fix the issues I had on the last computer, and they are the same. I am so sick of this game. So sick of it.

Hi , i dont know it there is the place to ask that buy anyway . I cant run the game becouse it crash at second whit the error “ATL RADERON HD 4300/4500 SERIES GPU whit vendor id 4098 and device ID 38223 is not DirectX 11 compilant”. If someone can help me o tell me where i can ask about ,i really need it.

PD: Sorry for my english

Since Hotfix, After joining, the game freezes for me at 8-12 mins, or other players disconnected in this time

There are 3 issues -

  1. Either me, or another player is stuck at the loading screen forever
  2. After joining, the game freezes for me at 8-12 mins, or other players disconnected in this timeframe
  3. I cannot join the game at all

These three started happening after the hotfix

The issue noted in OP sounds a lot like this issue that has lingered a long while:

Someone in a different thread mentioned they fixed it by resetting (their) router. So new IP etc.. That sounds like a band-aid workaround that may work for a few players, but I feel the game has some deeper issue somewhere that needs fixing by devs since so many people have this issue.

HI, yes I have reset my router several times. I have not seen any devs on this forum… Quite disappointing the level of support. To be honest I don’t think Microsoft are behind this game I think they gave it out to a small 3rd party firm.

Hello all,

I am playing on the latest build.

Today when trying to play multiplayer matches I have had continous freezes starting from the very beginning of the games that last up to 2-3 seconds. After which the game will quickly “catch up” and speed up everything that happened to be in sync again. However it will happen again quickly after and so on.

I have stable internet, a monster of a PC and never had these issues before. I have over 100 hours in AOE2:DE and never had this issue. What could possibly cause this?

My mate who is with me in the same game does not have this problem. He tells me my connection symbol is constantly Blue so there shouldn’t be any issues. In Singleplayer I do not have this issue. I verified integrity of my game files as well. The problem appears in regular ranked matchmaking. Wether 2v2, 3v3 or 4v4 doesn’t seem to matter, the problem exists in all these cases.

My commands are registered and I see them being carried out after the delay is over (and in sped up fashion because of the freeze), but they do not “get lost”.

1 Like

thought maybe the server problem ,i got this issue too after the last path

I have the same issue


As you can see no one even bothered to respond to your post

I have the same issue. clearly I am not the only one.

Microsoft is absolutely dropping the ball here. Why are they IGNORING their customers? Scam?

I fixed it by resetting my router. So new IP etc… Not sure if that works for you.

1 Like

Doesn’t seem to make a difference for my router, I even turned on QOS. Game is extremely laggy.