Multiplayer game becomes unplayable (rubber-banding, input latency, etc)

I have the exact same problem where the games freezes and catches up since the last patch, I can scroll around the map but not do any actions. :neutral_face:

Sounds a lot like this bug reported a while back:

Hi guys,

Been trying to rack my brain over this one and I’ve come up empty. Any support would be appreciated.

Firstly I want to preface that my graphics card runs single player perfectly fine with Ultra graphics enabled and max resolution. However, as soon as I enter a multiplayer game, my game stutters beyond belief. It doesn’t really feel like an FPS thing as the graphics card seems to cope fine between the stuttering. Sometimes it takes ages for for any input to engage - e.g. I will Q to queue a village and it will take the game 5 seconds to actually start the queue time. This stuttering usually gets worse until the game seems to “de-sync” from everyone else and and then will just freeze, forcing me to resign or quit the game.

I feel awful because the only way I can test if any change I make actually works is by joining a public match with out people. Please can someone help me out. My ping is fair for the most part paired with my local server and I pass the benchmark test always over 1150 or so.

Thanks so much in advance!

1 Like

Game Version:

  • Build: replaceme
  • Platform: Steam or Microsoft Store
  • Operating System: Windows 10 or Windows 7 or Mac or Linux
  • Gamertag: replaceme


Was clicking on villagers to build or go somewhere, It would take at least 30 seconds before they would do what i wanted them to do.

Reproduction Steps:

Here’s how to reproduce the problem:

  1. (List the steps we can take to reproduce the bug ourselves…)



1 Like

If you’re on Steam, verify integrity of game files, and restart your PC.

This bug’s probably happening due to your game files being corrupted or damaged. Or because there’s something wrong with your PC.

A friend and I are having the exact same problem. It happens later in the game. We are playing in a private lobby. We’ve both verified our files and neither showed any issues. There are no PC issues with either computer. I’ve recently run memtest over night with 0 errors and haven’t had a single issue. This happens almost every game we have to one or the other of us. Neither of us have any mods installed.
@SlenderBadger98 any other suggestions?

1 Like

Not really. I wish I could do something other than keep encouraging you to post updates on the topic if that’s the case. Thanks for your own experience. If more than one person has the issue, then it’s probably something wrong with the game and not the PCs they are run on.

Units not following your command is a game age bug. If you read the patch notes for the age of kings, there is written this

Microsoft Age of Empires II: The Age of Kings2.0a Readme File
August 2000
Unit Ignoring Orders Bug - Units no longer ignore orders under some circumstances.

Still not properly fixed.

Also there is this note

Limited Pauses - The total number of pauses available to each player in a multiplayer game is now limited. The total number of pauses remaining is displayed each time the game is paused.

Is this still the case?? You definitely don’t see a total number of pauses.

1 Like

I’m confused by your response here. You are quoting patch notes from August 2000. That was 20 years ago, and not even the same game.

1 Like

Just wanted to point out that it was an old bug and perhaps it is the engine core coding the problem.

1 Like

i had this issue. had to restore to an earlier version of window and uninstall steam + AOE2DE. reinstall everything worked fine after that.

issued I faced were multiple including yours.

  1. after 1-2 minutes, all units stop responding, then scrolling stop moving.
  2. after 5-10 minutes or longer, extreme delay latency only in multiplayer games from 2-3 seconds for unit to respond and gets worse as game goes by up to 30 seconds for unit to respond.
  3. sometimes game does not freeze like above, but unit does not respond while scrolling isn’t locked, the UI will get stuck on the last unit you click on and clicking on anything else no longer shows the UI, the resources counter stop going up even though there are resources there accumulating.

I’ve found that if I put my Graphics on “High”, I soon get this problem, where units become increasingly sluggish in their response - I right-click for them to move, for example, and a few seconds pass before they begin to obey. Otherwise performance is fine - I can still scroll around, see the right-click “move” animation playing when I click, etc, as usual. But the units’ delay in responding quickly gets longer and longer until it’s 30s and you just can’t play the game like that.

If I turn my Graphics back to “Medium” or moderate or whatever it is below High, then no problem!

1 Like

Sounds to me like you’re experiencing this bug reported here - Multiplayer game command lags delays

Try playing against a different version of the AI(like the HD AI). Also read through that thread for more information.

the points 1-3 I listed is in multiplayer mode against AI and I get the heavy delay. it was the game with corrupt window files. restore to an earlier window fixed it for me. each player may have different issue tho.

Sounds like this same issue reported back in Dec '19:

Yeah, I’m finding lots of separate threads reporting the issue. The thread I point to above dates back to Dec '19, so it has at least been an issue since then, it seems

Game Version: 101.101.35209.0

  • Build: 4667120)
  • Platform: Steam

Tentative Fix:

enabling V-sync, only works if game is quit, doesn’t take effect in-game during match via options.
This made a difference when trying two difference games, 3v3 populated with AI. Will try again with friends to see if this takes effect.


While playing a 3v3 multiplayer (3 players vs 3 Moderate AI) on a Normal sized map a delay starts to appear between command clicks and actions being taken. Timed with a stopwatch as roughly 30 seconds by the 10min (game time 1.7x) mark, increasing to 8 minutes by the 56min (game time) mark.

During this issue units may be seen to move in slow-motion occasionally, the clock icon next to player names in the scores is blue 90% of the time, and notably the units do not unfreeze and speed up. Other players may not experience any delay/lag. Issue MAY be linked to which player created the lobby.
Game does not drop, quit, fully freeze, or disconnect.

Reproduction Steps:

  1. Have V-Sync disabled?
  2. Create private multiplayer game on eastus server (nearest).
  3. populate with 3v3 (tried with just me and rest AI, problem persisted).
  4. play game and watch in dismay as your commands are increasingly delayed.
  5. weep over your villager that fell to a boar.



Win 10 10.0.18363 Build 18363
Asus Zenbook UX433FA
CPU: i7-8565U
Graphics: Intel UHD Graphics 620

AoE2 DE Settings:

V-sync off, all left-panel unchecked,
particles low, all right panel unchecked.
Benchmark: 1059.3

I created this Issue because although some posts seemed related the titles did not align with the keywords I naturally thought to search.

Related Posts:

The game has connection lag after a few minutes into the match, unlags, then freezes and disconnects in multiplayer

Online Game Speed Bug


And another thing:

Hitting F11 twice will bring up an overlay that shows FPS, Game time (and delay) and Ping.

T=xxx(+y) where xxx is in-game seconds and y appears to be your delay to game time.
L=xxx ms (a|b|c|d) where xxx is your ping, and abcd are your (?) deviation from L (current, avg, max, min)?
Looks something like that, those who know for sure please confirm how to interpret.

I’m adding this screenshot for information (aka, no it’s not the ping). As you can see in a relatively short time the in-game delay has accrued quite a lot already. This is enough for approx 15s delay between click and action (seems to be subject to the 1.7x scale).


I never had any issues playing before in 2019 or early january 2020, but I gave this game a couple of weeks to play some other games and I came back around feb 25th.
I tried playing a multiplayer 1v1 agains AI and got some random freezes and delay between commands which I found odd, since I would be the host and it was against AI, but the delay between commands wasn’t that bad.
Today I tried a couple more games against AI on multiplayer and I had like 5-10 minutes delay between commands, like WTF?
Even in dark age, I was trying to hunt some deer and my villagers cleared all of the deer without a mill. Later they came back and build 3 mills. I tried to pause the game and it showed “9 out of 10 pauses left” but it didn’t pause. I “played” for 5 more minutes and then it paused.
I really need help with this. Single player is normal



whenever my friend and me are playing a multiplayer game and one of us is hosting the game, we experience extreme lag. You click something and it takes minutes to react to it. We’re sitting next to each other and one sees the game 5 minutes ahead of the other one. Our PC’s stats shouldn’t be the problem, neither the internet connection, but whenever we join any other multiplayer game hosted by an other player, it’s fine.

Has anybody else experienced this? I would be grateful for any piece of advice or solutions!


I’ve played another match today 1v1 against AI on multiplayer to watch the replay trying to get some answers…
It was all good, barely any delay between commands until at some point some of the AI villagers started being idle, and it was starting to pile up some delay. Then AI tried to send all the idle villagers to the same tree and they were all just bumping. I watched with AI point of view and it was cycling between 10 villagers trying to give them commands to chop/move and after that the game was unplayable with over 10 minutes delay between commands.
I had a couple of eagle scouts around and they were killing AI villagers under TC and the AI couldn’t even garisson. It was stuck in a loop or something. My 2 eagles cleared the base poking with 4 attack each vill until I left the game after almost one hour.
I’ll try again with HD and classic AI to see if this problem persists

HD version was the same or perhaps worse. Countless minutes between commands
CD version was much better, but still had some hiccups. Got something like 5 sec delay at some point, that reverted to 0 delay, but still playable. Maybe it was just a coincidence, or it was because CD version AI doesn’t make a lot of villagers