Multiplayer games freezes on Xbox

:arrow_forward: GAME INFORMATION
:point_down: These details are CRITICAL; DO NOT skip them or your issue may not be reviewed.

GAME BUILD #: 101.102.42336

  • **GAME PLATFORM: Xbox
  • **OPERATING SYSTEM: Xbox series X

:arrow_forward: ISSUE EXPERIENCED

:point_down: *DESCRIBE THE ISSUE IN DETAIL (below).

Multiplayer game freezes nearly every game after the latest patch. The music keeps going, but the screen gets stuck and you can do nothing but close the game. We’ve played Only black forest and we’ve had the same issue in all of our games.

:arrow_forward: FREQUENCY OF ISSUE

:point_down: How often does the issue occur? CHOSE ONE; DELETE THE REST!

  • 100% of the time / matches I play (ALWAYS)

:arrow_forward: REPRODUCTION STEPS

:point_down: List CLEAR and DETAILED STEPS we can take to reproduce the issue ourselves… Be descriptive!

Here’s the steps to reproduce the issue:

  1. Play the game on xbox
  2. Map black forest
  3. 2vs2 against AI bots

:arrow_forward: EXPECTED RESULT

:point_down: What was SUPPOSED to happen if the bug you encountered were not present?

:arrow_forward: IMAGE

:point_down: ALWAYS attach a PICTURE (.jpg, .png, .gif) or VIDEO (.mp4, YouTube link) that highlights the problem.

:arrow_forward: GAME FILES (SAVE / RECORDING)

:point_down: Attach a SAVE GAME (.aoe2spgame) or GAME RECORDING (.aoe2record) of the match where you encountered the issue. Link it below if using an external file service.

1 Like

I’m experiencing exactly the same issues today, both on my Xbox series X and S.

Every multiplayer online game freezes around 15 minutes of gameplay.

Also offline multiplayer against bots gives the same freezing issue

2 Likes

I am also experiencing similar issues today:
Platforms XBOX One and XBOX Series S
Two multiplayer games hanged about 30 minutes in, one was a 2v2 death match other games was a co-op campaign.

3 Likes

Has anyone figured out how to fix it? I’ve tried resetting to factory settings/uninstall and reinstalling but still having the same problem (Xbox). Ever since it the update it’s been doing it. Anyone else feel like that?

3 Likes

No, I also re-installed the game, but the freezing persisted.
I think we need to wait for the Dev team to fix this and provide a patch/update again.

1 Like

Teammate has also be struggling with this 3/15/24 and 3/16/24

5-6 games where he has been froze after a few minutes

1 Like

I’ve just submitted a request and reported the problem on:
https://support.ageofempires.com/hc/en-us/requests/new?ticket_form_id=360001706471

Perhaps you could do the same and help speed up the fix.

Thanks!

Have reported and submitted a request. Hopefully it helps. Thank you

1 Like

At 11:10 Amsterdam time I received below e-mail response from the AOE support team.

Hi there,

Thank you for your message and for your report. I will inform my Team regarding your findings. Please keep checking game updates for fixes.

Thanks again for contacting us.

Sincerely,
Age of Empires Support

1 Like

At 8:14pm I received this

Hello there,

It sounds like you may need to reset your Xbox console.

  1. Uninstall the game. Hold the power button on the front of your console for 5-8 seconds until the console shuts down instantly.

  2. Unplug all cables and wait five minutes.

  3. Reconnect all cables and restart your console.

  4. Re-install the game to your main drive if you are using an external HDD.

Let me know if it helps.

Regards,

Age of Empires Support

I’ve replied saying that I’ve done that already and hopefully I’ll get something back

2 Likes

Do you still have issues with multiplayer on console?

Yes, it doesn’t work. That happened to me right now in a rapid game at 27:42.

Hello Felizon,

No unfortunately I still experience the same freezing problem.

I just played a ranked 3vs3 game on Black Forest.

My screen completely froze af 13:57 mins into the game. The game music continues but for the rest nothing is functioning.

I had to exit the game by going to Xbox home screen, shut down the game and restart AoE 2 again.
But the multiplayer game is ofcourse over and 3vs2 now.

I’m playing the game on both Series X and S consoles.
The AoE 2 version is 101.102.42346.0 (#107882).

I haven’t heard back from AoE support by e-mail since last sunday march 17th.
Also my game didn’t need an update download this past week. So status quo basically.

Thanks in advance for your support.
Best regards,

1 Like

Same here, game freezes. And as I play with keyboard and mouse on Xbox, in every single game I try I lose suddenly all the keys from keyboard except ESC(menu) and ENTER(Chat). I can’t select some of the buildings with clicking with mouse or to assign villagers to do anything. If I for example try to put them mine gold, they just walk there even though I click the resource.

It’s kinda weird they messed up the whole game for Xbox community, but they don’t bother answer. Feels like they really appreciate Xbox players :smirk:

1 Like

We’re investigating the issue but it’s not being easy to reproduce. All the info that you can give me could help to track the root of the issue, things like if you are playing using wifi or ethernet cable, your ISP, the exact moment the issue happens or if it would possible to record a video. Sorry for the inconveniences.

1 Like

Its not a WiFi or console issue as it’s happening on multiple consoles and not does not happen in other games.
There needs to be another update to remedy whatever has caused this since the update in mid March 2024.
An acknowledgement from the developers would be nice instead of a automated response.

Lastly it’s happening in campaigns or skirmish matches - not just in multiplayer

2 Likes

It happens in 100% of the multiplayer games at random time between minutes 15 to 30, my isp is fastweb, i play with cabled connection, tried wireless and it’s the same.
The problem started Friday 15 march evening.
Video Is not needed, the screen interface Is normal but freezed, you can do nothing, only close the game.
The bugs with keyboard and mouse , explained by other user, come out only with mod installed.

1 Like

So you are saying that if I have small trees mod installed it messes up the mouse and keyboard?

1 Like

Hello Felizon,

Thank you.

My ISP is the fastest internet provider of the Netherlands (optical fiber) and my Series X has a cabled connection.

Since half march 100% of my online and offline multiplayer matches freeze between 12 and 15 minutes into a game. Music keeps running but the rest is not working, no possibility to resign, quit etc.

Since the latest update I also cannot see the unit build count in the building wheel. (i.e. how many villagers are being built by a TC when you open the TC wheel with your right controller trigger.

1 Like

It happens me now the same situation in a “learn the game” match , the offline mode…
Freezed at 4:50.