Multiplayer UI Crashing Mid-Game

Game Version:

  • Build: 101.101.36903.0494835
  • Platform: Steam
  • Operating System: Windows 10
  • Gamertag: Chaisky


My UI has crashed 3 times in the last 10 games I have played. I am unable to click any buttons or chat. I am not using any mods. I am using the new ‘grid’ mode. Game continues to play, opponents do not experience issue.

Possibly unrelated but chat is very delayed, and the loading screen does not consistently load up opponents details.

Reproduction Steps:

No trigger identified. Has occurred after a few minutes in to later on in the game.

  1. (List the steps we can take to reproduce the bug ourselves…)
    Watch my recs?

I also have this issue with build 101.101.36903.0 494835
I am on Steam using win10 OS

I am using Small Trees, Advanced Idle Pointer, Zetnus Improved Grid Mod No Snow Version, No Stumps, No more plants, and Fish Borders.

Game did not load the names or civs in the loading screen, or the names in game. After about 30 seconds, my ui froze and I couldn’t move my screen or select anything, nor resign from the game.

Just to update, this is still happening occasionally. As you can see, population from build houses has not updates either.

Additionally, opponent names did not load on this occasion. Screenshot attached.

Build 101.101.36906.0 4941835

Same thing happening to me on Windows 10 in a ranked game. After 10s in the game nothing works anymore. Chat, hotkeys, mouse can’t select anything. It worked fine 4 hours ago, but now 2 games in a row the game froze. I am not using any mods.
Before this game chat has been very slow. It takes up to 1 min to write what i wrote.
The game freezes on occasion and then it catches up with really fast moving units(usually when someone surrenders).

This seems to be a common bug, but they haven’t acknowledged it. I’m keep a list of threads regarding it here that you can look at (no solutions yet from what I’ve seen): In-game UI freezes, then later inputs freeze too

I’ll add this thread to the list.

I’ve deleted and reinstalled the game and in ranked games UI still crashes.

Same just happened for me. In a middle of battle.

prob some files corrupted. I have had this issue and I reinstalled AOE2DE and steam and that fixed it.