My options settings reset to default after exiting game

All of my game settings are not persistent, every time I restart the game all items related to options are reset to default:
Graphics, game options, UI options, sound, accessibility, hotkeys, the first run popups about the cultural change and selection of the UI type, historical battles, campaign and Art of War progress.

I had the same behaviour when I was playing the beta.
I own all AgeDE on steam and this is the only one that has this problem.

Similar issue as this post, but from aoe2de: Settings reset after restart, medals from campaigns not saved

2 Likes

I have the EXACTLY same problem. So far it made my experience with the game terrible.

1 Like

I have same issue and I post the report here I STILL CANT SAVE GAME SETTING PLS HELP
give it a like if your issue has not been solved yet

2 Likes

I tried several things so far without any success. I cannot use this product without personal hotkeys. I am frustrated and I really want more ideas from support. So far all that I could get was: “Install new update and test again”. I tried almost everything and I am willing to test any new ideas.

I will contact support by email again and see if I can get further help. It seems a very particular kind of problem affecting only a few players.

1 Like

After all this time the issue still persists.
I found out this new information: Hotkeys reset everytime - ESOCommunity

It seems that on this folder (C:\Users{USERNAME}\Games\Age of Empires 3 DE{ID}\Users) the game creates these files Newprofile, Lastprofile.dat and stats.edat every time we start the game, re-writing our previous data.

I still didn’t found a solution.

After all this time I found how to fix it.
So it seems that the User Name of Windows cannot have special characters.

Steps to FIX:
→ press WINDOWS KEY + R to open the execute prompt
→ type netplwiz and press enter
→ double click your account
→ check if your user name has any special characters. If so, remove them and restart your machine.

Walkthrough with pictures, Method 2 of this solution:
How to Change Your Account Name on Windows 10.

2 Likes

This still should NOT be a thing !
The game has to be able to manage the user name, even with the special chars.

2 Likes

Yes, this is a critical issue that renders the game essentially nonfunctional and is hard to figure out. Devs definitely need to take a look into it.

I think the biggest problem of this thread is, as soon as one comment is marked as " solution " it gets ignored by the Forum team, to make a ticket.

1 Like

Unfortunately I bring bad news, I don’t know why I talked to soon.
This trick does not always work.

I don’t understand what triggers it but I just had my saves and campaign progression whipped clean, just as of today when I opened the game I had everything reset again.

I double checked the user name, nothing has changed. But it seems that the game cleanses itself after a while, I’m baffled.

I have saved, exited and entered, everything might be set as I left it. But after some minutes out of the game it goes to default again.

1 Like

Man thats terrible D:
Is your game on C drive ? ( Where windows is located ) ?

No I have it in a different drive, windows in “C” (ssd) games in “D” (hdd).

So after three days to be absolutely sure I finally to have it stable.
I have a mix of steps I made which I’m not sure which is the “nail in the coffin” but I really don’t wanna lose progress anymore.

1- User Name of Windows cannot have special characters.

2- Windows user path name also not having special characters and matching with Nº1 (this one is tricky because windows does not change it automatically and we might corrupt the system if we dabble too much in regedit).

3- Steam user name also no special characters (I doubt this one a bit but when I have courage I will try to change it).

4- After 1 and 2 → Uninstall COMPLETELY (clean references of AOE in regedit and delete the user saves folder eg: C:\Users{username}\Games\Age of Empires 3 DE)

5- Restart computer

6- Install and profit

I really had a bad experience with all this with so much trouble for things that shoudn’t be an issue and struggling since Oct 2020, I would have given up but fortunately or unfortunately I love AoE3 too much since childhood.

1 Like

I tried all of your steps BUT I didn’t change my steam name (which had the special character “&”).

I believe that it might be the issue here. HOWEVER, I am kind of fed up with this nonsense. I want to play the game but so far this absurd bug makes impossible for me.

BTW, I lost all of my avatars in this process of deleting everything and reinstalling. To my surprise, avatars are connected to my profile user written un my computer, not my xbox account. Oh… And I lost all of my USA challenge progress. I am still waiting for an answer from the Devs regarding it.