No puedo descargar la nueva versión de AoE DE

Hará cosa de dos meses salió la nueva versión del juego; tras eso, instalé la versión 1903 de windows siguiendo todos los pasos que disteis y pude empezar a jugar con los jugadores de Steam. Sin embargo, el otro día AoE DE dejó de funcionar y tuve que desinstalarlo y volverlo a descargar, pero la versión anterior, que, en la tienda de Microsoft, se identifica por tener el logo en blanco y negro, cosa que encontré en mi biblioteca. Al buscarlo manualmente, encuentro la “nueva” versión, pero al darle a descargar, la instalación se “completa” en pocos segundos y el juego no aparece. No entiendo por qué la Microsoft Store genera tantos errores. Por favor, si alguien sabe solucionar esto, que me escriba, gracias

Hey there,

From the description, it sounds like your antivirus or firewall may be preventing the game from downloading from the Microsoft store. Which antivirus/firewall are you using?

Can you please try uninstalling the game, disabling your antivirus/firewall, restart you machine, and then try to re-download the game? Let us know if anything changes for you.

1 Like

I tried to do what you told me to do. I uninstalled Malwarebytes, restarted the PC and tried again to download the game. However, none of that works. When I click “install”, the download is completed in a second but I still can’t really download it. As I said before, I can download the previous version. Thanks for the help.

Out of curiosity, do you still have the old version of the game installed on your machine? A few users have found that they may conflict with install.

No. You see, all this started when I realized that the AoE DE logo didn’t load and looked like a blank document. When I clicked on it to start the game, it wouldn’t load and, after several attempts, I decided to remove the game, which was the new version. After this, I tried to download it, so from the library I accessed the game in question, but his drawing, the logo, appeared in black and white. I installed it and saw that it was the previous version. After deleting it and downloading it a few more times, I decided to access the game’s download menu from the Microsoft store’s search engine. In this case it was the correct version, which looked in color, but there is the problem I mentioned earlier. The old version I have uninstalled and still does not start the download.

Could you try the following?

Sign out from all Xbox apps and sign out from MS store application. Now close the MS store app. Press Ctrl-Alt-Del and choose Task manager. Check for any MS store app running in the background and perform end task. Now open MS store and without signing in choose ‘…’ button and ‘get updates’. Check for and download all updates. Sometimes you need to trigger them manually this way. When finished sign in to MS store app again and go to your library. It should list your purchased products and also gives the option to install them.

1 Like

I’ve tried to do what you say but it doesn’t work. When opening the task manager after closing the microsoft store application, it was not running in the background. I still opened the app again and finished the task when it was open. After checking for updates and logging in, I went to the library and saw that the game was still in black and white, so I searched for it and again, when I clicked install, nothing was downloaded. Thanks anyway.

You could try adding a new user with administrative permissions and connect your MS account to that new local user account. Most times these issues are caused by broken user profile.

Nothing, it’s not working, I’m starting to stress XD

Just to be sure, are you downloading from this version:

That is the link to the AOE II DE store version. He’s talking about AOE I DE.

1 Like

Could you launch PowerShell and post back the result of the following one-liner:
$p = @("Darwin","MSDallas") ; $r= @(); Foreach ($i In $p) { $r += (Get-AppxPackage *$i*) }; $r; Foreach ($i In $r) { Get-ChildItem $i.InstallLocation | Ft}

Now launch PowerShell as administrator and post back the result of this one-liner:
$p = @("Darwin","MSDallas"); $w = "$env:ProgramFiles\WindowsApps"; $l = Get-ChildItem $w; $s = @(); Foreach ($i In $p) { $s += $l | ? { $_.Name -like "Microsoft.$i*"} }; $s}

1 Like

Sorry meant this link:

1 Like

yes, it is the same link that I access to download the game, but happens what I described, in a second the download bar is completed and appears a notification that says it is already installed, but it is not true. I think the Microsoft store is bugged and considers that I only have the previous version and I can not access the new one for some reason.

I’ve tried the first thing and nothing happens. Regarding the second, this message appears:

En línea: 1 Carácter: 173
+ … ach ($i In $p) { $s += $l | ? { $_.Name -like "Microsoft.$i"} }; $s}*
+ ~
Token ‘}’ inesperado en la expresión o la instrucción.
+ CategoryInfo : ParserError: (:slight_smile: [], ParentContainsErrorRecordException
+ FullyQualifiedErrorId : UnexpectedToken

I put the message in italics because otherwise it didn’t look the way it appeared to me.

I think the best thing I can do is buy this game in Steam, because the bugs generated by the Microsoft store are unbearable.

I made a little error in that one. The first checked if one of both AOE DE version were installed at all.

The second one checks you windows apps folder for leftover of previous install. If the folders are still there you might be able to restore that version from cache using another PowerShell command.

I’ve corrected the second one. Please try this snippet again and only by running powershell as administrator you have acces to read files below the windows apps folder.
$p = @("Darwin","MSDallas"); $w = "$($env:ProgramFiles)\WindowsApps"; $p | Foreach-Object { Get-ChildItem $w\Microsoft.$_* }; $p | Foreach-Object { Get-ChildItem $w\Deleted\Microsoft.$_* }

Did you ever read the forums on Steam about issues with installation of their games?
There are no holy men, there is only wololo when something does work.

Usually there’s more going on why it doesn’t work.

1 Like

@PCS70 I’m in the WindowsApps folder, but I don’t know how to find a folder related to Age of Empires. I’ve tried searching and there are no results.
Still I tried to use the PowerShell command you gave me and this is what appeared:

Directorio: C:\Program Files\WindowsApps

Mode LastWriteTime Length Name

d----- 29/08/2019 20:57 Microsoft.Darwin_100.1.28529.0_x64__8wekyb3d8bbwe

That’s very good news! It’s still installed there and it is also the latest cross-play version.

Please launch PowerShell again (no need to run as administrator) and paste the following snippet:
Add-AppxPackage -DisableDevelopmentMode -Register "C:\Program Files\WindowsApps\Microsoft.Darwin_100.1.28529.0_x64__8wekyb3d8bbwe\AppxManifest.xml"

Don’t mind the link format in the text as phone number. The web developer probably forgot to enable the following meta tag which is really handy to use on forums where you don’t want that behavior.
<meta name="format-detection" content="telephone=no">

After PowerShell is done (will be very fast), search for Age of Empires with Cortana search icon and pin to start menu or taskbar again.

1 Like

I pasted the snippet and this is the message that appeared

Add-AppxPackage : No se encuentra la ruta de acceso ‘C:\Program
Files\WindowsApps\Microsoft.Darwin_100.1.28529.0_x64__8wekyb3d8bbwe\AppxManifest.xml’ porque no existe.
En línea: 1 Carácter: 1
+ Add-AppxPackage -DisableDevelopmentMode -Register "C:\Program Files\W …
*+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~*

    • CategoryInfo : ObjectNotFound: (C:\Program File…ppxManifest.xml:String) [Add-AppxPackage], ItemNotFou*
  • ndException*
    • FullyQualifiedErrorId : PathNotFound,Microsoft.Windows.Appx.PackageManager.Commands.AddAppxPackageCommand*

I have italicized the message so that you can see it more or less as I saw it.