Not able to play online

I’ve been enjoying AoE2:DE online with my friends since launch, we almost exclusively play in online private lobbies. But for the past week or so I’ve been unable to play online at all.

I’m able to go into the multiplayer menus, however in the lobby browser it only says searching for games and none appear, although it does show the connections to the different regional servers and I can browse the mods fine. I also can’t create a lobby, the option is permanetly greyed out with a loading indicator next to the lobby name, I can receive invites but not join any of my friends games. A reinstall hasn’t resolved this issue even with all the local game files deleted. And whilst I can play multiplayer on my desktop computer, it just won’t work on my laptop, which is the computer I play mostly as I’m away a lot. I’ve also tried it on various networks and still no luck.

Has anyone else had a similar issue? Or does anyone have any potential fixes?


1 Like

2 other posts on this within the last 5 days. I am guessing it is hot patch related.

I am experiencing the same problem since today.

Hi there! I have a couple of steps for us to try for the trouble loading and creating lobbies.

  1. Double check that “Enable Crossplay” is selected in Options on the Game tab.
  2. Check if you are signed into Xbox Live. If you are not signed in, try doing so. If you are currently signed in, try signing out and then back in.

If there’s still trouble with lobbies, it would be really helpful to post a screenshot so we can look into other troubleshooting steps.

I hope this helps!

1 Like

In this topic someone posted screenshots showing the issue.

Thanks! I’ll post there too.

Have you had a chance to double check the crossplay setting and try signing out and back into Xbox Live?

1 Like

Here is what fixed it for me:

  1. Sign out of XboxLive (upper right corner in the main menu of the game)
  2. Restart the game.
  3. Sign back in to XboxLive

Thank you Dragon.